Zooming by scrolling mouse wheel while holding CTRL key broken

Discussion in 'General Questions' started by bertaka, Nov 13, 2008.

  1. bertaka

    bertaka

    Messages:
    4
    In Microsoft Word, Excel, Visio, etc. you can zoom in and out of a document by holding the CTRL key and scrolling the mouse wheel.

    This no longer works under Parallels 4. I know you can set keyboard key mapping in preferences, but it only works on instantaneous key presses - NOT holding down a key and scrolling the mouse wheel. It simply doesn't work anymore even if I am holding down the correct key (CTRL, not Command).

    Parallels 3 worked fine and was much simpler in how it remapped keys. I understand the new preference window tries to be clever, but it doesn't work for this critical zooming feature anymore.
     
  2. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    Hi,
    Make sure Parallels Tools are installed. Virtual Machine --> Install Parallels Tools.
    If it doesn`t help please, specify the type of the mouse you use, its manufacturer and model.
     
  3. bertaka

    bertaka

    Messages:
    4
    Specifically, I am using Visio 2007 on Windows XP SP2 and using the Logitech VX Nano wireless mouse.
     
  4. smottonen

    smottonen Bit Poster

    Messages:
    4
    Same problem with Outlook 2007 and a (wireless) Mighty Mouse. If I turn off the Mac's preference of Ctrl+wheel for Mac style zooming, the use of Ctrl+wheel in Parallels just scrolls (Ctrl modifier doesn't seem to be passed on to application).
     
  5. gstanford

    gstanford

    Messages:
    2
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  6. John@Parallels

    John@Parallels

    Messages:
    6,343
  7. smottonen

    smottonen Bit Poster

    Messages:
    4
    That doesn't work for Outlook's reading pane where the only way to zoom is Ctrl-Wheel. It works when booted via Boot Camp. It does not work in the VM. Ctrl-Wheel behaves just as Wheel (scrolls, doesn't zoom).
     
  8. bertaka

    bertaka

    Messages:
    4
    Workaround not practical for me

    Thanks for the link to the workaround, but I need the ability to hold down the CTRL key and scroll the wheel to zoom in and out in Visio.

    What is the priority of fixing this bug? Parallels 4 is unusable for me until it is.

    Thanks!
     
  9. John@Parallels

    John@Parallels

    Messages:
    6,343
    Well I tested CTRL+Wheel on smple USB mouse and it is working in every Office application and in IE
    so please check following
    build 3540
    Parallels Tools installation
    No mouse driver is installed inside VM
    Logitech driver is not installed on Mac

    If there are still problems please submit report from Parallels Desktop - Help menu -selecting Report a Problem, and post here report ID
     
  10. smottonen

    smottonen Bit Poster

    Messages:
    4
    Report 22065 has been posted. Parallels build number confirmed. Reinstalled parallels tools and restarted VM. Only mouse that appears in Windows device manager is the parallels mouse synchronization device. Tried a Microsoft USB mouse instead of my normal Apple Mighty Mouse. That did not work either. Still no zooming in either IE or Outlook.
     
  11. Drennyn

    Drennyn

    Messages:
    9
    This sounds like a similar issue John has been helping me with in another thread regarding games not detecting Shift/Option/Control key presses until the key is released. Again, this worked fine in Parallels 3.

    Even though my issue is about keys not being detected, John asked if I had a Logitech mouse installed--which I do. What's going on here? It doesn't seem to matter what mouse is installed...

    In fact, I tried the Control-Scroll combo in IE to zoom in and out...and I can get it work. You know how I did it? There's two ways...

    Option 1: I have to keep tapping Control repeatedly while scrolling w/the mouse wheel--holding it down doesn't work. That tells me that the VM is only "getting" the Control key when I release it...which is the same behavior I'm having in games.

    Option 2: Attach the keyboard directly to the VM by choosing Devices | USB | <Your Keyboard>. If the keyboard is attached directly to the VM, I can hold Control down and use the scroll wheel to zoom flawlessly. If the keyboard is not attached to the VM, I have to keep tapping Control VERY quickly while scrolling to get it to work.

    I have uninstalled/reinstalled Parallels Tools about 5 times already. I've even reset keyboard preferences in Parallels. I've tried using the Generic keyboard profile for my Windows VM. Nothing seems to resolve this issue except attaching my keyboard to the VM.

    This is a bug. Where do we file this?
     
  12. John@Parallels

    John@Parallels

    Messages:
    6,343
    Could you please create ticket in support http://www.parallels.com/support/desktop/request/
     
  13. Drennyn

    Drennyn

    Messages:
    9
    Ticket #646799 created.
     
  14. sguy

    sguy

    Messages:
    3
    I have exactly same problem. Only I could do to zooming is scroll with "tapping".
    I hope this bug to be fixed soon.
     
  15. John@Parallels

    John@Parallels

    Messages:
    6,343
    What are settings on System Preferences TrackPad?
     
  16. sguy

    sguy

    Messages:
    3
    Hi Jhon.

    My trackpad settings is as below.
    ------------------------------------
    TrackPad Gesture
    -Use 2 fingers to scroll - checked
    -Horizontal scroll - checked

    -Zooming with key operation - not checked(I've tried with checked with Ctrl-, but situation was same)

    -Click operation - checked
    -Drag operation - checked
    -Keep dragging - checked

    -Use tapping with two finger to alternate sub-button -checked

    Trakpad option
    -Ignore accidental input for TrakPad- checked
    -Ignore TrackPad when mouse connected - unchecked
    -------------------------------------------------------------------
    (I'm using Japanese version, so item name may different)

    I'm using TrakPad on Macbook which running Mac OS X 10.5.6. not tried yet with mouse.


    Complement for my previous post:
    >Only I could do to zooming is scroll with "tapping".
    What I mean same as Drennyn said. In my case, scrolling with TrackPad by 2 fingers.

    >Option 1: I have to keep tapping Control repeatedly while scrolling w/the mouse wheel

    Thanks for your support.
     
  17. John@Parallels

    John@Parallels

    Messages:
    6,343
  18. smottonen

    smottonen Bit Poster

    Messages:
    4
    The new build 3810 fixed this problem for me.
     
  19. sguy

    sguy

    Messages:
    3
    3810 fixed this problem for me too.

    Thanks!
     

Share This Page