Access not working with Mojave?

Discussion in 'Installation and Configuration' started by joerusz, Sep 25, 2018.

Tags:
  1. joerusz

    joerusz Bit Poster

    Messages:
    12
    I have two computers (one desktop, one laptop) that I upgraded to Mac OS Mojave. I can connect to either machine using Parallels Access and see the display, but neither mouse nor keyboard are functional. Please help!

    Joe
     
  2. RobK3

    RobK3 Bit Poster

    Messages:
    1
    Same here
     
  3. joerusz

    joerusz Bit Poster

    Messages:
    12
    I tried completely uninstalling the parallels agent on both machines and re-installing. Made no difference.
     
  4. NOTaMango

    NOTaMango Bit Poster

    Messages:
    1
    I'm having the same issue.
     
  5. Danil@Parallels

    Danil@Parallels Staff Member

    Messages:
    78
    Hi all! Can you please check if "Parallels Access Agent" is present and enabled in the list of apps on the "Accessibility" page (Apple > "System Preferences > Security and Privacy > Accessibility")? And update this thread with your results. Cheers, Danil
     
  6. joerusz

    joerusz Bit Poster

    Messages:
    12
    Both laptop and desktop have this enabled.

    Joe
     
  7. TracyH1

    TracyH1 Bit Poster

    Messages:
    1
    Exact same issue here. Tried using the Parallels Access removal tool and reinstalled access, but nothing works.
    I verified that Parallels access is listed under accessibility in secirty & privacy in settings.
    Seems like a bug to me.....
     
  8. CarlosG8

    CarlosG8 Bit Poster

    Messages:
    2
    Same here. I've tried connecting for multiple devices and nothing after Mojave update. Older IMac not running Mojave's works fine
     
  9. Ignacio2

    Ignacio2 Bit Poster

    Messages:
    2
    Same here , keyboard and mouse not work
     
  10. Michael@Parallels

    Michael@Parallels Parallels Support

    Messages:
    26
    Hey guys. Please, double check that it's called exactly "Parallels Access Agent" (not just Parallels Access) and that it's enabled (there's a tick to the left).
    If it's really so, click on it, and then on the minus button [-] to remove. Once done, add Parallels Access back:
    1. Restart Mac first
    2. Open Applications in Finder
    3. Right-click on "Parallels Access.app" item
    4. Select "Show Package Contents"
    5. Navigate to Contents > MacOS
    6. Drag'n'drop "Parallels Access Agent.app" to the apps list in the System Preferences > Security & Privacy > Privacy > Accessibility page.
    7. Make sure that "Parallels Access Agent" item appeared in the list with a mark in the checkbox.

    If still no luck, please do the following
    1. Enable detailed logging in Parallels Access on host (Parallels Access > Settings > Use detailed log messages)
    2. Quit Parallels Access (right-click on Parallels Access icon in system menu bar > Quit Parallels Access)
    3. Launch Parallels Access.app from /Applications
    4. Generate Technical Data Report and post here the report ID
     
  11. joerusz

    joerusz Bit Poster

    Messages:
    12
    I followed the drag and drop process, although it was there and checked already.
    Here is the report ID: 277996861

    Joe
     
  12. CarlosG8

    CarlosG8 Bit Poster

    Messages:
    2
    I checked and it is Parallels Access Agent that is enabled. I then went and unchecked it, waiting 5 seconds, and selecting it again. Then Voila! Everything was working again. I hope this helps.

     
  13. Ignacio2

    Ignacio2 Bit Poster

    Messages:
    2
    Thank you very much, this solution worked perfectly for me
     
  14. joerusz

    joerusz Bit Poster

    Messages:
    12
    After restarting, this is now working on my laptop. i put the desktop back to High Sierra as I needed on machine to work. Ill try that when I get a chance to upgrade again to Mojave.

    joe
     
  15. Danil@Parallels

    Danil@Parallels Staff Member

    Messages:
    78
  16. TomM17

    TomM17 Bit Poster

    Messages:
    2
    Unfortunately, following all of the steps has not fixed it for me. Report ID 279567496.
     
  17. Michael@Parallels

    Michael@Parallels Parallels Support

    Messages:
    26
    Hi Tom, did you restart your Mac after removing Parallels Access Agent from Accessibility options and before adding it back again? If not, try to.
     
  18. TomM17

    TomM17 Bit Poster

    Messages:
    2
    Restarting it one more time seems to have done the trick. Thanks.
     
    Last edited: Oct 12, 2018

Share This Page