Cannot enable TPM, TPM option missing from add hardware menu

Discussion in 'Installation and Configuration' started by KarstenS6, Aug 15, 2019.

  1. KarstenS6

    KarstenS6 Bit Poster

    Messages:
    2
    I tried to enable TPM by following the instructions to enable the Trusted Platform Module. The instructions do not work, because there is no "TPM chip" option on the add hardware menu. I see only Network, Printer, Hard Disk, CD/DVD, and Serial Port.

    I am using Parallels Desktop for Mac Pro Edition v15, build 46967. The overview states that it should work in the Pro and Business editions.

    Is there some other step missing from the instructions?

    Thanks,
    -- K

    Screen Shot 2019-08-15 at 03.09.52.png

    Screen Shot 2019-08-15 at 03.10.51.png
     
  2. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    520
    Hi @KarstenS6, please check that your VM is with Windows 10 OS type and installed with EFI.
     
  3. KarstenS6

    KarstenS6 Bit Poster

    Messages:
    2
    Thanks, Dmitry. The BIOS mode is "Legacy", so that appears to be the problem. Is there any way to convert the VM?

    Thanks.
     
  4. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    520
    No, unfortunately, you need to install new Windows VM with EFI. The simplest way is to download Window via Parallels Desktop: in Control Center click + > Get Windows 10 from Microsoft > Continue > Download Windows 10 > Install Windows > proceed with installation.
     

Share This Page