Central time zone set to Central America

Discussion in 'Windows Guest OS Discussion' started by Marc Hoffman, Apr 15, 2010.

  1. Marc Hoffman

    Marc Hoffman Bit Poster

    Messages:
    34
    This is a bug that has existed since version 4, but whenever Parallels releases a new version (I'm running Version 5) and the Parallels tools get updated in the guest OS, my timezone on the guest is switched from my time zone (Central) to Central America (not my time zone).

    Parallels, can this be fixed in the next release?
     
  2. Smudge2

    Smudge2

    Messages:
    37
    Yes please fix this soon. I travel every week for my job and when the Mac timezone is set to US Central, Parallels sets the Windows VM to Central America.

    Mac OS X 10.6.4 running Parallels 5.0.9344 running Windows XP SP3
     
  3. ms austin texas

    ms austin texas

    Messages:
    1
    I thought this was unique to my computer and have been fighting this for years. Parallels resets Windows XP time zone from "Central Time (US & Canada)" to "Central America." Causes all my appointments in Outlook to change by one hour. If Parallels has been causing this I would love to see the bug fixed.
     
  4. AustinUser

    AustinUser

    Messages:
    5
    I too have this problem, and thought it was something unique to my installation or something. Clearly it's an issue with how Parallels interprets the term "Central Time." It still occurs with Parallels v. 6 - can someone please fix this?
     
  5. arkbear

    arkbear

    Messages:
    7
    The work-around, apparently, is to clear the default tickbox for "Synchronize with Mac" on the Advanced section of the virtual machine Options screen. You will, of course, need to configure the virtual machine to get it's own time updates. Kind of an annoying bug, and yes, it's still with us in Parallels 6.
     
  6. AustinUser

    AustinUser

    Messages:
    5
    Thanks for the help - unfortunately for me, I've had this problem regardless of whether or not "Synchronize with Mac" is checked - that doesn't seem to make a difference. For me, it seems to disrupt the VM's time zone setting anytime the Mac host's time zone changes - again, regardless of the above Parallels setting.

    I'm curious to know if this workaround has solved the problem for anyone else - or if the problem is only related to transitioning to or from the "Central" time zone.
     
  7. shirleylacroix

    shirleylacroix

    Messages:
    2
    Time Zone

    I think this suggestion has fixed the problem for me that has been driving me crazy since I upgraded to Parallels 6. My timezone has now remained in CST for the last 4 minutes! That is a major accomplishment as I've been early for meetings all week! Thanks all for this suggestion.
     
  8. James T.S

    James T.S Bit Poster

    Messages:
    18
    I had the same problem and this work-around works for me.

    James T. Savidge, Tuesday, September 14, 2010
     
  9. plucas

    plucas Bit Poster

    Messages:
    7
    I having the same problem, I tried the bug fix and that worked for awhile. Outlook 2010 eventually went back to Central America time.

    plucas
     
  10. AustinUser

    AustinUser

    Messages:
    5
    Ahh - that may be the common thread here. 3 weeks ago I installed Outlook 2010 - well before upgrading to Parallels 6 just a few days ago, and this problem has continued to plague me. Every time I move between time zones, as soon as the Mac host changes to Central US time, the VM changes to Central Time (non-us). Even with the synchronize time boxes un-checked. But as long as I'm not traveling, it's stable. Problem is I travel 2x a week to the east or west coasts. :)
     
  11. James T.S

    James T.S Bit Poster

    Messages:
    18
    Things are a bit different for me, and despite what I said in an earlier posting, it is still happening to me.

    I have Outlook 2002 installed, I am not moving between time zones, I have “Virtual Machine -> Configure ... -> Options -> Advanced -> Time: -> Synchronize with Mac†unchecked, have “Automatically synchronize with an Internet time server†unchecked on the “Internet Time†tab of the “Date and Time Properties†Control Panel, as well as having â€Automatically adjust clock for daylight savings changes†unchecked.

    All I have to do to cause the Time Zone to be reset to “Central America†is to Suspend the VM, and Resume it. Some time during the Resume “start-upâ€, the Time zone gets changed.

    If I have the “Date and Time Properties†Control Panel open when I suspend the VM, when the VM is resumed, and the “Time Zone†is reset, the Control Panel still shows that the Time Zone is “Central Timeâ€. I can change tabs in the control panel, but it will still shoe “Central Time†as the time zone until I close and then reopen the Control Panel. Then it will show “Central Americaâ€.

    For me it seems to be tied with resuming a suspended VM.

    James T. Savidge, Wednesday, September 15, 2010
     
  12. radesix

    radesix

    Messages:
    47
    Windows 7 Timezone Issue

    I too confirm this bug. It's never been a problem for me until the upgrade to v 6. The timzone will not stay in Central Time for more than a couple of minutes it seems.
     
  13. James T.S

    James T.S Bit Poster

    Messages:
    18
    I happened to me again this morning when I resumed my XP VM for work.

    I later spent some time looking through the parallels.log but I didnt find anything that seemed to be related to the clock or time zones. However, I did not have detailed log messages enabled. I will turn that on and if I have time this evening I will try the Suspend/Resume process again to see if anything noteworthy shows up in the log.

    Parallels -> Preferences ... -> Advanced (icon) -> Troubleshooting: -> Use detailed log messages

    James T. Savidge, Thursday, September 16, 2010
     
  14. James T.S

    James T.S Bit Poster

    Messages:
    18
    I tried this last night but I did not find anything in the log that seemed to be related to setting of the time zone. I also did some Google research last night but I couldn’t find anything listed that seemed to be a description of this problem as we are experiencing it.

    Is it possible that this problem is related to the latest version of Parallel Tools more so than to the 6.0 upgrade?

    If so, and if there is a way to change the Parallels Tool to an older version, or to remove them entirely, I be willing to try and run some tests to confirm or reject this possibility.

    James T. Savidge, [jsavidge@texas.net], Friday, September 17, 2010
     
  15. Marc Bernstein

    Marc Bernstein

    Messages:
    5
    Started happening to me the with upgrade to 6.0

    I have been on Parallels 5 and did not have this problem. Immediately upon upgrading to Parallels 6, this began happening. My time zone, which is Central time, is changed to Central America every time I startup Parallels, either from a cold boot or a suspend. This causes my time to be off by an hour (due to daylight savings time differences, I imagine).

    I entered a ticket with Parallels support. Very discouraging to come to this forum and see that this was a known problem prior to the release. There are a lot of people living in the Central time zone; if this is not impacting everyone, then I'd sure like to know what is unique about my configuration that is causing this. If is is impacting everyone, pretty embarassing not to have this fixed by now.

    Update - 9/22/2010 5:05 Central (not Central America!)

    I submitted a ticket to suppport yesterday. They gave me the following instructions:
    http://kb.parallels.com/en/8985

    I tried it,but it didn't work. So I replied back and a new engineer replied with the same instructions again! I figured, what the heck, I'll try again. Sure enough, it seems to have worked. I have no tried various combinations of suspending, restarting, shutting down parallels, leaving parallels open, restarting my Macbook and the time zone seems to be holding in each case. I'm sure I have not tried every combination, but right now it's working based on kb #8985.
     
    Last edited: Sep 22, 2010
  16. MattV

    MattV

    Messages:
    6
    Seeing the same problem over here... Now when resuming the VM the time is very off.
     
  17. James T.S

    James T.S Bit Poster

    Messages:
    18
    After upgrading to this weeks Parallels 6 update and installing the new version of the tools, I have found a setting that seems to solve the problem for me.

    Virtual Machine -> Configure ... -> Advanced -> Time: -> Synchronize with Mac and Allow a different time than on the Mac

    With both of those options checked, and my Windows XP Time Zone set to Central Time (US & Canada), I am no longer seeing the time zone reset when ever I resume the VM.

    Allow a different time than on the Mac appears to be the critical setting for me.

    James T. Savidge, Thursday, September 23, 2010
     
  18. ImSeeker

    ImSeeker Bit Poster

    Messages:
    40
    I am also in Central time, and yes I think this is happening to us all. I will try the suggested solution 8985. BTW - when booting in bootcamp, the time is indeed often quite wrong. I'll see if I can use windows to fix the time as well.
     
  19. MattV

    MattV

    Messages:
    6
    Mine continues to reset to an hour prior even with the different time than the Mac setting.
     
  20. MattV

    MattV

    Messages:
    6
    Got it resolved by stopping and setting the Windows Time service to manual.
     

Share This Page