"Check your internet connection" during parallel desktop activation

Discussion in 'General Questions' started by ParallelsU142, Aug 5, 2018.

  1. ParallelsU142

    ParallelsU142 Bit Poster

    Messages:
    2
    I am unable to login yo my account for activation after installing parallel desktop.
    The same message of "check your internet connection" keep showing up.
    My internet connection is normal.
    Firewall is turned off.
    Already tried those tricks in your knowledge base / forum but nothing worked...

    Will request for a refund if I am still unable to login
     

    Attached Files:

    MarieM1 and MichaelS61 like this.
  2. AJ@Parallels

    AJ@Parallels Kilo Poster

    Messages:
    752
    Hello ParallelsU142, Please check our private conversation.
     
  3. ParallelsU142

    ParallelsU142 Bit Poster

    Messages:
    2
    not usable so REFUND please.
     
  4. zishengl

    zishengl

    Messages:
    2
    I can't log in too! I bought it yesterday.
     
  5. zishengl

    zishengl

    Messages:
    2
    I have the same issue, I can't login the account, and always showed that 'connect to the internet and try again'
     
  6. DanijelT

    DanijelT Bit Poster

    Messages:
    1
    I have the same problem, any solutions?
    I did the complete removal of Parallels desktop 13, and reinstall from new but didn't help.
     
    Last edited: Aug 5, 2018
  7. JeanE1

    JeanE1

    Messages:
    1
    I have the same problem! can't sign in parallels desktop 13!!!
     
  8. nbianda

    nbianda Bit Poster

    Messages:
    1
    Another with the same problem, even reinstalling (v13). The problem was not there with v11.
     
  9. NE_

    NE_ Bit Poster

    Messages:
    1
    Bought Parallels Desktop 13 today and have the exact same problem. Port 443 is open and reachable. If this persists i want a refund! Not usable!
     
  10. MichaelS61

    MichaelS61 Bit Poster

    Messages:
    4
    I have been using Parallels Desktop on my Mac since 2013, and yesterday, after the latest update, I am getting exact same issue with "Check your Internet Connection" and I can no longer get to my Windows 10. I did a chat last night with someone from Parallels, and they stated that they were aware of the issue, and that there is no ETA for a fix. I need access to my Windows 10 on my mac, I am a school teacher, and I need files that I can only get while in Windows. Does anyone have a fix for this, or is there anyway to roll back to the previous version??
     
  11. MichaelS61

    MichaelS61 Bit Poster

    Messages:
    4
    I have the exact same issue with the EXACT same screen shot! I need this to get working ASAP, I am a school teacher and I have files that I can only access while in Windows!
     
  12. MichaelS61

    MichaelS61 Bit Poster

    Messages:
    4
    I just tried to install a previous version of Parallels that used to work just fine on my Mac, but now after it is installed, I get the same window that opens up asking me to sign in. I am locked out of my Windows! Please find a FIX SOON!
     
  13. ChanceR

    ChanceR

    Messages:
    1
    Another user with same issue. Please advise on how to fix. I followed KB article also and it did not resolve my issue
     
  14. HenrikE2

    HenrikE2 Bit Poster

    Messages:
    1
    The SSL certificate for account.parallels.com expired yesterday... support is not helpful, talked to them yesterday.
    A sorry can't help and don't know an ETA is not what I expect from a company like Parallels. This is embarrassing and without an ETA, I am now forced to migrate to VMware Fusion as I can't postpone accessing my work VMs after reinstalling due to a HW failure.
    I wonder how Parallels plans to compensate all users that can't access their data and spend hours try to fix this.
     
  15. ConradK2

    ConradK2 Bit Poster

    Messages:
    1
    I'm getting the same thing. I tried uninstalling completely and reinstalling twice. I've tried using different windows disks. It just refuses to work. I also tried all tricks in forum that I could find. Help please!
     
  16. EdinT

    EdinT

    Messages:
    1
    Same problem here, will this be fixed soon or do we need to ask for a refund?
     
  17. DavidH42

    DavidH42 Bit Poster

    Messages:
    2
    Same problem (v13). Have been through the KB, checked hosts, firewall, proxy settings etc and no change. Have registered key via the webpage but unable to use app.
     
  18. hbrooks2

    hbrooks2 Bit Poster

    Messages:
    5
    I uninstalled v13 and installed v12. Had the same error.
     
    MichaelS61 likes this.
  19. MarieM1

    MarieM1 Bit Poster

    Messages:
    1
    Same issue here, tried everything from the knowledge base but the problem persists.
     
  20. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi, we had a minor technical glitch which has been resolved now. Please try to register now and let us know if you are experiencing any issues.
     

Share This Page