Civilization VI

Discussion in 'Windows Guest OS Discussion' started by brunok2, May 25, 2020.

Tags:
  1. brunok2

    brunok2 Bit Poster

    Messages:
    1
    Hi

    I just bought Parallels (home version) as I am looking for a solution in order to run some games I couldn't run on over virtual machine solution because of Direct X 11/12 support.
    As it is stated by Parallels that's Direct X11 is supported I then bought the software and installed the first game which requires Direct X11 it's Civilisation VI
    I installed it (on a dedicated Steam library folder I put on an external hard drive) and run then after
    I just saw the screen where you've to choose the version of Direct X 11 or 12 and I choose then 11.... few secs after the game just stopped without opening
    Can it be related to Direct X support or something else ?

    thanks
    BKantique
     
  2. JulioM3

    JulioM3 Bit Poster

    Messages:
    1
    I have the same problem. I've got to run Civilization VI but with fragmented graphics, so I can't play at all. If you choose Direct X 12 then it crashes.
     
  3. AdilE

    AdilE Bit Poster

    Messages:
    2
    Same issue here, fragmented graphics with Civilization VI[​IMG]
     
  4. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    5,720
    Hello, could you please collect the tech report right after the issue reproduced and reply us back with the report's ID.
    Looking forward to your reply.
     
  5. AdilE

    AdilE Bit Poster

    Messages:
    2
    Hi, here is the report ID: 341779981
     
  6. Andres13

    Andres13 Bit Poster

    Messages:
    1
    Hi guys! Any news about this issue? I just bought the game and parallels and it's still not working :(
     
  7. AgilePhilosopher

    AgilePhilosopher Bit Poster

    Messages:
    1
    yea same here.. any updates on options for a fix yet?
     
  8. ParallelsU439

    ParallelsU439 Bit Poster

    Messages:
    2
    Any update yet? DirectX games via Steam seem to have issues anyway, also on performance.
     
  9. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    5,720
    Hello guys, please collect the tech report once the issue reproduced. We will escalate this case to the Parallels Engineering Team for the further investigation.
     
  10. ParallelsU439

    ParallelsU439 Bit Poster

    Messages:
    2
    Tech report 344759296 sent in. Intro movies are fine, the menu looks like this:
    Screenshot 2020-07-15 at 08.18.09.png
     
  11. ParallelsUser 1812

    ParallelsUser 1812 Bit Poster

    Messages:
    5
    Same problem - also looking for a solution to this.
     
  12. ParallelsUser 1812

    ParallelsUser 1812 Bit Poster

    Messages:
    5
    Technical report 346087224 sent in case this helps.
     
  13. JoshS9

    JoshS9 Bit Poster

    Messages:
    2
    Same issue on mine. Report ID 346095154
     
  14. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    5,720
    Hello, did you play with Graphic setting at the VM configuration?
     
  15. JoshS9

    JoshS9 Bit Poster

    Messages:
    2
    I did, I have tried Different Resolution settings (in the Window 10 VM) as well as trying all 3 resolution options in the parallels graphics config. (Best for Retina, Scaled, Best for external displays) I have tried maxing out the memory as well as leaving it on Auto. I've also tried different settings in the game it self with no luck. (turning on and off various graphic options as well as trying different resolutions and full screen vs windowed mode.) The graphics glitch follows and occurs with any setting I've tried.
     

Share This Page