Error with Ubuntu 20

Discussion in 'Linux Guest OS Discussion' started by David100, Mar 11, 2022.

  1. MarianoM

    MarianoM Bit Poster

    Messages:
    1
    I have the very same exact issue.
     
  2. BenjaminB15

    BenjaminB15 Bit Poster

    Messages:
    2
    Confirmed M1/ARM, Same issue with Ubuntu 20.04 LTS ... kernels 5.4.0-90 and 5.4.0-100 are OK, but 5.4.0-104 breaks with EFI_RNG_PROTOCOL
    Note that the same EFI_RNG_PROTOCOL message appeared in the previous kernels, but 5.4.0.104 doesn't gracefully continue. Boot switches avoiding EFI fail.
     
  3. HarriL3

    HarriL3 Bit Poster

    Messages:
    2
    Confirmed M1/ARM, Same issue with Ubuntu 20.04 LTS ... kernels 5.4.0-90 and 5.4.0-100 are OK, but 5.4.0-104 breaks with EFI_RNG_PROTOCOL

    Both on Ubuntu 20.04.2 Server and Desktop.
     
  4. Igor27

    Igor27 Bit Poster

    Messages:
    2
    M1/ARM 5.4.0-104 not load - EFI_RNG_PROTOCOL error EFI_RNG_PROTOCOL unavailable
     
  5. AaronN1

    AaronN1 Bit Poster

    Messages:
    5
  6. Meng-Yuan Huang

    Meng-Yuan Huang Bit Poster

    Messages:
    3
    Parallel Desktop Version 17.1.2 (51548) fixes this problem. It works well with Ubuntu 21.10 arm64 with kernel 5.13.0-35.
     
    ParallelsU906 and BobW11 like this.
  7. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello everyone, we have released a Parallels Desktop hotfix version 17.1.2. The Ubuntu virtual machine boot-up issue got fixed in that. Please visit this KB article to know more.
     
  8. liuxg

    liuxg Bit Poster

    Messages:
    3
    I just got the new release of parallells desktop. I am not sure whether it resolves the issue or not.
     
  9. liuxg

    liuxg Bit Poster

    Messages:
    3
    I just got the new update for parallels desktop. I am wondering whether it resolves the issue or not. How can I know which release addresses the issue. Thanks
     
  10. AntonisT

    AntonisT Bit Poster

    Messages:
    3
    I can also confirm that the latest update (Version 17.1.2 build:51548) resolves the issue of stuck on boot with the latest kernel.
     
  11. BillyC2

    BillyC2 Bit Poster

    Messages:
    1
    What about the App Store Edition? I'm assuming the hotfix does not work for this version...
     
  12. LeandrinL

    LeandrinL Bit Poster

    Messages:
    1
    Hi, i still get the same error even after changing the kernel. What am i supposed to do? I am sadly on the verge of canceling my Parallels Desktop subscription.
     
  13. NikolaiS@Parallels

    NikolaiS@Parallels Staff Member

    Messages:
    31
    @LeandrinL , thank you for letting us know.

    As we can see, there is a recently submitted support ticket where our Tier-1 team has suggested the steps.

    We've taken the ticket in the second line in case these steps don't help, and we could take a closer look at the case.

    Thanks!
     
  14. H__6

    H__6

    Messages:
    1
    Is the problem back?
    I tried upgrading to 22.04.1LTS from 20.04LTS and when it boots it says `EFI stub: Exiting boot services` but without the `and installing virtual address nap` part.
    This is happening with kernel 5.15.0-46. (The workaround to boot with kernel 5.13.0-40-generic works.)

     

Share This Page