High Parallels CPU Usage

Discussion in 'Windows Guest OS Discussion' started by koppah, Oct 4, 2012.

  1. koppah

    koppah Bit Poster

    Messages:
    63
    Parallels seems to have gone down in efficiency with the release of PD8. When Windows is using about 20% CPU usage overall, the actual Parallels host in OS X can easily be using between 100 and 200%. Any reason why there's so much overhead...?

    Currently, my total Windows CPU usage is hovering around 20%, but Parallels is at 150%.
     
    Last edited: Oct 4, 2012
  2. pborzenkov

    pborzenkov

    Messages:
    19
    Please generate a problem report ("Help > Report a Problem") when CPU usage is high and post its ID here.
     
    Last edited: Oct 5, 2012
  3. koppah

    koppah Bit Poster

    Messages:
    63
    I will try to get one when I see this happening.

    FYI, I *believe* it's something to do with the graphics driver. When the CPU has been high, it's when I've been running Office 2013, and the Desktop Window Manager is also increasing in CPU, implying it's got something to do with how Office renders its UI. I've had to disable Hardware Acceleration in Office, as it's corrupting the display.
     
  4. REKREK

    REKREK

    Messages:
    2
    I have the same issue...here's my "Report a Problem" ID: 18815986
     
    Last edited: Oct 11, 2012
  5. REKREK

    REKREK

    Messages:
    2
    Resolved High CPU Issue

    I ended up just uninstalling and reinstalling Parallels 8. That seemed to resolve my high CPU issues.
     
    Last edited: Oct 14, 2012
  6. koppah

    koppah Bit Poster

    Messages:
    63
    Reinstalling didn't fix it. I'm STILL seeing VERY high CPU usage. I seriously think it's something to do with the Graphics Driver, as one time, I closed Office, but the Desktop Window Manager was still using 50% CPU.

    Parallels - are you looking into this?!
     
  7. koppah

    koppah Bit Poster

    Messages:
    63
    Is there any feedback from Parallels on this issue? I'm still seeing VERY high CPU usage for Office 2013 apps, and if I enable Hardware Acceleration, I get graphical corruption
     
  8. serv

    serv Parallels Developers

    Messages:
    789
    koppah,

    Are you running the latest Parallels Desktop build 8.0.18314? If so, generate a Problem Report when you see the corruption and post report ID here.
     
  9. koppah

    koppah Bit Poster

    Messages:
    63
    So, I nuked the VM and started from scratch. Things seem much, much better now.
     
  10. LellerP

    LellerP

    Messages:
    1
    Same issue here. Started happening after updating to the newest build 8.0.18314.
    Not running anything in Windows, with Windows reporting low CPU usage.
    My host OSX, however, shows that Parallels is constantly consuming at least 20%.
    Battery life has gone down. Please help.
    Support request ID is 19707857.
     
  11. koppah

    koppah Bit Poster

    Messages:
    63
    I'm also seeing constant 20% CPU usage now, but no longer high CPU usage from running Office 2013.
     
  12. Matt Stratton

    Matt Stratton

    Messages:
    7
    I have been seeing the same behaviour. Parallels 8 running Win8 with Office 2013 on a 15" MBPr with 16 GB RAM.
     
  13. ccoxhead

    ccoxhead Bit Poster

    Messages:
    4
    Ditto. WinXP on MacBook Pro with 8 Gb RAM. VM is on an SSD. Problem Report 20287777.
     
  14. Warwick599

    Warwick599

    Messages:
    1
    Same here, Windows 8 VM can be idle, but Parallels VM process on OSX easily approaches 200% CPU usage with fans running at full speed. Problem ID 20317647
     
  15. ccoxhead

    ccoxhead Bit Poster

    Messages:
    4
    Believe it or not, my problem was solved with a Repair Disk Permissions in OSX.
     
  16. mr_squall

    mr_squall

    Messages:
    3
    Same issue! Number: 22073669
     
  17. totvos

    totvos Bit Poster

    Messages:
    34
    I have the same problem since upgraded to PD8. This is a continuous, as opposed to sporadic, problem. Right now, my Windows 7 VM is telling me Windows is using 0-1% CPU, while PD8 is using 52% of my MBP CPU.

    Problem ID 22530885.
     
  18. TechStefan

    TechStefan

    Messages:
    1
    20-30% on MBP 2012

    Same here, Parallels hovers at 20%, at times higher, while Windows apps are either closed or idle. Win 7 Ultimate.
     
  19. JacopoC

    JacopoC Bit Poster

    Messages:
    5
    Hi,

    I have the same exact problem:

    - Seven Ultimate x64 + Parallels Desktop 8.0.18608
    (Rev 898384; Wed, 17 Jul 2013)...can anybody help me out?


    Kind regards

    ID 31047757
     
  20. pborzenkov

    pborzenkov

    Messages:
    19
    Could you post a screenshot of guest Windows with Task Manager's "Processes" tab (sorted by CPU usage), please?
     

Share This Page