Hitching and texture rendering problems in games (about every 5 sec.)

Discussion in 'Windows Guest OS Discussion' started by DashtonP, Sep 18, 2019.

  1. DashtonP

    DashtonP Bit Poster

    Messages:
    35
    Hi there!
    I have experienced this in a couple games (Black Desert, Planet Coaster, SWTOR): With the exception of Black Desert (runs poorly), I am able to run on at least at 30-60fps the other two games, but there are hitches about every 5 sec and all the textures appear to completely reload every 5 sec as well. This is most apparent when playing SWTOR which runs at 60fps but the textures appear to completely reload every 5 seconds, getting blurry and then clear again no matter the situation, and the whole game hitches (extremely briefly) at this time as well.

    Any help with this problem is greatly appreciated, FYI I am playing using the automatic / recommended settings in Parallels 15 VM for the gaming profile (4vCPUs, 8GB RAM, Auto Graphics Memory).

    Look forward to hearing from you :) thanks!
    Dashton Peccia
     
  2. DashtonP

    DashtonP Bit Poster

    Messages:
    35
    Best Answer
  3. SaravananR@Parallels

    SaravananR@Parallels Staff Member

    Messages:
    11
    Hi DashtonP. Please refer to this article to change the profile from "Productivity" to "Games only" then close the configuration windows and start your Windows virtual machine to check if that works!
     
  4. DashtonP

    DashtonP Bit Poster

    Messages:
    35
    Hi SaravananR! I am actually already using the 'Games Only' profile in Parallels, that is where I was experiencing the problem (I also experienced it in 'Productivity' profile as well).
     
  5. DashtonP

    DashtonP Bit Poster

    Messages:
    35
    Best Answer
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,982
  7. DashtonP

    DashtonP Bit Poster

    Messages:
    35
    Yes! It fixed the issue.
     
    Maria@Parallels likes this.

Share This Page