Install Cisco Anyconnect ARM64 version on Windows ARM VM

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by Sikeer, Mar 27, 2021.

  1. Sikeer

    Sikeer Bit Poster

    Messages:
    3
    When I install Cisco Anyconnect (win ARM64 version) into VM, it said cannot be installed, any one have same problem?
     
  2. AnatoliiV

    AnatoliiV Bit Poster

    Messages:
    4
    Same here, version 4.9.06037
     
  3. kundanno

    kundanno Kilo Poster

    Messages:
    107
    I have had the same issue with Checkpoint VPN. I think the issue is that x64/x86 emulation does not work with "kernel" drivers.
     
  4. Sikeer

    Sikeer Bit Poster

    Messages:
    3
    me too. I switched it to x86 version, it can be installed successfully, but when I connected to VPN gateway, it report error.
     
  5. MichalK7

    MichalK7 Bit Poster

    Messages:
    1
    I am looking forward for an answer it blocks my work on parallels completely.
     
  6. romanbochagov

    romanbochagov Bit Poster

    Messages:
    4
    cisco anyconnect working fine on all win arm, but for install you need 21286 (maybe some more). use official vhdx image, install cisco and update windows to last ver
    need to fix this for clean install last win ver
     

    Attached Files:

  7. ThorstenM3

    ThorstenM3 Bit Poster

    Messages:
    3
    Hi Roman,

    you are using OS build 21354.1, while the latest which I get through updating is 21343.1. My edition is called Windows 10 pro insider preview while you have windows 10 Pro only. Just saw that there is an update and I will install it as well.
    Have you installed the Anyconnect client for Windows 10 or the ARM version of it?

    Working since days on it and be very happy that it seems to work for you. So far I got a break when I tried to install the Anyconnect ARM version and when I install the Windows 10 version it seems to work but it is not installing the network adapter. The driver can not be installed.

    Have now really hope that it can be fixed the way you have done it.
     
  8. romanbochagov

    romanbochagov Bit Poster

    Messages:
    4
  9. ThorstenM3

    ThorstenM3 Bit Poster

    Messages:
    3
    Have tried it now with OS build 21354.1
    Anyconnect latest version for Windows 10 - an official package - (not the ARM version, because it still fails to install)
    The Windows 10 version can be installed but it fails to install the network adapter. The driver can not be installed even when the inf file is available in the CISCO subdirectory. Also a manual installation is not possible.
    As a result I get the below.
    Bildschirmfoto 2021-04-08 um 18.38.11.png

    Which version of the VPN (ARM or regular Windows 10) have you installed and how have you managed it?
     
  10. romanbochagov

    romanbochagov Bit Poster

    Messages:
    4
    use arm version. for install use 21286 official build
     
  11. mosaic

    mosaic Bit Poster

    Messages:
    1
  12. AnatoliiV

    AnatoliiV Bit Poster

    Messages:
    4
  13. romanbochagov

    romanbochagov Bit Poster

    Messages:
    4
    1. install 21286 build vxhd from microsoft
    2. install arm-version cisco anyconnect
    3. update windows to last version (if you need)
     
    mosaic and AnatoliiV like this.
  14. AnatoliiV

    AnatoliiV Bit Poster

    Messages:
    4
    Thanks a lot. It works.
    Screenshot 2021-04-10 at 18.16.49.png
     
  15. AnatoliiV

    AnatoliiV Bit Poster

    Messages:
    4
    Updated to the latest build avialable, all fine.
    Screenshot 2021-04-10 at 19.27.11.png
     
  16. ThorstenM3

    ThorstenM3 Bit Poster

    Messages:
    3
    Hey Roman,
    this was now so simple and so useful. A downgrade of Windows and CISCO ARM can be installed. Thanks a lot! Everything works now.
    If I could send you some good german beer I would do so ;-)
     
  17. Michael.

    Michael.

    Messages:
    1
    For me it doesn't work with the ARM64 Anyconnect.
    I can install the msi-file if I first adjust the MSI-file with Orca.
    But after installation it doesn't work, it tries to connect but say "Attempting to repair VPN adapter" I get the feeling that I'm missing the network adapter that normally are installed under network adapters.
     
  18. KevinB21

    KevinB21 Bit Poster

    Messages:
    10
    I'd rather not have to downgrade Windows to install but good to know it's possible for it to work. I'll try messing with the MSI too and see if I can get a working transform.
     
  19. KevinB21

    KevinB21 Bit Poster

    Messages:
    10
    I made a transform for the MSI and replaced every instance of "NOT VersionNT64" with "VersionNT64" and now it installs and appears to work correctly. Originally I just removed the launch condition that was blocking the install. It appeared to install correctly but would fail to connect. So I took a guess that the newer builds of Windows ARM are reporting VersionNT64 as true but older builds were not and there are various components that a "NOT VersionNT64" condition on them that don't get installed if you only remove the launch condition. There were also various conditions built on VersionNT64 being TRUE, and I considered changing them to NOT VersionNT64... but held off and so far it seems okay. I don't really have the inclination to dig through the install and figure out exactly what every component condition does without better tools than Orca. Ultimately this is something Cisco will have to fix in their installer but for now a search and replace of "NOT VersionNT64" with "VersionNT64" in Orca seems to work.
     
  20. Micke.

    Micke. Bit Poster

    Messages:
    1
    I did a quick and dirty Search and Replace "NOT VersionNT64" with "VersionNT64" and now it´s working for me. Thanks Kevin!
     

Share This Page