Is there a way to write a £ symbol?

Discussion in 'General Questions' started by AGrace, Sep 24, 2012.

  1. AGrace

    AGrace Junior Member

    Messages:
    14
    I can type the £ symbol in Mac OSX but not in Window's 7 using parallels. The key shortcut on my MacBook Pro 13 inch is shift + 3, but doing the same in windows launches my 3rd task bar item. If I use the windows shortcut shift + 3 gives me a # symbol. A few google searches later and all I find are people wanting to use the # symbol not the £.

    (NB- i've been using the £ in thread by copy-pasting it).

    Any help is appreciated.
     
    Last edited: Sep 26, 2012
  2. TraneF

    TraneF Member

    Messages:
    26
    The obvious solution is to use Windows shortcuts instead of OS X: Alt-0163 should give you what you need.
     
  3. AGrace

    AGrace Junior Member

    Messages:
    14
    Tried that, it didn't work. You're right, it was obvious to use that.. but it does not work.
     
  4. TraneF

    TraneF Member

    Messages:
    26
    I just tried it and it works fine. It's worth noting that this only works typing the numbers on the number pad. If you're using a MacBook of some variety, you'll need to click the num lock key first, hold alt and then type 0163 on the numeric keypad overlay on the keyboard. When you release the alt key, the pound symbol should magically appear in your application or console.
     
  5. AGrace

    AGrace Junior Member

    Messages:
    14
    I have a MacBook Pro 13, which has no numpad.

    [​IMG]
     
  6. TraneF

    TraneF Member

    Messages:
    26
    Good grief. Apple's not making this easy for you, is it? My mid-2007 MacBook has the number pad overlay and num lock keys. Still, this will be doable (if not ideal). In Windows 7, go to Accessories -> Ease of Access -> On-Screen Keyboard. When the keyboard is on-screen, click the Options button and turn on the number pad. On your MBP, hold the alt key while clicking the virtual keyboard's on-screen number pad 0163 keys.

    It's a pain in the neck and you have my condolences, but it should do the trick. I never did understand Microsoft's insistence on using the number pad for the Alt- key combinations. Now, Apple is seemingly joining the fray by wanting to sell you hardware where it used to be simple even on a laptop keyboard.

    Cheers,

    trane
     
  7. BernardK

    BernardK Member

    Messages:
    24
    Why no Shift+3 ?

    Hi,

    I can see on the image that I have the same keyboard, but with an * above the 3, and [$ £] instead of [\ |] near Return.

    To type an asterisk, I press Shift and 3, to type this > £ <, I've just pressed one Shift key and $. It also works in Notepad in a Win7 VM. So why do you have to press cmd+3 ? It looks like you have a modified keyboard mapping somewhere. Googling with <keyboard mapping settings in parallels desktop for mac> gives this : Keyboard issues troubleshooting - KB Parallels -> http://kb.parallels.com/113932

    There is also an On-screen-keyboard in OS X (at least Mountain Lion), which shows all characters depending on the modifier key (or keys) depressed : Apple menu -> System Preferences -> (Personal) Language & Text. Click on Input Sources and check Keyboard & Character Viewer :

    [​IMG]

    Also check Show input menu in menu bar :

    [​IMG]

    The country flag corresponding to the keyboard checked in the Input source list, should appear in the menu bar (left to the time). Click on it and select Show keyboard Viewer.

    [​IMG]

    Play with the modifiers and see if you find a combination which displays a £.

    HTH

    Bernard
     
  8. TraneF

    TraneF Member

    Messages:
    26
    Which ultimately means it's not the same keyboard mapping. Different languages/mappings use different modifiers to output the various glyphs. My US keyboard, for example, outputs £ by Option-3. Depending on the native OS X mapping, the equivalent key combination may not correspond in Windows. On a US keyboard, Alt and Option share the same key and Alt-3 in Windows will have its own meaning. That's why I stuck with the native Windows Alt-code for a solution.
     
    Last edited: Sep 25, 2012
  9. AGrace

    AGrace Junior Member

    Messages:
    14
    To clarify;

    In native Mac OSX, shift+3 = £. In windows 7 (VM) the same shift+3 = #. There is absolutely no key command(s) in the Windows VM that creates a £ symbol.
     
  10. TraneF

    TraneF Member

    Messages:
    26
    I'm out of ideas. Based on your keyboard, one must assume you're using either CP-1252 or ISO 8859-1 as your Windows codepage. Both use Alt-0163 to output the £ symbol. The fact that you say "Shift + 3" gives you a # sign in Windows indicates that you're using a US keyboard mapping in your VM. Even then, Alt-0163 will work. The numbers must be typed on the number pad, not the row above the QWERTY layout (it isn't optional). Alt-0165 will output a ¥ symbol.

    Best of luck with it. This does not seem to be a Parallels or Windows issue (i.e., bug). I would look at your VM regional settings to see what your keyboard and non-UNICODE settings are and make sure they match.
     
  11. AGrace

    AGrace Junior Member

    Messages:
    14
    the virtual keypad will work with your suggestion but it's nearly as impractical as having the £ symbol saved on my clipboard for pasting when needed.. sigh.. this is stupid.
     
  12. TraneF

    TraneF Member

    Messages:
    26
    I still think that most of your issue is that your VM is set to use a US keyboard layout (the whole Shift+3=# thing). If you can successfully map your VM keyboard to match the locale of your OS X keyboard, I suspect your problems will largely go away.
     
  13. AGrace

    AGrace Junior Member

    Messages:
    14
    I can't change that unfortunately. Our VM's go through a US ip range setup by the IT department. This won't ever change. :-/
     
  14. TraneF

    TraneF Member

    Messages:
    26
    That touches a tender spot for me. I've worked in localization for over 15 years and had the powers that be decide "what was what" more times than I care to remember. You have my condolences. I can't think of anything beyond the virtual keyboard Alt-0163 that'll get what you need.

    Best of luck with it!

    Cheers,

    trane
     
  15. AGrace

    AGrace Junior Member

    Messages:
    14
    thanks for all you help!
     
  16. TraneF

    TraneF Member

    Messages:
    26
    The pleasure was mine (although it'd have been better had we found a solution for you). :)
     
  17. TraneF

    TraneF Member

    Messages:
    26
    Just a quick note to say that it might be worth a few quid to buy a USB number pad for the MBP and save you a heap of grief. I know I would ...
     
  18. BernardK

    BernardK Member

    Messages:
    24
    [I started to write this reply this morning after seeing AGrace's Today, 09:53 AM reply]

    To AGrace : How did you upload and insert your image into the post ? The FAQ says :
    "If you have uploaded an image as an attachment, you can click the arrow next to the 'Attachment Icon' and select it from the list."

    As I haven't found that arrow, I used [​IMG], and after posting the reply I saw my screen captures in the reply, but today they have disappeared.

    To both : It's more and more obscure : you guys have both a US keyboard with different behaviour ? On all keyboards I have used, the Shift key always displayed the character engraved above the numbers, so I thought it was the rule. I have just added the US keyboard in the Input Sources and noticed it's not the case on my MBP : if I open Textedit, switch to US keyboard and press Shift+3, it writes a # !

    I have found this : http://answers.yahoo.com/question/index?qid=20090203034620AAtWyaa

    and tried to add the British keyboard. As uploaded screen captures disappear, I will only describe how to get there : Apple menu -> System Preferences -> (Hardware) Keyboard. If necessary click on the Keyboard tab, check Show Keyboard & Character Viewers in menu bar, click Input Sources…. In the list of countries, check British. The menulet in the menu bar allows now to switch the layout.

    Now switch to the Win7 VM. You can notice that changing the keyboard from the Mac menu has no effect. The corresponding keyboard must also be installed in Windows.

    Try to find your way in Control panel, Region and language, modify keyboards, tab Keyboard and language, button Modify the keyboards…, and see if you can add English (Great Britain).

    I was able to do it with a Windows 7 Professional version. The Mac and Windows must be in sync. Then I switched to the British keyboard with the Mac menulet, also selected Show keyboard viewer to see how key presses are interpreted, opened Notepad and pressed Shift + 3, and there comes the £ !

    Hope it works for you.
     
  19. AGrace

    AGrace Junior Member

    Messages:
    14
    I have a UK keyboard (well as much of one as Apple will allow) but the language on my mac is locked to US english, as is the keyboard.. which is why I believe we have different results.

    Additionally, in regards to that link to Yahoo! Answers, my keyboard doesn't have a dedicated ~ key. Like I said, I tried all keyboard short cuts, non prevailed.

    Lastly, regarding your image insertion; I use photobucket to host my images. I'd suggest you use them also. I've never had an issue.
     
    Last edited: Sep 26, 2012
  20. BernardK

    BernardK Member

    Messages:
    24
    Sorry, but Best Answer is not the best part in this link. It was rather for josho answer, how to install a keyboard.

    It's a pity that you can't add another layout in the Mac.

    And how about inserting an image ?

    Thanks
     

Share This Page