Loses network after sleep (Catalina / Par 15.1.4 / Win10Pro)

Discussion in 'Windows Guest OS Discussion' started by ksignorini, Jul 1, 2020.

  1. ksignorini

    ksignorini Bit Poster

    Messages:
    25
    I'm using Parallels 15.1.4 with macOS Catalina 10.15.5 on a 16" MacBook Pro 2019.
    My network is set up as Bridged (Default Adapter) since I need to specify my IP address within my home network scheme. I cannot use DHCP for this setup.
    Every morning, when I wake my computer from sleep, the Windows 10 Pro VM has lost its network connection and must be restarted.
    Any ideas how to fix this?
    Thanks!
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hello, did you shut your VM down completely or just suspended it?
    If you shut down your VM and then start it, does the network works normally?
     
  3. ksignorini

    ksignorini Bit Poster

    Messages:
    25
    If I shut down completely it will reconnect after reboot. That's the only way. Otherwise, every sleep cycle of the computer, the Windows 10 VM loses its bridged network connection. Every time.
     
  4. ksignorini

    ksignorini Bit Poster

    Messages:
    25
    That is... shut down the VM completely to restore network connection. Suspend just suspends the broken connection and it doesn't work when un-suspended either. It takes a full VM reboot to restore the network connection.
    I'd have to test, but I don't think this happens when using the default Shared Network. Only Bridged. (But I need Bridged as I need my router to dish out s specific IP to this VM based on Mac address.)
     
  5. ChaseE1

    ChaseE1 Bit Poster

    Messages:
    1
    Did you figure out a solution to this? I'm having the same issue. I can switch to shared, then back to bridged and it will start working again, or I can reboot. OS 10.15.6, Parallels 15.1.4, Win 10 Pro 2004, and problem persist in version 20H2. I'm assuming this is an upgrade to parallels 16 fix.
     
    LeoL15 likes this.
  6. ksignorini

    ksignorini Bit Poster

    Messages:
    25
    I never did get resolution. Just I do what you are doing.
     
  7. LeoL15

    LeoL15 Bit Poster

    Messages:
    5
    It happens to me also for the last 1 year after I upgraded to parallels16 . Everything the computer went to sleep and wake it will lose all the connections. This is specially for Quickbooks which I need to quit and logging again. anyway for parallels to have option to keep network the same state and no change of IP address?
     
  8. DirkM9

    DirkM9 Bit Poster

    Messages:
    6
    I have the same problem with my CentOS 7 VM. After waking up the computer the VM has no IPV4 address anymore. The VM has the network configuration set to shared.
    MacOS is 11.2.3 (20D91)
    Parallels Desktop is 16.1.3 (49160)
    Parallels Tools is installed.
     
  9. LeoL15

    LeoL15 Bit Poster

    Messages:
    5
    The only solution that I have on hand now after disconnection to Quickbooks is to disconnect the network and connect to either Shared Network again.
    And this can be happen couple of time every day when the Mac goes to sleep. I also have tried to disable Mac to goes sleep automatically when display is off without any success.
    Parallels developer please do something about this
    MacOS 11.2.3 (20D91)
    Parallels Desktop 16.1.3 (49160)
    Parallels Tools is installed.
     
  10. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hi, could you collect the tech report once the issue reoccurs and reply us back with the ID number please?
     
  11. LeoL15

    LeoL15 Bit Poster

    Messages:
    5
    Hi Maria,

    Kindly find report id as follow 365859972. This report is taken after issue re-occurs.
     
  12. DirkM9

    DirkM9 Bit Poster

    Messages:
    6
    I have communicated with support via email and for me the following procedure has helped (so far). In may case it's CentOS7 VM, which lost its IPV4 address.
    1. Shutdown the virtual machine
    2. Quit Parallels Desktop
    3. Uninstall Parallels Desktop
    4. Temporarily disable Antivirus and Firewall on MacOS (I've no antivirus or firewall installed)
    5. Download and install Parallels Desktop, from the below link: http://www.parallels.com/directdownload/pd16/
      Note: Do not start the virtual machine. after the installation
    6. Quit Parallels Desktop
    7. Click Apple icon -> System Preferences -> Security and Privacy -> Privacy Tab -> Accessibility -> Check (enable) Parallels Desktop
      Note: If the options are grayed out, please click the lock from the bottom left corner of the same window to unlock it
      (These option was still checked)
    8. Click Apple icon -> System Preferences -> Security and Privacy -> Privacy Tab -> Full Disk Access -> Check (enable) Parallels Desktop
      (These option was still checked)
    9. Start Parallels Desktop and the virtual machine. Check for the issue
     
  13. LeoL15

    LeoL15 Bit Poster

    Messages:
    5
    Hi DirkM9
    Thank you for the recommendation for solution. I did try the steps provided by you but the same the problem persist.
    Once MacBook goes to sleep, the connection to network will cut off also and I will need to reconnect/re login program like Quickbooks.
     
  14. LeoL15

    LeoL15 Bit Poster

    Messages:
    5
    Hi Maria ,
    I copy new technical report again 367324184. Please help me to rectify this problem.
     
  15. JohnK51

    JohnK51

    Messages:
    1
    Do you have a solution, I have the same problem?
     

Share This Page