Major Mouse Issues

Discussion in 'Windows Guest OS Discussion' started by Eric_Kalpakoff, Dec 16, 2014.

  1. Eric_Kalpakoff

    Eric_Kalpakoff Bit Poster

    Messages:
    3
    Is anyone else experiencing similar issues?

    Running Parallels Desktop 10 for MAC, dual monitors in full screen. Both Windows 7 and Windows 8.1 Pro have major mouse issues. Called support and it was painful at best to watch him troubleshoot the issue.

    Issues are: If dragging a selection box from the top of the screen toward the bottom, the selection box behaves as if the mouse button was release and pressed again while dragging. Same occurs when dragging items around. The mouse button will disengage and reengage while holding the button down and most of the time it causes major havoc like inadvertantly dragging the wrong items, unable to make a selection box or highlight text properly,

    So the tech support guy changed the mouse options in the guest PC config but none of them worked quite normal and basically I had to choose between two options.
    Deal with this issue or have a mouse pointer that jumps around and accelerates erratically. Does anyone else have these issues or can offer better solutions that changing the gaming mouse option in config?
     
    Joel1 likes this.
  2. Mervin@Parallels

    Mervin@Parallels Guest

    Messages:
    202
    Hi Eric_Kalpakoff,
    1) Please turn off "Smart Mouse" on your Virtual Machine. You can configure or disable this feature in the Virtual Machine configuration(http://kb.parallels.com/en/117287) > Hardware -> Mouse & Keyboard.
    2) Try to switch between two options: Optimize for games and Don't Optimize for games in the Virtual Machine.
    3) Enable/Disable smooth scrolling.
    The detailed explanation is given in this link, please follow: http://kb.parallels.com/6909
    If the issue still persists, please provide us the Ticket number via which you contacted Parallels Technical Support, we will check it and help you further.
     
  3. Eric_Kalpakoff

    Eric_Kalpakoff Bit Poster

    Messages:
    3
    I have tried all of these as did tech support when I called.

    Don't Optimize for Games: Mouse movement is smooth and normal. Click and drag is 90% un-usable. mouse button releases at random and presses at random resulting in bad selections or inadvertently dragging wrong items.

    Optimize for Games: Mouse movement is erratic and jumps around the screen, nearly impossible to move pointer to desired position. 100% unusable.

    Smooth Scrolling has no affect on either.
     
  4. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    Use the report a problem under the help menu. Many have this same issue and it definitely needs to be addressed. It feels like OSX 10 grabs the cursor temporarily then you have to click to reactivate the VM thereby losing the click. Definitely something that needs to be fixed and was introduced in the last update.
     
  5. Pankaj Singh

    Pankaj Singh Bit Poster

    Messages:
    2
    I have a Dell studio 1550 Laptop (window 7) , sometime its touchpad doesn't work and cursor comes directly to the bottom of the page . Please share your solution for this issue.
     
  6. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    Parallels is a product on the mac that virtualizes windows. None of this applies to your dell laptop. Sorry.
     
  7. PaulT1

    PaulT1 Bit Poster

    Messages:
    15
    I have also noticed this issue! Wow. It is really bad. Note that it mainly only happens in FULL SCREEN. At least for me.

    I spoke with support for over an hour while he remote controlled my Mac, broke one virtual machine, then moved onto the next one. Installed and reinstalling parallels tools. Why is there not a public bug tracker? This would work so well.
     
  8. easy4tutoring

    easy4tutoring Bit Poster

    Messages:
    7
    Utilize the report an issue under the help menu. Numerous have this same issue and it doubtlessly needs to be tended to. It feels like OSX 10 snatches the cursor incidentally then you need to click to reactivate the VM in this manner losing the click. Without a doubt something that needs to be settled and was presented in the last overhaul.
     
  9. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    Honestly, I got fed up with going around and around trying to get Windows working on the mac, until I realized, I do 95% of all things in Windows, why am I using a Mac. I'll still help around the forums, but moved to PC and still using mac laptop.
     
  10. PaulT1

    PaulT1 Bit Poster

    Messages:
    15
  11. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    They had it working on 9. They "sort of" had it working on 10 in the begining. The cursor changed temporarily but at least it didn't drop (wasn't as smooth as 9). But then some update--dont remember which one, broken it completely. I'd have to guess some sort of yosemite work around, but can't confirm.
     
  12. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    Well that didn't take long. Got really annoyed with Windows back on my Mac hoping Parallels will fix the mouse issue
     
  13. PaulT1

    PaulT1 Bit Poster

    Messages:
    15
    Sorry, what didn't take long?
    BTW, the latest update does not appear to have fixed this for me.
     
  14. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    No, didn't fix it for me either. And now they reintroduced the mac capture issue when you run more than one VM at a time; even though VM has focus, a black mac cursor appears and no hover events happen in the VM. Clicking turns the cursor to windows temporarily, but then letting go changes it back. Moving it around in large circles eventually resets and gets it to capture. Sigh... That DID work for a long time.
     
  15. MagnusL1

    MagnusL1 Bit Poster

    Messages:
    1
    Experiencing the exact same issue here ever since upgrading to version 10. Host is OS X 10.8. VM OS doesn't seem to matter. XP, Windows 7, Ubuntu. "Optimize for Games" solution *does* seem to work, but I really dislike this mode for productivity (I want the same mouse acceleration etc on Mac and Windows). I find it frustrating because the Windows program I mainly use Parallels for requires a lot of "mouse dragging" in the upper screen region. It glitches all the time, and I get mouse clicks all over the place. Makes me regret upgrading to version 10. Eager to hear about any working fixes.
     
  16. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    Latest update still does not fix the issue. Sigh...
     
  17. DevinO1

    DevinO1 Bit Poster

    Messages:
    1
    I was having similar (or same) issue earlier this week on a newly created VM.
    Host: OSX Yosemite 10.10.2 on iMac w/ 3.4GHz intel Core i7 and 32 GB RAM
    Client: Win 7 Pro 64 bit, set to 2 processors and and 8 GB RAM

    Mouse actions were "twitchy", had all symptoms as listed above, selecting text would select only a sub-part of selected area, VM would behave as if I had clicked (or not clicked) the mouse at random. Button clicks would sometimes require multiple SOLID clicks to actuate.

    If working in a client app (browser, text editor, whatever) that had a scroll bar on the side, and I grabbed the scroll bar with the mouse and moved it up or down for more than 1 screens worth of content, the mouse would randomly "disengage" from the scroll bar.

    Tried making the suggested mouse option changes (Optimize / No Optimize for games, scroll options, etc) as listed above. Nothing worked.

    Updated Parallels to version 10.2.0 (28956) and also changed VM settings to 1 Processor and only 4 GB RAM, and the problems seem to have gone away. (Yes, I know I changed more than 1 thing at a time so I can't be sure of WHAT fixed it).

    At this point I'm not willing to change the VM settings back, because I don't want to risk screwing things up again (and possibly not being able to rectify them).
     
  18. PaulT1

    PaulT1 Bit Poster

    Messages:
    15
    The issue only occurs in full screen, when "Use OS X full screen" is checked and when SmartMouse is set to auto or Don't optimise for games.
    It is still broken in the latest version: 10.2.0 (28956).
     
  19. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    Yup! I tried the 1 process thing did nothing for me. Full screen and smartmouse that is not optimized for games is still broken.
     
  20. AlekseyM

    AlekseyM Product Expert

    Messages:
    208
    This is making parallels unusable now. Try selecting all the icons on your desktop. It's impossible now.

    Please submit Help support ticket.

    Help => Report a Problem
     

Share This Page