Mouse Cursor Flickering All The Time

Discussion in 'Windows Guest OS Discussion' started by OguzhanV, Nov 18, 2018.

  1. OguzhanV

    OguzhanV Bit Poster

    Messages:
    5
    I am using my Boot Camp as Virtual Machine. I have this issue from the beginning, but i couldn't find any fix for it. My cursor flicker between macOS' black cursor and Windows' white cursor. Double (sometimes even single) click doesn't work sometimes. How can i fix this, any suggestion?

    [​IMG]
     
    MattF1 likes this.
  2. KristianM2

    KristianM2 Bit Poster

    Messages:
    2
    Best Answer
    https://knowledge.autodesk.com/supp...es-with-AutoCAD-within-Parallels-Desktop.html

    Issue:
    While using AutoCAD with Windows 7, 8, 8.1, or 10 within Parallels Desktop on a Macintosh computer, the program tends to run slow, dialog windows are sized incorrectly, text and menus are the wrong size, and mouse cursor performance is sluggish and not smooth.
    Causes:
    New DPI settings from enhanced screens, such as Retina displays, can cause these problems.
    Solution:
    To improve the performance of AutoCAD within Parallels, change either the video resolution or the mouse setting, or both:
    1. Shut down your virtual machine.
    2. Click the Virtual machine menu and choose Configure and then Hardware (see How to get to the Virtual Machine's Configuration).
    3. Under Video, select either "Scaled" or "More Space" for the resolution choice.
    4. Under Mouse & Keyboard, select "Optimized for Games" for the SmartMouse setting (or simply turn it on for Parallels 7 and 8).
    The path to these settings is slightly different in older versions of Parallels.

    Additionally, turning off hardware acceleration within AutoCAD (see How to enable or disable hardware acceleration in AutoCAD) and/or turning of dynamic input (F12 toggle or change DYNMODE to zero) may help.
     
  3. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Hello OguzhanV, Let us ensure that Parallels Tools are properly installed. Please follow https://bit.ly/2N1mrkW to install Parallels Tools. If you see reinstall or update Parallels Tools then kindly reinstall it.
     
  4. OguzhanV

    OguzhanV Bit Poster

    Messages:
    5
    Reinstalled and restarted but still having the issue.
     
  5. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Kindly go to actions in the top menu bar, Actions--> Configure--> Hardware--> Mouse & Keyboard --> and select ' Do not optimize for games '
     
  6. OguzhanV

    OguzhanV Bit Poster

    Messages:
    5
    I already tried that, but there is no change at all.
     
  7. KebhaK@Parallels

    KebhaK@Parallels Staff Member

    Messages:
    123
    Please let us know your Parallels Desktop version and Mac OS version.
     
  8. OguzhanV

    OguzhanV Bit Poster

    Messages:
    5
    Latest Parallels and Mojave 10.14.1
     
  9. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Kindly check whether the copy of Parallels Desktop up-to-date. To download the latest update go to Parallels Desktop menu > Check for Updates, or download the installation image directly from here.
     
  10. OguzhanV

    OguzhanV Bit Poster

    Messages:
    5
    Yes, i have the latest version installed. I am facing this issue for 3 updates actually, nothing changed with all these updates
     
  11. JeffW7

    JeffW7 Bit Poster

    Messages:
    2
    Hello,
    I had a similar problem on my Windows 10 VM using Parallels 14.1.0 (45387) and macOS Mojave 10.14. With the VM in full screen mode, the flickering cursor would happen every time I moved the mouse from one screen to the other and clicked. It would take a few seconds before the flickering would stop and I could use the mouse in the VM. None of the above suggestions worked for me either.
    However, after upgrading to macOS 10.14.2, the problem appears to have gone away. Perhaps it will correct your problem as well.

    Regards,
    Jeff
     
  12. KebhaK@Parallels

    KebhaK@Parallels Staff Member

    Messages:
    123
    Please start your Windows on native Boot Camp run SFC and chkdsk. Then update your Windows and check the mouse issue on Windows virtual machine.
     
  13. JeffW7

    JeffW7 Bit Poster

    Messages:
    2
    It seems the upgrade to macOS 10.14.2 did not provide a permanent fix to the cursor flicker issue. The issue has returned and is still very annoying. I have to wait several seconds for the flicker to stop before mouse clicks register on a monitor when using multiple monitors in full screen mode
     
  14. natel2

    natel2 Bit Poster

    Messages:
    7
    When the issue didn't occur in safe mode, we can say that the issue is possibly caused by one of your driver or hardware. Can you provide us a screenshot of the blinking circle that is happening on your device? This is to know what kind of troubleshooting is applicable for you.
    To reset your Windows Store cache, follow these steps:
    1. Open Run command by pressing Windows key + R on your keyboard.
    2. On the text box, type WSReset.exe.
    3. Run the troubleshooter again to see if the cache error gets resolved.
     
  15. ChoonginL

    ChoonginL Bit Poster

    Messages:
    2
    I had the same problem for 2 years and have not solved yet. However, when I changed the resolution of VM from [Max/Min] to [Optima to Retina display] in [View] -> [Retina Resolution] the problem totally FIXED! (The tabs might be different because I am using Korean ver., just pure translation.) But the problem is forcefully using retina resolution in VM is not good for displaying legacy applications.
     
  16. MartinP3

    MartinP3 Bit Poster

    Messages:
    3
    No reliable workaround for me except this silly applescript which first focuses the Control Center window and then switches focus to the VM window, causing the cursor to not have its party.
    tell application "System Events" to tell process "Parallels Desktop"
    set frontmost to true
    click menu item "Control Center" of menu 1 of menu bar item "Window" of menu bar 1
    click menu item "Windows10" of menu 1 of menu bar item "Window" of menu bar 1
    end tell​
     

    Attached Files:

  17. ChoonginL

    ChoonginL Bit Poster

    Messages:
    2
    it reduced the time to flicker but still not fixed.
     
  18. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,705
    Hi, are you using the latest version of Parallels Desktop? Also please generate the problem report using this KB article

    Except for that kindly check if the following actions resolve the issue or at least make the delays taking less time:
    1. Shut down Windows
    2. Open virtual machine configuration as described in https://kb.parallels.com/117287 > Hardware > CPU & Memory > Increase memory to 8192 Mb
    3. At the same tab expand Advanced settings and type in the following system flag:
    devices.usb.mouse=2
    4. Start Windows and check if the issue still persists.
    Should it reoccur, collect a fresh technical report right after mouse delay and flickering (move cursor to the top of the screen > Help > Send technical data).
    Please reply us back with one more report ID
     
  19. MattF1

    MattF1 Bit Poster

    Messages:
    5
    I'm also experiencing this exact problem with the mouse cursor flickering anytime I click on a different monitor (I have 3 total). I tried everything recommended in this post but nothing has corrected the issue.

    My technical report id is 296299312
     
    Last edited: Jan 30, 2019
  20. RyanS8

    RyanS8 Bit Poster

    Messages:
    5
    I also tried all the suggestions in this thread.
    Please make this a priority, Parallels. This bug is costing me a ton of time. It takes 5 seconds before the mouse calms down every time I change screens. This adds up to a huge waste.

    My report ID is: 296316186
     
  21. MattF1

    MattF1 Bit Poster

    Messages:
    5
    I just finished chatting with support. After a remote sharing session, this is what corrected the issue for me:
    1. Configuration > Hardware > Graphics > Memory: Auto (Recommended) (VM must be shutdown to change this)
    2. Configuration > Hardware > Mouse & Keyboard > Mouse: Don't optimize for games
    3. Uninstall Parallels
    4. Reinstall Parallels
    5. Verify issue is corrected
    My cursor does still flicker when clicking on a different external display, but just once (instead of 20/30 times like before).
     
    Last edited: Jan 31, 2019
    Maria@Parallels and RyanS8 like this.

Share This Page