Mouse Cursor Flickering All The Time

Discussion in 'Windows Guest OS Discussion' started by OguzhanV, Nov 18, 2018.

  1. RyanS8

    RyanS8 Bit Poster

    Messages:
    5
    How do you uninstall Parallels? I'm exploring the package contents and do not see an uninstaller.
     
  2. MattF1

    MattF1 Bit Poster

    Messages:
    5
    Mac Finder > Applications > drag Parallels to trash.
     
    RyanS8 likes this.
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,835
    @MattF1 thanks a lot for sharing info about reinstalling Parallels Desktop as an solution for the issue. But as I understand your mouse still flicking?
    @RyanS8 what about you? Does the Parallels re-installation help you?
     
  4. MartinP3

    MartinP3 Bit Poster

    Messages:
    3
    Currently on Mojave 10.14.4 Beta (18E174f) and no flicker. But it will probably not last ¯\_(ツ)_/¯
     
  5. RyanS8

    RyanS8 Bit Poster

    Messages:
    5
    The uninstall / reinstall worked! Fingers crossed this holds. FYI I'm running Parallels 11.2.3. Thanks for the help!
     
    MattF1 likes this.
  6. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    You are welcome, Please feel free to reach us any time for any queries regarding Parallels.
     
  7. MattF1

    MattF1 Bit Poster

    Messages:
    5
    It just flickers once, no big deal as there is no impact on the mouse click actually getting registered. I consider my issue resolved.
     
    Maria@Parallels likes this.
  8. MattF1

    MattF1 Bit Poster

    Messages:
    5
    I'm sad to report back that after two days, my cursor flickering issue has returned.
     
    BenK1 likes this.
  9. CurtisW2

    CurtisW2 Bit Poster

    Messages:
    1
    I am also having the same issue (and have for a while). I only came here because it recently started getting excruciatingly slow (5-8 seconds until I can use the cursor). I'm running Parallels 14.1.1, Windows 10 (latest), Mojave 10.14.3. I tried everything on this post, and the only thing that helped was reinstalling parallels (not parallels tools).

    The sad news is, the flickering still persists, however it flickers much quicker so it is less noticeable and becomes usable in about 1-2 seconds.

    Update: it appears that the CPU (or graphics?) usage of the guest OS affects the speed of the flicker.. while in use, I'm still seeing the flickering for 3-5 seconds.
     
    Last edited: Feb 6, 2019
  10. DanielS36

    DanielS36 Bit Poster

    Messages:
    1
    I am having this same exact problem. It is basically halting all my work in Windows. I use Parallels to run AutoCAD LT in Windows 10. It was working fine until about a week ago. Now whenever I start up a VM session, AutoCAD is basically useless because the mouse continuously flickers between Mac and Windows cursor.

    - I upgraded to the newest version of Parallels.
    - I un-installed and re-installed Parallels
    - I un-installed and re-installed Parallels Tools
    - I changed the mouse settings to both "Auto-detect for Games" and "Don't optimize for games"
    - I changed the mouse settings inside Windows per ticket 116990. (Make from standard windows scheme to another, does not fix. Change back, does not fix.)

    Please help! I cannot use Parallels VM at all to do any work with this issue!
     
  11. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,835
    Thanks a lot for the detailed description. Please reproduce the issue and generate the problem report right after that. Check this article for more info about the report and reply us back with the report ID.
     
  12. BenK1

    BenK1 Bit Poster

    Messages:
    10
    Answers like this ... useless
     
  13. BenK1

    BenK1 Bit Poster

    Messages:
    10
    You're right - If control center goes active before the VM, it doesn't happen. Proving that it's a completely unnecessary behavior that should have been fixed long ago.
     
  14. BenK1

    BenK1 Bit Poster

    Messages:
    10
    This issue is starting to drive me insane
     
  15. Ross1

    Ross1

    Messages:
    1
    Seems to be fixed with latest update version 14.1.3 (45485)

    Windows cursors were not working so it would flicker back and forth between the active windows cursor and the Mac cursor.
     
    Maria@Parallels likes this.
  16. ZhefangW

    ZhefangW Bit Poster

    Messages:
    1
    I have this issue too. My solution is remove a application "dozer" https://github.com/Mortennn/Dozer
    I guess some "dozer" like application will get the cursor status, so it would flicker back and forth between the active windows cursor and the Mac cursor.
    :)
     
  17. Andreas76

    Andreas76 Bit Poster

    Messages:
    5
    Same here.
    • Clean Installed system
    • RAM 8.192
    • Mouse is set to "Don't optimize for games"
    • Latest Parallels Version 14.1.3 (45485)
    • Un- and reinstalled Parallel Tools
    • Ticket 314657493.

    This is my 5th clean install and every time some problems appeared.

    This is very annoying and disappointing. Nice that parallels is advertising good performance and gameplay for their product but I'm not able to set up a serious clean systems without having this kind of basic problems.
    Im still in trial period but have no good experience at all. Hope Parallels can provide me additional trial time when problems are solved.
     
  18. KristianM2

    KristianM2 Bit Poster

    Messages:
    2
    Best Answer
    https://knowledge.autodesk.com/supp...es-with-AutoCAD-within-Parallels-Desktop.html

    Issue:
    While using AutoCAD with Windows 7, 8, 8.1, or 10 within Parallels Desktop on a Macintosh computer, the program tends to run slow, dialog windows are sized incorrectly, text and menus are the wrong size, and mouse cursor performance is sluggish and not smooth.
    Causes:
    New DPI settings from enhanced screens, such as Retina displays, can cause these problems.
    Solution:
    To improve the performance of AutoCAD within Parallels, change either the video resolution or the mouse setting, or both:
    1. Shut down your virtual machine.
    2. Click the Virtual machine menu and choose Configure and then Hardware (see How to get to the Virtual Machine's Configuration).
    3. Under Video, select either "Scaled" or "More Space" for the resolution choice.
    4. Under Mouse & Keyboard, select "Optimized for Games" for the SmartMouse setting (or simply turn it on for Parallels 7 and 8).
    The path to these settings is slightly different in older versions of Parallels.

    Additionally, turning off hardware acceleration within AutoCAD (see How to enable or disable hardware acceleration in AutoCAD) and/or turning of dynamic input (F12 toggle or change DYNMODE to zero) may help.
     
  19. KristianM2

    KristianM2 Bit Poster

    Messages:
    2
    Actually, the above didn't work for me. I'm trying disabling the graphics/hardware acceleration from within AutoCAD now.
     
  20. Andreas76

    Andreas76 Bit Poster

    Messages:
    5
    I´m not using AutoCAD. Flickering appears directly after booting and just using small tools like Total Commander. Did you have had a look at my problem report ?
    However, my trial period is over and I just spend the time in (re-)installing, reconfiguration, and waiting for support. Do you want to give me additional trial period ?
     

Share This Page