no Internet connectivity on Parallels 19 running macOS 14

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by MHWill, Oct 19, 2023.

  1. VitaliiA1

    VitaliiA1 Bit poster

    Messages:
    2
    For me it does not help. Version 19.2 and I still don't have network :(
     
  2. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    499
    Hello Vitalii!
    Would you reproduce the issue again and collect a technical report while the issue is being reproduced (click Parallels icon > Help > Send technical data > check "Attach screenshots..." > press Send Report). Once done, kindly send the report's 9-digit ID in your reply to this post.
     
  3. Andrew78

    Andrew78 Bit poster

    Messages:
    1
    I am also seeing this issue on macOS 14.2.1 (23C71) with Parallels 19.2.

    I've tried switching between bridged and shared mode with


    prlctl set macOS --device-set net0 --type bridged

    I have sent a technical report:
    Technical report 445969143 has been sent to Parallels.
     
  4. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    80
    Hello.

    Thank you for the data. Could you let us know the steps that lead to the issue occurring, apart from starting the virtual machine, if such are present. Do you happen to observe symptoms other than lack of connectivity on macOS virtual machines?

    If possible, please check if the issue can be reproduced if the network connection affecting applications, such as AnyConnect or Falcon are temporarily disabled, if that is possible.

    Thank you.
     
  5. PatrickvE

    PatrickvE Bit poster

    Messages:
    2
    Hello, I am having the same problem. After updating to macOS Sonoma 14.2.1 (23C71), no more internet in Windows.
    Parallels Desktop 19 for Mac Business Edition Version 19.2.1 (54832)
    The workaround with the NAPT connector seems to work for half an hour. Spent 2 days trying and resetting all network related settings in Mac, Parallels etc.
    Report ID 447033241 is generated.
    The only way to get internet in Windows, is to change Shared Network to Bridged Network > WiFi. The Windows NIC is receiving an IP in the Wifi range.
    Is there any chance this could be fixed?
     
  6. ParallelsU649

    ParallelsU649 Bit poster

    Messages:
    1
    Same issue. Guest OS is Sonoma (14.2.1) running on a Sonoma (14.2) host using 19.2.1.
    Report ID: 447565429
     
  7. JoeH18

    JoeH18 Bit poster

    Messages:
    1
    Same problem. I don't have any internet access as long as Parallels is running, even if the virtual machine is not running. I've had this problem since version 17. The fixes are always temporary and the problem always comes back.
     
  8. PatrickvE

    PatrickvE Bit poster

    Messages:
    2
    A complete wipe / reinstall of Mac Sonoma and Parallels fixed my problem. Probably only reinstalling Parallels should have been enough.
     
  9. ZevS1

    ZevS1 Bit poster

    Messages:
    1
    I am on a Macbook running Sonoma OS. I followed the instructions suggested earlier in this thread (to update this: <SystemFlags>devices.net.use_naptd_for_macvm=0</SystemFlags> in terminal), and I am still having the same issue.... As soon as I open Parallels 19 (same issue with 18), my internet connection is lost. Once I close the program, my internet connection is restored. I do not have to run the VM for this issue to happen. I also can't send any technical data since I don't have connection with the app open.
     
  10. WolfgangH14

    WolfgangH14

    Messages:
    1
    Still no Internet connection with parallels 19.2.1.
     
  11. KarapetA

    KarapetA Bit poster

    Messages:
    1
    The issue is that both the VM and Host attempt to obtain an IP address from DHCP using the same MAC address by default.
    Have you tried these settings?
     

    Attached Files:

  12. JK67

    JK67 Bit poster

    Messages:
    3
    Same problem. REALLY FRUSTRATING. Makes Parallels totally useless. I have a business account.
    Internet working totally fine on the Mac side. Dead on the Windows side.

    Technical report submitted: 453484655
    Parallels Version 19.3.0 (54924)
    macOS 14.1 (23B74)

    Please fix or help.
     
  13. JK67

    JK67 Bit poster

    Messages:
    3
    I called support, and the agent said it can be due to an antivirus firewall running or VPN blocking internet but he thought in my case the prior Windows installation was somehow corrupted. He accessed my computer remotely and installed Windows from scratch, and that fixed the internet problem.
    Thank you Parallels!
     
    Adeboye Adeotan likes this.
  14. BobbyH3

    BobbyH3

    Messages:
    1
    This fixed my and another person's issues in the most recent parallels. The latest update caused connectively issues.
     
  15. DanielF26

    DanielF26 Bit poster

    Messages:
    1
    Maybe this helps someone: I had the very same problems described in this (and other threads) - nothing helped. No shared networking in a Win-11 vm for me. This is especially problematic since using the VPN via MacOS didn't work either. I experienced these problems since upgrading to MacOS 14.4.
    I got it back working by switching off DHCP and manually changing the IP address inside the VM to 10.211.55.3, subnet mask 255.255.255.0 and dns server to 10.211.55.1. I think the VMs are not able to reach the Parallels DHCP server. Another hint I found was to give defender and parallels full disk access (our Mac is company managed).

    Maybe these clues help another user or even Parallels to find a workaround/patch. I am pretty sure that this is not a Parallels problem but rather a MacOS problem. I temporarily switched back to Parallels 18 with no success to verify this.

    Daniel.
     
  16. LawrenceMk4

    LawrenceMk4

    Messages:
    2
    After a year of on and off with the same problem i found a solution that works every time:

    I just plain and simple run the maintenance script of the software OnyX or something that does similar stuff, specifically rebuild _ds.store - after that it restarts your mac and closes all programs!

    [​IMG]
     
  17. LawrenceMk4

    LawrenceMk4

    Messages:
    2
    NOTE: VPN sometimes fixes the problem too, I use perfect privacy as VPN and some servers work, some don't...
     

Share This Page