Painfully Slow internet on Windows

Discussion in 'Installation and Configuration' started by Myles, Jun 13, 2018.

  1. Myles

    Myles Bit Poster

    Messages:
    3
    Just installed Parallels 13 on my iMac and have bought Windows 10. However, download speed from the Windows 10 virtual machine is painfully slow. Have the config optimisation set to No limits. Pretty much everything is default settings as I have just installed.
    Any clue why Windows download speed so slow? Is there a setting somewhere I need to change?

    Thanks in advance.
     
  2. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    752
    Hello Myles, Let us ensure that Parallels Tools are properly installed. Please follow this link to install Parallels Tools. If you see reinstall or update Parallels Tools then kindly reinstall it. Kindly go to Actions--> Configure--> Hardware--> Network1--> change the source to Bridged ( Default adapter ) and check if it helps.
     
  3. Myles

    Myles Bit Poster

    Messages:
    3
    Great. Yes thanks. That has done the trick.. Out of interest, what is going on there?
     
  4. Setting the network source to 'Default Adapter' will obtain the IP address directly from the router/modem. Hence, you will get the maximum network speed in the virtual machine also.
     
  5. Myles

    Myles Bit Poster

    Messages:
    3
    Gotcha. Not sure why that is not the default setting therefore?
     
  6. By default, the network source will be in 'Shared'. However, you can change the settings based on your requirements or if you experience issues with the 'Shared' network option.
     
  7. lorein

    lorein Bit Poster

    Messages:
    24
    Modify the internet bandwidth settings as Windows 10 reserves 20% of internet bandwidth for system applications & OS, and you can't browse the internet with 100% internet connection. So trim the internet bandwidth settings
    • Press Win + R key > and in Run dialog box > type gpedit.msc > OK.
    • Give permissions now a pop-up window open with the title of Group Policy > then click on Computer Configuration
    • Then go to Administrative Templates > Network > Qos Packet Scheduler > Limit reservable bandwidth.
      Click on Enable > change the Value from 20 to 0.
    • Click Apply > click OK

    Also disable the Firewall temporarily and flush the DNS record. Hope these tricks works for you to fix Windows 10 slow internet issue
    Source: http://www.pcerror-fix.com/windows-10-slow-internet-fixed
     
  8. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    2,673
    We are glad you have shared these steps for everyone here.
     
    lorein likes this.
  9. SaschaK4

    SaschaK4 Bit Poster

    Messages:
    3
    I have the same problem. Downloading in speeds of 350kb/s. Tried to switch to bridged with no success.
    Then i checked the checkbox "Network Conditioner" and kept the Profile to "Custom". From that point I download in 20/30 MB/s.
    Disabled the "Network Conditioner" again, speed falls down immediately.
    Is this a bug? I thought the Network Conditioner is only for simulations!?
     
  10. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,673
    Hello, what is your Parallels Desktop and macOS version?
     
  11. SaschaK4

    SaschaK4 Bit Poster

    Messages:
    3
  12. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,673
  13. SaschaK4

    SaschaK4 Bit Poster

    Messages:
    3
    Ok, i generated two tech reports.
    1) 352500607 this one has the "Network Conditioner" Checkbox checked; i dowloaded the 4.31 GB iso image from http://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-DVD-x86_64-Current.iso. it took me about 4 minutes.
    2) 352500848 this one has the "Network Conditioner" Checkbox unchecked; tried to download the same iso image; chrome shows me an estimate of 4,5 hours; while it is downloading i generated the tech report
    Also did a recording that shows the issue, and uploaded it to my dropbox: https://www.dropbox.com/s/pmojidpijrkrjuu/Screen Recording 2020-10-22 at 19.08.12.mov?dl=0
    Hope that helps.
     
  14. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,673
    Thanks a lot!
    Could you please update your Parallels Desktop to the latest build 16.1.0 and check the issue.
     
  15. Petrhaus

    Petrhaus Bit Poster

    Messages:
    3
    Hi, I have the same bug, even with 16.1.0.
    I need to turn on the network conditioner to get full network speed.

    Thanks.
     
  16. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,673
    Hello, could you please provide us with more information about the issue?
    Please collect the tech report once the issue reproduced and post the report's ID here.
    Take screenshot of the network speed and share it with us.
    Any other details will be very helpful.
     
  17. Petrhaus

    Petrhaus Bit Poster

    Messages:
    3
    The details are the same as reported by SaschaK4.
    With the network conditioner off, the network speed is tremendously slow, so we need to keep it active and with a custom profile.
     
  18. KristianS1

    KristianS1 Bit Poster

    Messages:
    35
    You're not losing 20% of your bandwidth with the default setting. It just allows Windows to reserve up to 20% when doing background downloads e.g. Windows updates.
    I wouldn't mess around with that setting.
     
  19. Petrhaus

    Petrhaus Bit Poster

    Messages:
    3
    Unfortunately this has nothing to do with the problem reported, the problem is in the network conditioner settings. I have a (real) 600mbit connection and the speed drops to 1-2mbit with the network conditioner off.
     
  20. KristianS1

    KristianS1 Bit Poster

    Messages:
    35
    Essentially what I was pointing out. Hopefully so that other people don't go down a rabbit hole of changing dozens of settings.
     

Share This Page