Parallels 13 macOS Sierra High Windows 10 slow performance

Discussion in 'Windows Guest OS Discussion' started by PatrickG5, Oct 14, 2017.

  1. FernandoR3

    FernandoR3 Bit Poster

    Messages:
    3
  2. FernandoR3

    FernandoR3 Bit Poster

    Messages:
    3
  3. BradyM1

    BradyM1 Bit Poster

    Messages:
    1
    Best Answer
    After tearing my hair out for a month with these same symptoms, I finally found a fix. Anyone having slow performance who uses Avira, a simple solution awaits you at:
    http://kb.parallels.com/en/124336
    Parallels is beautiful once again!
     
  4. mark29

    mark29 Bit Poster

    Messages:
    1
    I have the same problem. Each time when Parallels updates to a new version they promise it "will be faster than the last version" and it never seems to be. I have a new Mac book pro (2017) with Windows 10 and it still seems to be slow running W10. Also all the menus are extremely confusing and not intuitive.
     
    LeeM4 likes this.
  5. eriklarshansen

    eriklarshansen Bit Poster

    Messages:
    7
    I too have been incredibly bugged at how my entire system came to a screeching slowdown with the upgrade to the new Parallels. I just bought a new iMac Pro and hoped this would solve the problem, but the 5 to 6-minute boot up still took place. I unchecked the USB 3.0 box, and now it is flying again. Thank you very much for figuring this out and hopefully Parallels will fix this bug so that people can turn this feature on again. The only thing I'm really running off USB 3.0 is my Time Machine drive so I don't need the capability.
     
    LeeM4 likes this.
  6. LeeM4

    LeeM4 Bit Poster

    Messages:
    1
    This is infuriating. I can't believe a fix hasn't been found yet.
    I am running a Mac Pro, with 12 cores, tons of RAM, Windows 7 and gaming under Parallels has always been great, however, after the last update, its UNUSABLE!!!

    PLEASE FIX THIS!!!!
     
  7. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Hi @LeeM4, need more details on the situation you're having. I've created a support request for you, our team will contact you soon.
     
  8. AvivR

    AvivR Bit Poster

    Messages:
    1
    I don't know if this will help you all, but I just found a solution to my instance of this problem: Turn off 3D Acceleration. My performance went from unusable to decent (not blazing, but good enough to get work done).
    • Make sure your VM of Windows 10 is shut down.
    • In the control center, click on your Windows 10 VM's gear icon, or right click on the VM and select "Configure..."
    • Hardware (on top) -> Graphics (in the left pane) -> Advanced Settings (in the right pane)
    • Set "3D Acceleration" to "Disabled"
     
    Tim Shea likes this.
  9. GeorgeH4

    GeorgeH4 Bit Poster

    Messages:
    4
    I find the Parallels support response on this thread pathetic (sorry guys). It is obvious there is problem here with Parallels 13. I used to be a Parallels user some time ago and after getting a 2017 iMac it was my first choice to run Windows on it. I was appalled to see unbelievably slow performance of Windows under Paralles 13 from booting to general use. Oh well, good thing I didn't commit to a purchase, exploring other options now - Fusion, VirtualBox..
     
    LeeM4 likes this.
  10. GeorgeH4

    GeorgeH4 Bit Poster

    Messages:
    4
    AvivR, I tried but disabling 3D accel. didn't make a difference.
    I feel the slowness is caused by poor disk transfer rates.
    After Windows finally opens I open Windows Task manager and watch Read speed value under Performance>Disk.
    This value spikes to 70MB/s on my 100.00 USD, 5 year old Thinkpad equipped with SSD but on the 2017 iMac it barely goes to 5MB/s. There clearly is an issue with hard disk access rates whether that is caused by antivirus software (as mentioned above) or poor hypervisor implementation I don't know. Either way I will not be buying Parallels 13 because this is just a joke.
     
  11. GeorgeH4

    GeorgeH4 Bit Poster

    Messages:
    4
    Hi, which version of Parallels do you use and which version of MacOS? Everywhere I read people are complaining of slowness under High Sierra - Parallels 12 and 13. I tried Fusion and while it feels a bit better than Parallels it is still not what I expect as acceptable.
     
  12. GeorgeH4

    GeorgeH4 Bit Poster

    Messages:
    4
    OK, I resolved my issue by installing a fresh High Sierra (deleted the HD prior to the install). Windows on Parallels 13 is running fine now. It seems something was messed up with the previous High Sierra install (which was an update from a previous version).
     
  13. MatsM

    MatsM Bit Poster

    Messages:
    1
    After unstalling the latest update of Parallels 13 it is impossible to work. Open a program in Windows can take minutes, open or save a file ten times longer. Is it possible to reinstall Parallels 13 without this latest update?
     
  14. WarBirD

    WarBirD Bit Poster

    Messages:
    2
    Is there a way to do that with Kaspersky ? I am not good with Console stuff. But since I installed Kaspersky, things are slow as hell and even Kaspersky starting takes forever after boot of that Virtual W10. Any help getting that fixed like the other one ? I really appreciare any help.

    Thanks so much.
     
  15. Tim Shea

    Tim Shea Bit Poster

    Messages:
    3
    Thanks. This solved my problem.

    Just upgraded to a new 2017 MacBook Pro 15" (16 GB RAM, High Sierra) driving an external 4k monitor through USB. Parallels 13, Windows 10 Pro 64-bit. VM ran fine on the Mac screen. Not on the 4k monitor. Black screen, lags, etc.

    This resolved when I turned off acceleration (as above). (Stop VM, then Configure->Hardware->Graphics.) The VM then ran, but (to me) seemed slightly laggy.

    So I increased video RAM to 1 GB. The VM then ran well on the external monitor.

    Finally, I tweaked my Graphics settings to:
    • Memory: 1 GB.
    • Resolution: "Best for external displays"
    • Advanced: 3D acceleration: DirectX 10
    • Vertical synchronization: Off.
    • Automatic graphics switching: Off.
    Performance is great at 4k resolution, running Windows 10 as a full, single screen on the larger monitor.
     
    TobyF1 likes this.
  16. TobyF1

    TobyF1 Bit Poster

    Messages:
    2
    'Also my MacBook Pro gets hot when im on the VM, independent from what I am doing. What can I do to get a better performance without let my macbook running hot.'

    This, in general, means excessive pressure on your system. I would first ensure any junkware is not making a mess, check for bugs like Auto Fixer https://macsecurity.net/de/view/195-remove-mac-auto-fixer-virus
     
  17. RachelB1

    RachelB1 Bit Poster

    Messages:
    2
    I have a pretty new (9 months) 21.5 iMAC with a Fusion HD and 8 GB of RAM. Mac OS is High Sierra and Windows 10. Initially when I installed Parallels it seemed to be working fairly well. Last couple of months the whole computer (Windows and Mac side) becomes unusable after I use it after a few hours after a reboot. Windows is already a bit slow from the start. Mac OS apps become very slow to just open as I keep getting the spinning wheel.

    All I do under Windows is Quickbooks. And I don't really have much open in Mac OS other than a browser for email and browsing, and a PDF document + a Numbers worksheet at any given time.

    I am trying to figure out if upgrading to 16 GB would help any or 8 GB should be fine for this setup. I wouldn't think it's a problem since I don't really have much open.
     
  18. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Hi @RachelB1, you're right about 8 GB, it should be enough for both Mac and Windows with Quickbooks. Can you please send us a technical report collected right after you notice performance issues? Go to Help menu > Send Technical Data... Please post the report ID here.
    Additionally, you can open Activity Monitor and check CPU, RAM and disk usage. What applications are in the top? Attach screenshots please.
     
  19. RachelB1

    RachelB1 Bit Poster

    Messages:
    2
    Thank you. I will when the problem happens again. The last change I made is to turn off TRIM.

    I have a Fusion drive, do you know if TRIM needs to be turned on or off ? I've read that if the HD is SSD it should be turned on. If it's not, then it should be off. I imagine it needs to be off since with Fusion only MacOS system files reside in the SSD portion.

    Thanks
     
  20. ArtistW

    ArtistW Bit Poster

    Messages:
    26
    The same here since the update to Parallels 14 - iMac, MacOS Sierra, 3.1 GHz, 16GB RAM, Fusion Drive.
    Windows 10 takes between 6 and 9 minutes to start.
    Parallels Support has tried everything - they said there seems to be a problem with the Fusion Drive, waiting for the next update.
     

Share This Page