Parallels 15 (Pro) Desktop very slow on iMac Pro

Discussion in 'General Questions' started by ChristianS27, Aug 19, 2019.

  1. ChristianS27

    ChristianS27 Bit Poster

    Messages:
    1
    Hey guys,

    upgraded to Parallels 15 (had 14 Pro before) newest Windows 10 VM running, it was smooth so far.
    Now since the Upgrade its running very slow.... especially using Chrome is taking ages to load, Edge Browser much faster. General Performance is not that good... what can I do? (

    System is:

    CPU: Intel Xeon W 3,2 GHz (8 Core) (assigned 16GB of Ram and 8 Cores to Parallels)
    RAM: 32GB
    Radeon 56
    1TB SSD

    I can't use it to work with it anymore so far.
     
    JeffS15 and kba like this.
  2. UserQR43

    UserQR43 Bit Poster

    Messages:
    1
    Running into similar issues. Also running on an iMac Pro. Unable to move around in Excel quickly. Scrolling has a 1-2 second freeze and lag
     
    JeffS15 and kba like this.
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    4,190
  4. FrancisT1

    FrancisT1 Bit Poster

    Messages:
    1
    I have the same issues. Tried the steps in the KB article below but didn't fix the problem. My Mac becomes so slow when I open Parallels I can barely work. This happened after the upgrade from 14 to 15.
     
  5. MarkG17

    MarkG17 Bit Poster

    Messages:
    3
    I have the exact same issue on my MacBook Pro running Mojave. Going to try to uninstall and go back to 14
     
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    4,190
    Guys, does the Mac and VM became slow at all or with any specific app?
     
  7. MarkG17

    MarkG17 Bit Poster

    Messages:
    3
    In my case it was immediately upon upgrading from 14 to 15. And it was evident as soon as the VM booted. Not only did it take forever to start up, it was painfully slow with every app. And it took a few minutes to suspend as well. I had no choice but to revert to 14. Now my VM and it's apps are back to running at normal speeds. I will not reinstall 15 (nor will I recommend it to anyone) until the issue is resolved. It really is un usable in it's present form
     
    JeffS15 likes this.
  8. MarkG17

    MarkG17 Bit Poster

    Messages:
    3
    In my case it was immediately upon upgrading from 14 to 15. And it was evident as soon as the VM booted. Not only did it take forever to start up, it was painfully slow with every app. And it took a few minutes to suspend as well. I had no choice but to revert to 14. Now my VM and it's apps are back to running at normal speeds. I will not reinstall 15 (nor will I recommend it to anyone) until the issue is resolved. It really is un usable in it's present form
     
  9. KimD4

    KimD4 Bit Poster

    Messages:
    4
    Same here.

    Macbook Pro 15inch 2016
    2.7GHz i7
    16GB 2133 LPDDR3
    Radeon Pro 455 2GB
    512GB SSD
    Mojave 10.14.6

    After upgrading to Parallels Desktop 15 from 14, Excel (2019 version) starts to become too slow to use. Scrolling lags all the time so that it's nearly impossible to work with it. After several reinstallations, I finally gave up and moved back to 14. Everythings seems to be fine with 14.

    Parallels needs to fix it soon.
     
  10. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    4,190
    Guys, please reproduce the issue and collect the tech.report right after that.
    Please post the report's ID here.
     
  11. ShekerK

    ShekerK Bit Poster

    Messages:
    2
    I'm having simillar problems. On Paralells 14 everything ran smooth. After update everything is much more slower. I personally find it the most annoying when trying to scroll down an Excel file. It jumps 100 rows after 1-2 seconds of not doing anything. Here is my technical data report number 322265148. Please help.
    Thanks,

    Sheker
     
  12. Phani

    Phani Bit Poster

    Messages:
    5
    I have the exact same problem. Raised a ticket with Parallels and sent technical data of both parallels 14 and 15 for comparison. I was thinking of doing a clean install, but looking at the comments here, I will better skip that and go back to parallels 14. Can't see any difference between 14 and 15 anyways
     
  13. SteveF6

    SteveF6 Bit Poster

    Messages:
    2
    I had exactly the same issue (upgraded to 15, Mojave as host OS). My W10 VM was incredibly slow. I looked at the KB article https://kb.parallels.com/117114 to do with interrupt storms, but there nothing shown up by the utility Parallels has provided to check.
    In the end I've downgraded back to 14 and so far things seem to be better.
     
  14. ShekerK

    ShekerK Bit Poster

    Messages:
    2
    Where can I find the link to downgrade??
     
  15. SteveF6

    SteveF6 Bit Poster

    Messages:
    2
    Direct link is: https://my.parallels.com/desktop/downloads?product=pdfm
    you'll need to select the version you want (14) from the drop-down. You can just install 14 over the top of 15.

    In case there's a redirect and you need to navigate to the downloads page ...
    Log into my.parallels.com, go to the dashboard, in the 'Products' section, in the 'Parallels desktop' section, click on 'Active Subscriptions'. There should be a 'download' link at the top right hand side, click that. Choose the version you want from the dropdown, then you should be shown a link to download v14.
     
  16. Abhishek@Parallels

    Abhishek@Parallels Staff Member

    Messages:
    19
    You can download the installer file for Parallels Desktop 14 from https://bit.ly/2G8eIlW .
     
  17. PederL

    PederL Bit Poster

    Messages:
    1
    Have the exact same problem. Can't even work in Microsoft PowerPoint on the VM.
    MacBook Pro 2018
    32 GB RAM (16 GB on VM)
    6 Cores 2 cores for VM
     
  18. TedPar

    TedPar Bit Poster

    Messages:
    1
    I just wanted to add to the thread that I'm also seeing the same behaviour since upgrading from v14 to v15, my Windows 10 virtual machine is running very slow compared to what it used to with v14, the reduction in speed was apparent after the upgrade. I'm running on a MacBook Pro 2016.
     
  19. PaulG12

    PaulG12 Bit Poster

    Messages:
    5
    I have the same issues list in this thread. My report id is 323165377.
     
  20. Phani

    Phani Bit Poster

    Messages:
    5
    After sharing the technical data with Parallels, I have also shared Windows Performance Analyser trace, still awaiting an update...
    In the mean time, I did a clean install of macOS and then Windows 10, but still the same issue. :(
     

Share This Page