Parallels 6 is doubling pasted text

Discussion in 'Installation and Configuration' started by gradkal, Sep 20, 2010.

  1. gradkal

    gradkal

    Messages:
    7
    Hi,

    I often use copied text from Mac OS X in Windows and vice versa. If I have in Parallels preferences/keyboard "activate system-shortcuts of Mac OS X" (right translation? Sorry, I´m german) marked and try to paste copied text from Mac OS X into a Windows-application Parallels doubles the text. Vice versa it works well. This bug is very annoying. Without marking paste of text works both ways right. I would like the new feature having the additional shortcuts in Windows, but as long as it doubles the text, the disadvantages prevail.
     
  2. joevt

    joevt Kilo Poster

    Messages:
    1,205
    Does enabling "Optimize modifier keys for games" help?
    Virtual Machine -> Configure -> Options -> Advanced
     
  3. gradkal

    gradkal

    Messages:
    7
    Thanks for the tip. Unfortunately it brings no difference if this feature is marked. But what I realized now is, that it has to do with using "Command + V" in Windows. This keyboard-shortcut is causing the text-doubling. If I use "Control + V" in Windows or go via the menu "Paste" the text will be inserted in every Windows-app correctly. So, for me that´s usable. But it keeps a bug. I hope, they will fix it in the next release.
     
  4. joevt

    joevt Kilo Poster

    Messages:
    1,205
    I don't have this problem with Command-V and "Enable Mac OS X system shortcuts".

    Do you have Cmd-V -> Ctrl-V in the Parallels Desktop keyboard preferences?

    Do you have anything specified in the Mac OS X System Preferences Keyboard Shortcuts that might affect Cmd-V?

    Which version of Windows are you using?

    Are you using Window mode or Coherence mode?
     
  5. gradkal

    gradkal

    Messages:
    7
    I´m using Windows XP SP3 in Coherence Mode.

    There is no difference if I have "Cmd V --> Crtl V" checked or unchecked. As long as I use "Cmd V" in Windows with enabled Mac OS X system shortcuts it doubles the text. I don´t have any special keyboard shortcuts defined. There is also no difference between Window Mode and Coherence Mode.

    So, for the next time I will stay with "Ctrl V" in Windows. Not a big issue.
     

Share This Page