Parallels Business license not activating

Discussion in 'Installation and Configuration' started by MacF2, Feb 20, 2019.

  1. MacF2

    MacF2 Bit Poster

    Messages:
    1
    My company recently renewed a Parallels Business license for 3 users, but we cannot get the license to activate properly anywhere. I have tried on the existing Parallels account of one of the users, and it appeared to activate at first. But now the Business license is nowhere to be found in his Parallels account, and he is still receiving notifications that his license has expired. I have also tried to activate the license on my own Parallels account, but that results in an error that the "license is already registered in another Parallels account."

    Basically, I need a way to deactivate the license on the personal user's account and move it to my own account for distribution. But since I cannot see it on his account, I cannot work with it at all. These users' Parallels installations will expire in 5-6 days, so I really need to solve this ASAP.
     

Share This Page