Parallels causes Excel 2008 (Mac) slowness

Discussion in 'General Questions' started by bgstults, Feb 28, 2008.

  1. John@Parallels

    John@Parallels

    Messages:
    6,343
    Does anyone else have this configuration?
    Office in Boor Camp, and MS Office 2008 in Mac
     
  2. bgstults

    bgstults

    Messages:
    19
    So I replicated my Windows configuration exactly, this time using VMWare Fusion. I figured this was the only way to see if the problem really is on the Parallels side, or whether it's some sort of weird co-existence of Microsoft programs together that was causing the issue.

    Turns out that it doesn't happen under VMWare. Thus, it's most definitely an issue on the Parallels side -- combined likely with some combo of other circumstances, of course.

    It's too bad, because Parallels kicks VMWare's butt when it comes to smooth coexistence of Windows and Mac Apps and documents together in the same shared environment. I really wish you folks at Parallels were able to replicate this, because it's a truly dealbreaking bug for me. I'm happy to send you any sort of information that might help you track it down.
     
  3. John@Parallels

    John@Parallels

    Messages:
    6,343
    But we are not able reproduce situation
     
  4. bgstults

    bgstults

    Messages:
    19
    Alright, so here's a little more information that could help in reproducing it.

    I've found that I can get the problem to mostly go away -- temporarily -- if I delete *all* the Office preferences. Then, over the course of the workday, it will gradually creep back up. Quitting and re-opening Excel provides a temporary fix, but it eventually will revert to the old behavior.

    It seems a lot like some sort of resource lock. But in terms of reproducing it, maybe this gives something to go on.
    * Keep Outlook open
    * Work in the Mac environment for a workday
    * Look for changes in Excel responsiveness over the course of the day
     
  5. John@Parallels

    John@Parallels

    Messages:
    6,343
    Well let us take a look,
    I installed Vista in Boot Camp -without SP1, and office 2003
    Excel and Entourage , Boot Camp VM with Outlook connected to Exchange(3000 mail p/d) were on all day, Memory usage increased in Mac OS, but for Microsoft Excel 2008 in Mac OS(this is the same behavior as without Parallels)- in my case about 500MB in Virtual memory (as on Mac without Parallels)
    I used early MB model, for stress test CD 1.83 2 gb memory
    I still cannot see anomaly either in Parallels behavior or in Microsoft Office for Mac (memory leak is normal for it - they did some fixes in the latest update - I didn't install it either)
     
  6. bgstults

    bgstults

    Messages:
    19
    One variable in your setup might be the operating system itself. In my case, it's Windows XP (SP2 and SP3). In yours, it's Vista. I would test that on my end, but I actually don't have a copy of Vista to do so.

    To give some memory usage data points, here are the top 10 processes as reported by Activity Monitor in descending order of real memory usage
    Parallels Desktop - 643MB real, 1.81GB virtual
    Firefox - 215MB real, 1.21GB virtual
    Microsoft Word - 138MB real, 1.20GB virtual
    DashboardClient - 80MB real, 993MB virtual
    Microsoft Excel - 55MB real, 1.02GB virtual
    Finder - 44MB real, 1.05GB virtual
    Adium - 41MB real, 1.01GB virtual
    Remote Desktop Connection - 35MB real, 964MB virtual
    Colloquy - 26MB real, 953MB virtual
    Activity Monitor - 25MB real, 1.02GB virtual
     
  7. John@Parallels

    John@Parallels

    Messages:
    6,343
    I did earlier test with Windows XP , but didn't work the whole day,
    as for Microsoft Excel 2008, in the begining it gives
    real 60 virtual 1.12
    at the end of the day
    real 200 (1 sheet opened with few formulas in it) 1.5 virtual
     
  8. jackybe67

    jackybe67 Kilo Poster

    Messages:
    467
    I work with exel 2007 about 1 year and it is very fast......xp,build 5608 , memory 760 mb (total 2 gb)

    Also no problems with office Mac 2008 + parallels..........
     
    Last edited: Jul 28, 2008
  9. bgstults

    bgstults

    Messages:
    19
    The issue is with Excel 2008 on the Mac side, not a version of Excel on the PC side.
     
  10. bgstults

    bgstults

    Messages:
    19
    Well I'll be darned. Someone over at the Microsoft forums figured it out, partially. At least a set of circumstances under which I can make the problem fairly consistently exist or not exist.

    It's shared folders in Parallels. When I have them all on, Excel goes to slowness. When I turn them off, Excel behaves like its usual self.

    I have a pretty big home directory - 110GB total, 48GB of which are on my desktop. Might we be on to something here?

    John, I'll look forward to seeing whether this has an impact on your setup.
     
  11. John@Parallels

    John@Parallels

    Messages:
    6,343
    I suppose in your situation this can be the case, as Windows constantly are trying to index those folders.
    Try to disable indexing service in Windows
     
  12. Seedy

    Seedy

    Messages:
    4
    Did anyone confirm whether there is a fix for this problem. I am a new Mac and Parallels user and I can confirm that Excel 2008 for Mac runs extremely slowly when Parallels is running. I have 4Gb RAM (1 Gb for Parallels). Activity Monitor suggests that the machine is idling - but simply entering text in a cell is painful. Excel performance is crisp when Parallels is not running.

    Cheers

    Craig
     
  13. John@Parallels

    John@Parallels

    Messages:
    6,343
    Try to check disk activity also in Activity Monitor
     
  14. Seedy

    Seedy

    Messages:
    4
    Thanks John. I just restarted - and Excel is currently performing well alongside Parallels. However Activity Monitor was reporting about 400 Kb writes per second - with no obvious stuff happening on the system. After about 5 minutes it settled back to next to nothing. I'll keep an eye on this when I get to work in the morning.
     
  15. Seedy

    Seedy

    Messages:
    4
    Excel 2008 and Parallels have been running all day - although I had no need to use Excel until late in the day. Currently if I try to enter simple text in a cell I can type 5 or 6 characters then wait for about 1 second before anything appears.

    According to activity monitor, at the time of the tests data writes were around the 4-10 Kb per second and "writes out" sat at around 4 per second.

    Excel's response time was restored immediately when I hit the "turn off" dialog button to shut down windows. Obviously Parallels continued to run for a minute or two while it was closing Windows XP.

    I hope this helps
     
  16. John@Parallels

    John@Parallels

    Messages:
    6,343
    Did you checked memory usage for Excel at this time,
    I will try to test as you say Excel leaving it the whole day, do you also have Boot Camp?
     
  17. Seedy

    Seedy

    Messages:
    4
    Sorry John .... I didn't think to check memory. I'll keep an eye on it tomorrow. I do have Boot Camp installed. Rgds Craig
     
  18. John@Parallels

    John@Parallels

    Messages:
    6,343
    I have started test case
    physical 63
    virtual 1.03 GB
     
  19. MWAA

    MWAA Bit Poster

    Messages:
    4
    Slowdowns

    I have this same problem. Running 5608 Parallels with XP SP2 on a 2.6 Macbook pro with 10.5.4. Excel works fine, Parallels works fine, but when both are active, Excel is hopeless. Excel 2008 is the worst culprit, but I have noticed this slowdown with other software as well, including Acrobat Professional 7.0.

    I had the memory set on 512 mB, and increased it to 848 mB based on what I see here, which does seem to have helped. I'll work with it some more and see if it really has made any difference.

    Can I ask : Why set the memory less than 1 gig?
     
  20. John@Parallels

    John@Parallels

    Messages:
    6,343
    it was matter in 10.5.3 and earlier for now formula for Parallels Desktop should be
    1,25 GB at lease to Mac OS and not more than 1500 mb to VM
     

Share This Page