Parallels causes Excel 2008 (Mac) slowness

Discussion in 'General Questions' started by bgstults, Feb 28, 2008.

  1. bgstults

    bgstults

    Messages:
    19
    I continue to find this to be an issue. Has anyone discovered a good fix? John@parallels, I'm a little unclear from your last note what the "optimal" setting should be.

    One thing I *have* found to work -- although it is very annoying -- is to delete all the Microsoft preferences. This gives you a while (sometimes hours, sometimes days) of happy operation of Excel before it starts acting up again.
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    Optimal settings depends of amount of memory you have on Mac
    anyway at least 1.25 Gb of memory for Mac, other you can give to VM
    if you have 2 gb - 1.25 to Mac + 0.75 to VM
     
  3. bgstults

    bgstults

    Messages:
    19
    Changing memory allocation does not seem to have any effect. For reference, I have 4GB of RAM, and have tried allocating 512MB, 768MB, and 1GB to Parallels, with no differences.

    I was able to isolate my "fix" to one specific preference file that, when removed and rebuilt, solves the problem for a while:
    com.microsoft.office.plist
     
  4. John@Parallels

    John@Parallels

    Messages:
    6,343
    Could you please clarify what operation was performed?
     
  5. bgstults

    bgstults

    Messages:
    19
    I quit the MS apps, moved that pref file to the trash, and re-opened Excel.
     
  6. bgstults

    bgstults

    Messages:
    19
  7. Old Marine

    Old Marine

    Messages:
    32
    For what it is worth

    I am running a MacBook Pro 2.16MhZ C2D, 2 GB, 120GB machine on OSX 10.5.4 with Parallels build 5608. I run Microsoft Office for the Mac 2008 updated to V 12.1.2

    I too have experienced the slowdown described by others on this thread with Excel, and have noted that the slowdown is not present when PD is not running.

    This has not been a huge problem for me as I am a casual Excel user, but when I have needed to work with spreadsheets it is extremely annoying.
     
  8. John@Parallels

    John@Parallels

    Messages:
    6,343
    Thank you, I checked that thread , I suppose we need to submit problem to developers, to correlate situation with Microsoft.
     
  9. John@Parallels

    John@Parallels

    Messages:
    6,343
    Did you try bgstults's solution?
     
  10. Old Marine

    Old Marine

    Messages:
    32
    implemented the change as noted but not being a big Excel user have not had opportunity to test yet. Will try and do that over the next day or two and report back on whether this solved the problem/
     
  11. Mirko Holzer

    Mirko Holzer

    Messages:
    1
    Solution: Turn "Recent Files" off in Excel

    Hi there,

    I've had the same problem and found the solution here:

    http://www.tech-archive.net/Archive/Mac/microsoft.public.mac.office.excel/2008-09/msg00309.html

    Just turn off the "Recent Files" feature in Exce 2008l's general settings (turning it off for PowerPoint and Word also improves the speed there). It seems, that Parallels' file internal management system has speed problems accessing files that are inside the NTFS particition.
     
  12. Old Marine

    Old Marine

    Messages:
    32
    Results of turning off recently viewed files

    Mirko,

    Turned off the "recently viewed" feature in preferences for Excel and Word, and the problem with slow application response for both went away.

    Thanks for the follow up.
     

Share This Page