Parallels Stealing Focus, Switching Spaces

Discussion in 'General Questions' started by Dogfish Jones, Dec 21, 2007.

  1. mssrkurtz

    mssrkurtz Junior Member

    Messages:
    10
    When running Outlook on my XP VM, it steals focus every time I receive a piece of mail.
     
  2. mstockman

    mstockman Bit poster

    Messages:
    3
    Me too, and kinda-sorta-workaround

    This problem is driving me nuts. There doesn't seem to be any rhyme or reason for when it decides to steal the focus and switch the space, but it's maddening.

    The only workaround I've come across is to hide Parallels Desktop when I switch away. When it's hidden, Parallels can't steal the focus.

    The reason this is only kind of a workaround, of course, is that it's a pain to remember to hide the application, and having to click the icon in the Dock to get back to Parallels defeats the purpose of Spaces in the first place.

    But, if you need to leave Parallels running a lengthy background process (compiling, or batch-processing files, or running a long script), hiding the app will prevent it from stealing the focus.

    But this problem really needs fixing.
     
  3. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Can you please clear following checkbox
    Bring notification windows to front
    in Parallels Desktop -<Virtual Machine name>-Edit-Virtual Machine-Coherence
     
  4. mssrkurtz

    mssrkurtz Junior Member

    Messages:
    10
    Already done

    I already have this checkbox cleared and it continues to steal focus.
     
  5. keriol

    keriol Bit poster

    Messages:
    4
    Hi!

    I'm running Leopard with latest updates installed. For me it happens with 5608, Parallels with XP Prof. running on Space 1, only Outlook is active.
    On Space 3 I'm trying to work with IntelliJ IDEA, a Java IDE. Every time Windows triggers an event (incoming mail / doing some windows network stuff in outlook or explorer, shown by the hourglass), my Mac switches to parallels on Space 1.
    If I'm fast enough to switch back every time, this happens at least 3 times for a single incoming mail (with Outlook notification enabled).

    One more observation I think I made:
    It only happens when the topmost Windows application triggers an event. If I hide Outlook behind an other application, it happens only when a new mail arrives, but not with every "hourglass"-event.


    This checkbox is cleared for a long time on my system, but you are right, the behavior reminds me of the times when the checkbox was active.


    Greets,
    Andi

    P.S.: I also cross my fingers for a fast solution, as it really drives me crazy. My colleagues are not amused when they have to call me every time they send me a mail: "could you please turn on your outlook again?" ;-)
     
  6. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Ok, I need time to check it, but from your side please check following:
    1. select box I mentioned, click OK, start and shutdown WIndows
    2. Exit Parallels Desktop
    3. Uncheck this button, exit Parallels desktop and check, if problems still there
    I would like to ask you to reinstall Parallels Desktop as described in http://kb.parallels.com/en/4790
    I will be sure, that old or somehow incorrect installation doesn't affect Parallels Desktop
     
  7. mssrkurtz

    mssrkurtz Junior Member

    Messages:
    10
    Still happens

    I followed the first steps, but found that it was still stealing focus every time I receive a piece of mail in Outlook, so I uninstalled and re-installed according to the instructions you posted and I'm still having the problem.
     
  8. keriol

    keriol Bit poster

    Messages:
    4
    Same for me.
    Un- & reinstalling according to the KB article didn't help.
     
  9. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    I got the moment and need additional information:
    1. Is Windows is running in Coherence?
    2. Outlook notifications is set
    3. Outlook version
     
  10. keriol

    keriol Bit poster

    Messages:
    4
    Used Software

    1. Yes, i'm running in Coherence mode
    2. OL notifications are on
    (all options set: play sound, briefly change cursor, show envelope icon, display notification)
    3. OL 2003 (11.8169.8172) SP3

    Just as a reminder:
    It also happens when e.g. Explorer is in the foreground and windows does "some windows networking stuff" (shown by the hourglass mouse cursor).


    Thanx,
    Andi
     
  11. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Do you mean searching Network Shares?
     
  12. keriol

    keriol Bit poster

    Messages:
    4
    I mean network activities not being triggered by the user. Activities, windows does in the background, like searching for printers, discovering it's network, whatever.
    I really can't say what's happening, the only indicator that something happens is the mouse cursor changing from arrow to hourglass for a short time.
     
  13. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Sorry, may be I am missing something, will try to check this to,
    But I reproduced situation, when entering fake share and got Space jump to Parallels Desktop
     
  14. mssrkurtz

    mssrkurtz Junior Member

    Messages:
    10
    Another example is when I shut down XP and switch to a different space, I will be forced back to the space with XP. If I switch away again, I will be forced back again. This happens several times.
     
  15. mssrkurtz

    mssrkurtz Junior Member

    Messages:
    10
    Any Update?

    Are there any updates for this problem? Were you able to reproduce it?
     
  16. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Yes, I reproduced situation and submitted problem, we are working on this
     
  17. jag7007

    jag7007 Bit poster

    Messages:
    1
    I've been getting the same thing. I think I see this only in Coherence mode. I’ve run full screen before and don’t remember seeing the issue in that mode.

    Parallels - Coherence Mode:
    Group All Coherence Windows: No
    Disable Drop Shadow: Yes
    Do Not Minimize Windows to Dock: No
    Bring Notification Windows to Front: No

    Exclude Dock: Yes
    Use Multiple Displays: Yes

    Relocate (Taskbar) Automatically: Yes

    Windows:
    Taskbar ends up on right side
    Taskbar set to Auto-Hide
    Running MS Outlook 2003 always
    Sometimes running other programs (Adobe InDesign, etc) but focus issue occurs regardless

    Mac:
    Running various programs for video/audio editing
    Running OSX Leopard 10.5.4 with all current updates
    Running Spaces with Parallels in Space 2
     
  18. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Thank you we already identified problem, and working to find solution
     
  19. Edd

    Edd Member

    Messages:
    88
    Your terse responses are not appreciated. I would ditch parallels in a heart beat if fusion was anywhere near as good (and sadly beta 2 is not yet) solely based upon the rudeness of the parallels reps on this board.

    Please be courteous to us.
     
  20. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    I am not sure what exactly do you mean?
    This problem was identified by me , and submitted to development, What rudeness are you talking about?
     

Share This Page