PD16: Bring back "Enable smooth scrolling" checkbox

Discussion in 'General Questions' started by DoniK, Aug 13, 2020.

  1. DoniK

    DoniK Kilo Poster

    Messages:
    119
    Release notes: "The Enable smooth scrolling checkbox was removed from the virtual machine configuration because this functionality works fine and very few users disable it."

    For the love of all that is good and holy, why did you remove this longtime option? Just because it's a minority feature, doesn't mean it isn't critical to some people! It "works fine" -- for some, but not for everyone! Literally the entire reason that checkbox was there. The arrogance knows no bounds. Please bring it back!
     
  2. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, this option is enable by default in the newest Parallels Desktop version.
    If you would like to add a feature request please share it here.
     
  3. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    I agree that this move was colossally shortsighted. Altium Designer doesn't play nice with smooth scrolling, which breaks the shift+scroll and ctrl+scroll shortcuts for panning, which are sort of all you've got if you're stuck with a trackpad. Which is a shame, because the improved directx support of the new version DOES seem to improve Altium performance.
     
  4. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, could you reproduce the issue and collect the tech report right after that please.
    Then please post report's ID here.
     
  5. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    614
    Hi @Alex@8, can you please share more details about the issue with Altium Designer and smooth scrolling? I just checked Altium Designer v20.1.14, all three scrolling types (regular vertical scroll, Ctrl+scroll for zoom in/out, and Shift+scroll for horizontal scroll) worked well for me. With the previous Parallels Desktop version, did you toggle smooth scrolling option in the VM config often?
     
  6. DoniK

    DoniK Kilo Poster

    Messages:
    119
    @Dmitry@Parallels Thanks for posting a workaround! I luckily happened to notice it today in another thread. Reposting it here in case anyone finds this thread and not the others:

    Btw, how are we supposed to use the feature suggestion forum? To find anything to see if already there and worth upvoting, you have to search. But if you find it in search, you can't vote for it there, you can only vote from within list view. Guess I'll put in a new feature suggestion regarding the feature suggestion. ;)
     
    NickP14, JunC1 and Dmitry@Parallels like this.
  7. JunC1

    JunC1 Bit Poster

    Messages:
    2
    Please bring this feature back!!!! Who says it's NOT critical!!!!! This is so annoying when scrolling isn't working as it was supposed to or how it should work on Windows. It works as if there were frame drops.
     
  8. JunC1

    JunC1 Bit Poster

    Messages:
    2


    Thanks a bunch Donik
     
  9. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    614
    Hi @JunC1, can you please share more details about "scrolling isn't working"? What applications that you are using are affected? How often did you toggle this option in previous versions? Please let me know.
     
  10. DavidL49

    DavidL49 Bit Poster

    Messages:
    1
    Just supplying a datapoint -- I had no scrolling problems with Ubuntu 14.X->18.X under versions of Parallels through v15. However, in Ubuntu 20.04 under v16, scrolling in all apps was very jerky and painful to use. Disabling smooth scrolling per the workaround posted above improved the situation dramatically. It is not nearly as smooth as the native scrolling but it's now it's at least back to being usable.
     
  11. DavidC79

    DavidC79 Bit Poster

    Messages:
    3
    I use a logitech mouse with my Mac. It appears that when scrolling the mouse wheel one click up in my editor (Delphi IDE), it will scroll over 100 lines of code. When scrolling down it works fine.
     
  12. DavidC79

    DavidC79 Bit Poster

    Messages:
    3
    By the way. Editing the config.pvs as DoniK directs fixes the problem.
     
  13. m.bornhold

    m.bornhold Bit Poster

    Messages:
    3
    Hello, I am evaluating Parallels as a solution to isolate development environments from the regular work in our company. So far I really like the performance of Parallels Desktop 16 when using macOS as host and Linux Mint as guest OS. But I noticed a pretty inconvenient scrolling behaviour at least tested in Linux Mint and Ubuntu guests. I am using the internal macbook touchpad with two-finger scrolling. In macOS I have a very fine grained scrolling and it starts after moving my two fingers 1-2mm. But within the guest OS I have to move them 1-2cm and it results in scrolling at least two lines instead of pixel-by-pixel. As a result the scrolling feels very unresponsive and lagging. I know it sounds like a silly problem, but as you probably know, it is super easy to disappoint developers with tools that feel slow or are somehow inconvenient to use. Counting myself also as such a person, this scrolling behaviour is a no-go for my day-to-day work as developer ;)

    So far the only solution I found is to follow the advice of @DoniK, many thanks for it. After disabling smooth scrolling in the config file, I am getting a very similar scrolling behaviour in the guest as on my host machine. Ideally I would love to lower the scroll sensitivity a bit but at least Linux Mint only offers this option for the touchpad settings which are not in use. Only the mouse settings take effect, but they do not have a config option for scroll sensitivity.

    To sum it up: Also for me this is/was a very useful option and I would love to use it without editing the config file manually. Please bring it back if possible :)

    Besides of this issue: A very nice product +1
     
  14. m.bornhold

    m.bornhold Bit Poster

    Messages:
    3
    Ok, yesterday evening I was too optimistic :D Modifying the config file only solved one part of the issue for me: The scrolling is now very responsive and starts when I move my two-fingers about 1-2mm on the macbook touchpad, great! But still it always scrolls three lines up or down instead of pixel-by-pixel. This would make sense for a physical mouse wheel but not in case of using a touchpad. When I use the window scrollbars I am able to scroll pixel-by-pixel, so at least the pixel-by-pixel scrolling is supported by the Linux Mint guest OS.

    Maybe it's just me, being too stupid to find the right config option. Honestly I am even not sure if this problem is located at Parallels, the guest OS or somewhere in-between. If someone has and idea how to fix the remaining issue this would be very much appreciated :)
     
  15. m.bornhold

    m.bornhold Bit Poster

    Messages:
    3
    After some more googling I found out that the scrolling behaviour I am looking for is called "high-res scrolling" in linux. Sadly it looks like it is not fully supported yet by the underlying drivers, compare with https://flaviutamas.com/2020/understanding-linux-mouse-drivers.

    My conclusion: Please bring back the "Enable smooth scrolling" checkbox ;) This will make working with PD16 on macOS much more convenient with linux guest OS's.
     
  16. BartlomiejS

    BartlomiejS Bit Poster

    Messages:
    1
    I bought Parallels to work in Delphi on VM with Windows
    Unfortunately, the work is very difficult because when I scroll the application code down after one scroll click, it usually jumps many lines down (to many).
    This is very annoying and frustrating for every Delphi Developer working with Parallels!
    Scrolling up works fine.
    Watch in the video. A scroll is heard:
     
  17. brandonf2

    brandonf2 Bit Poster

    Messages:
    8
    Turning off this feature, Smooth Scrolling, was super critical for using Visio without throwing your computer through the wall and in to the coy pond. With Smooth Scrolling enabled, the scrolling in Visio is WAAAAY too fast to be useable. Please, for the love of all that is good and holy, put the checkbox back.
     
  18. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    I remain extremely annoyed that this checkbox hasn't been re-added, as multiple Altium shortcuts are neutered by smooth scrolling (shift/ctrl-scroll to pan, and shift+ctrl+scroll to change layers while routing). Further, even with the workaround, only the trackpad works reliably and not a physical mouse wheel.
     
  19. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, could you collect the tech report once the issue reproduced and post the technical report's ID here?
    Looking forward to your reply.
     
  20. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    I have a couple tickets open about mouse behavior and just got off the phone from a remote support session - mostly I just want everyone else to know they're not alone in deficient mouse support.
     

Share This Page