PD8 - Mouse pointer disappearing?

Discussion in 'Windows Guest OS Discussion' started by TylerD, Sep 6, 2012.

  1. TylerD

    TylerD

    Messages:
    4
    I just upgraded to PD8 and am experiencing a problem with my mouse pointer disappearing when switching between an OSX window and a Windows app in Coherence Mode. For instance, I am running Microsoft OneNote next to a Safari window, and after browsing in Safari, my mouse pointer disappears and only becomes visible again when I click something in OSX. I have reinstalled Parallels Tools successfully, which seemed to temporarily remedy this problem, but this issue has since returned. Very, very frustrated with the upgrade right now.

    I am running PD8 in Mountain Lion, and am running Windows 7 Home Premium.

    I appreciate any help I can get with this.
     
  2. dwoodwoo

    dwoodwoo

    Messages:
    2
    I'm having the same problem with windows 8 preview, onenote 2013 preview with parallels 8.0.18101. Cursor disappears occasionally when hovering over onenote while in coherence mode.
     
  3. JeffK75

    JeffK75

    Messages:
    5
    I'm having the exact same issues running the following:

    Parallels 8 fully updated
    Windows 7 Professional SP1
    Microsoft OneNote 2010

    The cursor occasionally disappears over other Windows based applications. However, it always does over OneNote. I typically have to click off the OneNote window to a OSX related application, then click back to do what I need. The cursor then disappears again.

    Any assistance on this is appreciated. Thank you!
     
  4. ThorneH

    ThorneH

    Messages:
    1
    Same problem here. Just updated Parallels and mouse pointer disappears over some parts of some Windows programs. Moving it around and hitting the right click usually brings it back, but that is no solution. Will try reinstalling Parallels Tools from within Windows 7.

    Other suggestions?

    Thorne
     
  5. lnemo

    lnemo

    Messages:
    114
    +1 with PD8 latest build and XP Pro.
     
  6. darthdecon

    darthdecon

    Messages:
    3
    same here using windows 8 and just disappears every time i click on the virtual machine and then it tells me to press control alt to reclaim mouse, ive tried reinstalling tools, restarting VM, computer, plugging in my wireless mouse, im up for some more suggestions
     
  7. darthdecon

    darthdecon

    Messages:
    3
    well not sure which part fixed it but i went to coherence mode then enabled the usb receiver on the VM menu at top right screen then disabled it and went back out of coherence mode and now all is fine working in both modes again
     
  8. darthdecon

    darthdecon

    Messages:
    3
    ya i just recreated the situation i was in either fullscreen and/or coherence mode and i reset the VM made mouse issues then in coherence mode i went to the two red slashes at the top of the screen towards the right and embedded the usb receiver and then undid that and problem was solved. hope this works for the rest of ya and hope parallels gets a fix by the way i am using a macbook pro retina 2.7ghz 512gb flash drive, 16gb 1600mhz memory, blah blah blah, with a logitech m510 so perhaps program no likey mouse.
     
  9. ipadnutz

    ipadnutz

    Messages:
    1
    I also experience periods where the VM (Windows XP) appears idle for 2-3 minutes then returns to normal. During the idle time I cannot type or select a Windows app but anything on the MAC side works fine. I have noticed this symptom in Coherence mode and have not yet tried the other modes to see if the problem follows.
    MacBook Retina Core I7 OSX 10.8.2 16GB RAM 500MB SSD
     
  10. Michael Lauer

    Michael Lauer Bit Poster

    Messages:
    89
    using Pinpoint to find the lost mouse cursor

    Has anyone with this problem tried to install Pinpoint?

    I have a source that suggests that this might help solve this problem.

    Let me know...
     
  11. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    Hi everyone,

    Something still might be wrong with Parallels Tools, please try to do a "clean" re-install as suggested at http://kb.parallels.com/8969
    If you have an antivirus running on Windows side, disable it before the re-install.
    Another thing to try is to go to VM Configuration: http://kb.parallels.com/115563 > Options > Advanced and turn the Smart Mouse option on (VM should be should be off)
     
    Last edited: Jun 6, 2013
  12. d-underwood

    d-underwood

    Messages:
    1
    I just wanted to update everyone that I went through the steps in http://kb.parallels.com/8969 and also turned the 'Smart Mouse' option from 'Auto' to 'On' and this resolved the issues I was having related to this in all display modes. I did the full uninstall and removed the registry keys that were hanging out behind as mentioned in the article. Thanks.
     
  13. Tobyv

    Tobyv

    Messages:
    1
    Hi Guys,

    This issue still seams to be around in Paralells Desktop 9. I have followed the steps in http://kb.parallels.com/8969 and in PD9 there is no "Smart Mouse" option or it has moved.

    Please advise

    Thanks so much

    iiToby
     
  14. jgarrigues

    jgarrigues Bit Poster

    Messages:
    5
    I concur with Toby - I'm seeing the same problem on Parallels 9 when I try to use Microsoft OneNote 2013 in Coherence mode. The mouse disappears and I have to scroll to a section of the screen that is outside the coherence/OneNote window to get it back again.

    Hardware: iMac (2013)
    OS: Mac OS X 10.8.4
    Parallels Build 9.0.23036 (Aug 28, 2013)
    VM: Windows 7 w/SP1 (32 bit)
    Software: Microsoft Office 2103

    Sidebar - Toby, I found the SmartMouse under the Hardware tab, Mouse & Keyboard option. It seems that there is not an option for SmartMouse any more - it is always on. The only option is whether you choose to 'optimize for games' or not.
     
  15. TakeCtrl

    TakeCtrl Bit Poster

    Messages:
    6
    I've been having this for a while now, and just upgraded to the latest version of Parallels and it's still happening. The problem for me appears to happen periodically when I'm typing an email in Outlook on my Windows 8 VM. I'm thinking that when Outlook hides the cursor (because I'm typing) Parallels is not correctly unhiding the cursor. I've tried disabling hiding the cursor while typing in Windows, but as I've found in a lot of forums, that doesn't exactly do what it says it does. The only work-Around I've found has been to toggle [f3] on OSX, or press control+option to release keyboard/mouse control from the VM. Each of these will cause my cursor to reappear.
     
  16. jgarrigues

    jgarrigues Bit Poster

    Messages:
    5
    I engaged the Parallels technicians over the weekend to troubleshoot this issue, and I also performed some follow-on testing on my own. Unfortunately, the issue persists. It doesn't happen unless I'm in Coherence Mode on particular software apps (so far these include OneNote 2013 and sometimes Outlook 2013). The mouse disappears and I have to scroll to a section of the screen that is outside the coherence/OneNote window to get it back again.

    Hardware: iMac (2013)
    OS: Mac OS X 10.8.4
    Parallels Build 9.0.23036 (Aug 28, 2013)
    VM: Windows 7 w/SP1 (32 bit)
    Software: Microsoft Office 2103

    Here's a summary of my actions:

    The Parallels tech did the following:
    -Uninstalled and reinstalled Parallels Tools.
    -Did steps given in KB article:
    - http://kb.parallels.com/en/114484
    - http://kb.parallels.com/en/9151
    -Enabled the Bluetooth option.

    Afterward, I did the following:
    - I used a wired mouse instead of my bluetooth mouse or bluetooth trackpad - the wired mouse had the same results as the other two.
    - I uninstalled / reinstalled Office 2013 completely on my Windows 7 VM - no changes.
    - I created a new Win8 VM and Office 2013, but still got the same results.

    I'm not going to chase after this one much more... It's proving futile - just have to deal with it and work in Full Screen Mode when I'm using the impacted apps.
     
  17. rsmith

    rsmith

    Messages:
    2
    Confirming that this issue is occurring for me as well. Im using the latest version of Parallels 9 with Windows 7 and Outlook 2013. When typing an email, the mouse cursor disappears and will not reappear until to use my trackpad to right click or vigorously move the mouse to force it to reappear.

    Thanks
     
  18. Sponch@web.de

    Sponch@web.de Bit Poster

    Messages:
    2
    same here with Win8, OneNote 2013 and PD9.
    support please!
     
  19. CaseyMcCord

    CaseyMcCord

    Messages:
    2
    [[solution]]

    Yo Dogs - SOLUTION:

    1) In OneNote goto: FILE -> Options -> Advanced ->
    2) Uncheck the checkbox: "Automatically switch between inking, selecting, typing, and panning"
    3) Enjoy the solution to a problem that has haunted many for years. :)

    PS: Parallels, I really love your software and have also been haunted by this for a while. So I do use this VM religiously and have worked like crazy to find this so I just thought I ask: If this really does fix most people problems can I have a free upgrade to the next Parallels? You guys are the best!
     
  20. cornellian

    cornellian Bit Poster

    Messages:
    2
    WOW, just confirmed that this worked. You deserve a lifetime of free upgrades!

    The mouse pointer will still disappear when typing (a default Windows setting) but it now actually reappears when you move the mouse.

    Thank you very much!
     

Share This Page