Shift key not working for first character when Remote Desktop connected

Discussion in 'Windows Guest OS Discussion' started by ConsultDavidW, Aug 29, 2014.

  1. MichaelH3

    MichaelH3 Bit Poster

    Messages:
    1
    Thanks! I upgraded to 10 and was frustrated. This fixed it.
     
  2. Heathy65

    Heathy65 Bit Poster

    Messages:
    11
    Glad I found this thread. Fix worked for me :)
     
  3. LondonL

    LondonL Bit Poster

    Messages:
    1
    Hooray for the internet! Thanks so much for posting this fix.
     
  4. PavelP1

    PavelP1 Bit Poster

    Messages:
    4
    After Upgrading to 11 I have problems with "ctrl+a" on Remote Machine and "cmd+a" which was perfectly working on v10 now does not. I have Windows XP guest machine same effect on windows 7 guest machine. I have tried "Optimized for games" in keyboard options but no luck! Any ideas?
     
  5. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Please try the steps below:
    1. Click on the Parallels Desktop tab (on the Mac top menu bar)
    2. Choose Preferences -> shortcuts
    3. Click on "OS X System shortcuts" -> and choose "always"
     
  6. PavelP1

    PavelP1 Bit Poster

    Messages:
    4
    Unfortunately, it did not help. I noticed that ctrl+a works not from first time on RDP machine and cmd+a does not work at all. Symptoms like with "shift" button were.
     
  7. PavelP1

    PavelP1 Bit Poster

    Messages:
    4
    New update did not help with that problem. :-(
     
  8. KyleM2

    KyleM2 Bit Poster

    Messages:
    1
    When I was using Parallels 10 I also had problems with the shift key working in Remote Desktop. Creating a keyboard shortcut from "Shift" to "Shift" for the virtual machine seemed to fix it.

    However, I just upgraded to Parallels 11 and the keyboard shortcut from "Shift" to "Shift" no longer helps. However, the following did fix the problem in Parallels 11 for me:
    In the virtual machine configuration go to "Hardware" > "Mouse & Keyboard". Under "Keyboard" select "Optimize for games".
     
  9. GregC2

    GregC2 Bit Poster

    Messages:
    2
    I upgraded to 11 and experienced the problem with Shift while in Remote Desktop (Windows Guest). Setting "Optimize for Games" corrected the problem. Parallels help states:
    Note: You're not recommended to optimize keyboard for games when not playing games.
    Is there a fix scheduled for this issue?
     
  10. ThomasS8

    ThomasS8 Bit Poster

    Messages:
    1
    I don't usually reply to the forums but this has been a source of great frustration, so if this helps anyone...
    Try this. In your VM bring up the Remote Desktop Connection window. Before connection click on the "Local Resources" tab. In the Keyboard pane click on the dropdown box and select "On this computer". Now connect to your remote desktop and check it out. My VM is running Win7 so can't vouch for other versions of Windows.
     
  11. GregC2

    GregC2 Bit Poster

    Messages:
    2
    Windows 7 w/ Parallels 11
    I ended up going back to Version 9. Performance was unacceptable. Slow, delayed response in the menu system. Screen black or not updating in Windows. I am not discounting the possibility of user error. It just didn't seem stable. Will look at Version 11 again if/when I upgrade OS X.
     
  12. MonikaH

    MonikaH Bit Poster

    Messages:
    1
    Thank you so much for this!
    After struggling the whole day with this issue, _this_ finally worked for me on WinXP.
     
  13. SuzanneP

    SuzanneP Bit Poster

    Messages:
    1
    I don't normally post on forums either but this discussion saved me so much frustration. I upgraded from Desktop 9 to Desktop 11 and could no longer use shift key on Win7 remote desktop. The shift to shift did not work, but "optimize for games" as posted above works. Thank You!!
     
  14. Dhruba@Parallels

    Dhruba@Parallels Kilo Poster

    Messages:
    779
    Sounds good! Let us know if you have any additional questions.
     
  15. ChrisW11

    ChrisW11 Bit Poster

    Messages:
    1
    Thank you - this works on parallels v12 to a Windows 10 VM RDP to Windows 8.1
     
  16. martmeister

    martmeister Bit Poster

    Messages:
    30
    Good call Steve. Just worked for me and we are back in business. Thank you.
     
  17. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Great! Thank you for sharing the information. We will send it to the development team to have a look up to this work around. Thanks!
     
  18. WimC

    WimC Bit Poster

    Messages:
    7
    I also have this problem and tried the fix. It works but now I have a new issue: every RDP session to a Windows VM now asks me if I want to turn on Toggle Keys.
    This happens when my Mac is docked into a Horizontal Henge Dock with a logitech K800 keyboard (and unifying receiver plugged into the dock).
    I'm running Windows 10, latest build and Parallels Desktop Pro version 12.1.3 (41532)
    Settings for the VM are:
    - Mouse: don't optimize
    - Keyb: optimize for games
    - Shift mapped to Shift
    - Send OSX System Shortcuts: always
    Has anyone else had this issue?

    togglekeys.png
     
  19. WimC

    WimC Bit Poster

    Messages:
    7
    It appears this happens when you work on multiple monitors, the RDP session only uses 1 monitor and you change the focus from the RDP session to another program running on the 2nd screen (e.g. Outlook). I can reproduce this perfectly. Do I have to file a bug report now somewhere?
     
  20. Swati@Parallels

    Swati@Parallels Kilo Poster

    Messages:
    360
    Hello WimC, please start RDP (Do no click on connect) -> Click on Show option -> Select Local Resources -> under Keyboard, select " On this computer ". Keep us posted on your progress.
     

Share This Page