Sluggish - and worse

Discussion in 'Installation and Configuration' started by EmeryK, Oct 21, 2018.

  1. EmeryK

    EmeryK Bit Poster

    Messages:
    11
    I've posted one other question here several weeks ago. Still frustrated. My Mac (21 inch iMac Desktop with 8GB Ram and 1TB hard drive - not an SSD) continues to be near worthless with Parallels. The entire computer is a crawl. Launching Word takes several minutes, keyboard has lag, everything is just downright slow slow. I'm fairly new to Mac and a first-time parallels user. As mentioned in an earlier post I gave up on Parallels once and went to a straight BootCamp installation of Windows. Then I decided to try Parallels 14. During the trial period I was impressed. It seemed to work almost "unnoticed" (Windows and Mac performed great).

    Now it is mostly sluggish. Occasionally it seems better. I don't know enough about Mac to diagnose the cause. I've thought it could be a RAM issue. But most of the time the Activity Monitor still shows Memory Pressure in the green rather than yellow. I don't want to throw darts at the board - I'd be willing to add ram or consider an SSD upgrade if that would help. But on this forum I've seen some posts alleging poor performance with really good hardware specs.

    Can someone give help?
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,143
    Hi @EmeryK, we would suggest you to disable if any anti-virus is installed, and then follow the step mentioned below to fix the slow performance in a Windows virtual machine.
    Inside the Windows press the Start button > Cogwheel Settings icon > System > Power and sleep > Additional power settings > Choose what power buttons do > Change settings that are currently unavailable > Turn on fast startup (recommended) > Uncheck > Save changes.
     
  3. EmeryK

    EmeryK Bit Poster

    Messages:
    11
    OK. I disabled Windows defender. (That's all I have for anti-virus). The other suggestion was given a couple weeks ago. I do not have that option (see attached screenshot). What else can I try?
     

    Attached Files:

  4. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,143
    Dear@EmeryK, could you please open Task manager, Activity monitor, resource monitor and go to the Help menu of Parallels Desktop application and send us the technical data report via Send Technical Data... menu item? Then, post the number here.
     
  5. EmeryK

    EmeryK Bit Poster

    Messages:
    11
    281350547
     
  6. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,143
    Hi @EmeryK, thanks for the report ID, For a better performance optimization please follow step-by-step instructions below:

    1. Shut Down Windows (Actions > Shut Down) to be able to configure its settings.

    2. When shut down go to the virtual machine's configuration https://kb.parallels.com/en/117287 > Hardware > CPU & Memory > change RAM to the recommended level

    3. Under Hardware scroll down to Hard Disk > unwrap Advanced Settings > uncheck 'Enable TRIM'.

    4. Perform clean boot in Windows as described in the MS article https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows and if the issue persists, please remove and add Bootcamp based virtual machine again to check the performance.
     
  7. EmeryK

    EmeryK Bit Poster

    Messages:
    11
    OK. Here's an update: The RAM was set to 2GB already (I'm not sure if something in the report made you think otherwise???) I was able to get into the Advanced Settings under "hard disk" but there was not an option for "Enable TRIM" is there another place to look?

    I'm (very very slowly) booting Windows and will try the clean boot if possible; but I wanted to report on the other steps.
     
  8. EmeryK

    EmeryK Bit Poster

    Messages:
    11
    OK... I ended up uninstalling the Virtual Machine and reinstalling. If anything bad has gone to worse. Launching Word took maybe 4 minutes; opening a file in word has been "trying" for several minutes now. Quicken simply doesn't launch.

    It simply doesn't work! Shall I give up?
     
  9. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    98
    Ensure Options -> Optimization is set to No Limit in VM configuration.
     
  10. EmeryK

    EmeryK Bit Poster

    Messages:
    11
    Still no better. Can anyone give me any help? I've tried everything suggested. Parallels takes 8-10 minutes to launch. And everything - Mac and Windows - gets sluggish. No one here has suggested my machine is under-powered. So what?
    Again -- on the windows side I'm running Quicken and Microsoft Office. I don't do any gaming, photo editing or anything heavy duty.
     
  11. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    733
    Please start the virtual machine, select Actions (from the Mac menu bar) -> Reinstall Parallels Tools and make sure that the tools are installed successfully without any error message. Then restart the virtual machine and check if it helps. Also, make sure that the Windows is up to date.
     
  12. jhbarker

    jhbarker Bit Poster

    Messages:
    7
    EmeryK,
    I had the same problem. I saw an improvement after disabling "self-expanding" in in the advanced settings of the hard drive. Go to Configuration...Hardware...Hard Drive...Properties. Not sure if that is your issue, but I hope it helps.
     
  13. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    733
    Hello jhbarker. Nice to know that you were able to sort out the issue and thanks for sharing the steps here.
     
  14. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    98
    Having used the same spec iMac I can assure you that the source of responsiveness issues is HDD. Windows 10 is not optimized for HDD and minutes boot time can be expected. You can try either to install Windows 7/8 or use external SSD drive.
     

Share This Page