Unable to Mount USB Devices (PD12 and Windows 10)

Discussion in 'Installation and Configuration' started by danfratamico, Sep 17, 2016.

  1. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    I was running PD11 and upgraded to PD12 on my MacBook Air. After the upgrade, I am no longer able to mount any USB devices (may be other devices too, but I only tried USB). I am getting the "Unable to connect 'USB device name' to your virtual machine right now. Error 471". I have tried reinstalling PD12 from scratch and reinstalling Parallels Tools on my guest OS. What could be the issue? It works fine on my iMac with PD12 and OS X El Capitan. My MacBook Air has the same OS on it.
     
  2. kat

    kat Product Expert

    Messages:
    819
    Hi DanielF1,
    Have you tried this ?
     
  3. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    Yes, I did try this. When I plug in an USB drive and I'm prompted where to attach it, if I select Mac it mounts just fine and I'm able to access it. As soon as I click on Windows 10 it immediately gives me the error message. I'm wondering if something is corrupt in my virtual machine configuration. I will try to install a second Windows 10 VM to see if it's happening on there too. Will keep you posted, thanks.
     
  4. kat

    kat Product Expert

    Messages:
    819
    Hi DanielF1,
    Just want to make sure you update Parallels tool.
     
  5. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    I have uninstalled and reinstalled PD12 Tools twice and it didn't help.
     
  6. kat

    kat Product Expert

    Messages:
    819
    Hi DanielF1
    I am going to step back because you are being helped in another thread. The issue you are having may be related in some way. If after your other issues are settled and if you still have are having trouble with your USB devices, please repost. You may wish to read these two articles "Connect External Devices" and "Adjust Devices Settings" in the mean time.
     
  7. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    The other thread is actually for PD12 on my iMac, this issue is for my MacBook Air.
     
  8. kat

    kat Product Expert

    Messages:
    819
    Hi DanielF1,
    If you used the same installation media it is most likely corrupt. The error code 471 is generally caused by windows system files that are damage.
     
    Last edited: Sep 19, 2016
  9. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    Ok, I will try to copy over the DMG to my laptop using another USB drive. What do you mean by Windows system files being damaged? I am using Mac OS.
     
  10. kat

    kat Product Expert

    Messages:
    819
    Your copy of Windows, the DMG is most likely missing a file.
     
  11. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    I'm sorry, I am confused. When you mean by my copy of Windows, do you mean my Windows 10 VM? Is something corrupt in my Parallels Tools installation? I believe I mentioned before, but I installed a fresh copy of Windows 10 and installed PD12 Tools on it and the same issue. I also just got done copying over the DMG file again and I checked the hash with the original and it's the same. I really don't think anything is corrupt on the files.
     
  12. kat

    kat Product Expert

    Messages:
    819
    The error code 471 is caused by misconfigured system files in your windows operating system. So it is more than likely your download or copy of Windows is corrupt in some way.
     
  13. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    I see, well I will try installing a copy of CentOS Linux to see if it's happening on there too.
     
  14. kat

    kat Product Expert

    Messages:
    819
    Please let me know how that turns out.
     
  15. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    I installed CentOS and installed PD12 Tools, still same error message. As another test, I installed Windows 7, installed the tools and same error message. This rules out my VM configuration or anything with my guest OS. It's definitely something within the host application.
     
  16. kat

    kat Product Expert

    Messages:
    819
    Hi DanielF1,
    Follow these instructions to create a Problem Report
     
  17. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    I just created a problem report. The number is 117491577
     
  18. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    Just want to mention that I upgraded my PD 12.0.1 to 12.0.2 and it did not solve the issue.
     
  19. Elric

    Elric Parallels Developers

    Messages:
    1,661
    Hi,
    The Parallels Desktop has newly discovered issue with VirtualHere USB host. This should be fixed in the upcoming updates of Parallels Desktop.

    As a workaround I'd suggest to remove the VirtualHere:
    start /Application/Utilities/Terminal
    execute (without qoutes) "sudo rm -rf /System/Library/Extensions/vhhcd.kext"
    reboot the Mac
     
  20. danfratamico

    danfratamico Bit Poster

    Messages:
    32
    Awesome, worked like a charm! Thanks so much!
     

Share This Page