Update linux parallels tools with aarch64 support

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by QuintonC1, Dec 29, 2020.

  1. QuintonC1

    QuintonC1 Bit Poster

    Messages:
    1
    With the new Parallels in beta, you can install Ubuntu Server and Kubuntu (using apt-get) and it runs in the beta.
    Trying to install the Parallels tools give the error: arhitecture aarch64 is not supported.
    Supported this architecture for using linux on Apple silicon would be nice.
     
    CraigH16 and NunoP1 like this.
  2. NunoP1

    NunoP1 Bit Poster

    Messages:
    1
    I had this issue as well. Is there any timeframe expected for this? Can we build from source from somewhere? Thanks!
     
  3. IngoF1

    IngoF1 Bit Poster

    Messages:
    1
    I had the same issue - after installing ubuntu (ARM-Virtual-Machine 5.8.0-25-generic #26-ubuntu SMP aarch64) unmounted the CD - mount again- error: Arhitecture aarch64 is not supported - Thank you - kind regards - (Parallels Desktop 16 for M1 Mac build 50393)
     
  4. JimP6

    JimP6 Bit Poster

    Messages:
    3
    Per Parallels support the Tools M1 are in dev but no date yet. I want to use an Ubuntu box with Vagrant and the box needs the tools. Support wanted to know my setup, workflow, and such so I sent them that today along with my Vagrantfile. Hope this speeds up development.
     
  5. ZacharyH6

    ZacharyH6 Bit Poster

    Messages:
    1
    @JimP6 I am running into the same issue with vagrant and the sync folders. Did parallels get back to you yet?
     
  6. JimP6

    JimP6 Bit Poster

    Messages:
    3
    They recently sent our a survey and I told them about the Tools problem. No response yet.
     

Share This Page