visual effects on Ubuntu 10.04?

Discussion in 'Linux Guest OS Discussion' started by schvenk, Mar 24, 2010.

  1. schvenk

    schvenk

    Messages:
    21
    Just installed Ubuntu 10.04 in a Parallels 5 VM. It works well overall, but when I try to enable Visual Effects (and after it does a search for drivers) I get the error, "Desktop effects could not be enabled."

    I'm guessing this is an issue with the Parallels display driver? Is there another driver I could install that would work, or some other fix?

    Thanks!
     
  2. serv

    serv Parallels Developers

    Messages:
    789
    schvenk,

    Ubuntu 10.04 beta 1 places libGL.so* to /usr/lib/mesa/ and configures dynamic loader so that it takes precedence over more conventional /usr/lib/libGL.so*.
    The simplest solution is to edit /etc/ld.so.conf putting /usr/lib on the first line, and then run ldconfig to rebuild loader cache.
     
  3. schvenk

    schvenk

    Messages:
    21
    Thanks for the help. I changed /usr/lib/mesa to /usr/lib in /etc/ld.so.conf/GL.conf and am now able to enable visual effects...mostly. Transparency works, wacky window drag effects work, but I don't get any drop shadows. Any thoughts?
     
  4. Juan PabloP

    Juan PabloP

    Messages:
    1
    My Xorg is dead after install the Parallels Tools in Ubuntu 10.04 beta1/beta2, how fix that?
     
  5. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    Any luck with the drop shadows?
     
  6. WimDS

    WimDS

    Messages:
    141
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  7. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    154
    I too want to make Desktop Effects enabled, but am a bit confused as to how to edit ld.so.conf. Here are the contents of it:

    include /etc/ld.so.conf.d/*.conf

    How would I edit this so that Desktop Effects will work? This seems to be different from the file as described in previous posts. Thanks.
     
  8. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    Hi, you should edit the file: /etc/ld.so.conf.d/GL.conf
    Code:
    sudo gedit /etc/ld.so.conf.d/GL.conf 
    You can delete (or comment) the original lines and add:
    Code:
    /usr/lib
     
  9. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    154
    Didn't work

    I edited the file as you suggested, but still cannot enable Desktop effects. Any other suggestions?
     
  10. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    154
    Spoke too soon

    Sorry, I spoke too soon - I hadn't run the ldconfig command. Having done this, visual effects not only works, but so does the mouse component of Parallels Tools. Excellent!
     
  11. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    Great. Did you get drop shadows on the Windows? I couldn't make it appear.
     
  12. kraized

    kraized

    Messages:
    1
    I can't get the drop shadows to enable either. Everything else seems to work fine. :/
     
  13. Adam Webster

    Adam Webster

    Messages:
    1
    Hi

    I am trying to learn more about linux and I was just wondering how you run the ldconfig command. I have found a few ways to try by searching but none of them work for me.
     
  14. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    Hi Adam,

    Open the terminal (from menu: Applications > Accessories > Terminal)

    Type:
    sudo ldconfig

    Enter the super user password (normally it's the same as your) - sudo allows you to execute a command as the superuser.
     
  15. Bradrox

    Bradrox

    Messages:
    7
    Visual effects.

    I am also having the exact same problem and I am trying to fix it using the suggestions Ive read on here. I put in idconfig in the terminal and got this /sbin/ldconfig.real: Can't create temporary cache file /etc/ld.so.cache~: Permission denied What should I do?
     
  16. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    Did you run ldconfig as a super user?
    Code:
    sudo ldconfig
    
     
  17. Bradrox

    Bradrox

    Messages:
    7
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  18. Bradrox

    Bradrox

    Messages:
    7
    Yeah. Now when I do it it doesnt do anything. Just goes to the next line.
     
  19. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    @Bradrox: ldconfig shouldn't print any message. If you want to see the output, run:
    Code:
    sudo ldconfig -v
    
    Didn't it work for you? Can you enable visual effects?
     
  20. Blrmkr

    Blrmkr

    Messages:
    1
    Also having the same issue. Tried the suggestions above to no avail. What am I missing?
     

Share This Page