Allow Parallels Extension

Discussion in 'Installation and Configuration' started by appleseed, May 31, 2022.

  1. appleseed

    appleseed Bit Poster

    Messages:
    3
    Hello Everyone,
    I have parallels business edition 17, I run my vm and it asks "Allow parallels extension" But when I got to security and privacy nothing there to allow it. Has anyone run into this?
     
  2. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, can you please provide us with more information on the issue you are facing with Parallels Desktop?
     
    appleseed likes this.
  3. appleseed

    appleseed Bit Poster

    Messages:
    3
    Sure, when I run the application and try to launch my virtual machine and I've upgraded from parallels 16 this started. I've attached a picture of the error and my settings. I'm on Big Sur at the moment, I've removed it completely with app cleaner and reinstalled it but still same issue.
     

    Attached Files:

  4. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, please refer to this KB article and change the hypervisor type from Parallels to Apple.
     
  5. appleseed

    appleseed Bit Poster

    Messages:
    3
    Thank you! This worked!
     
  6. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, your most welcome.
     
  7. JacekA

    JacekA Bit Poster

    Messages:
    16
    Hi,
    I also have a problem with Allow Parallels Extension but of a different nature. I have Big Sur installed on NVMExpress.
    In my case, the procedure is looping. Every time I approve it and restart the mac, the action is repeated. I am attaching a screenshot.

    For now, I want to install Parallels 17 TRIAL.
     

    Attached Files:

  8. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, please refer to this KB article and change the hypervisor type from Parallels to Apple.
     
  9. JacekA

    JacekA Bit Poster

    Messages:
    16
    Thank you, I was able to fix the problem yesterday. I did switch my hypervisor to Apple and then is working. It is strange, that the system itself set back the hypervisor as Parallels after a reboot mac.
     
  10. Nazeemabanu@Parallels

    Nazeemabanu@Parallels Staff Member

    Messages:
    90
    @JacekA You are most welcome and thank you for the update
     

Share This Page