Google Chrome performance in Parallels 8

Discussion in 'Windows Guest OS Discussion' started by Leif ArneB, Sep 5, 2012.

  1. Leif ArneB

    Leif ArneB

    Messages:
    5
    Hi all,

    I just upgraded to Parallels 8 and all in all I´m rather satisfied with the result. I especially like the support for Retina resolution - however i find no use for it as to that I´m running a dual screen setup.

    I currently have new MBP with retina running OSX Mountain Lion combined with a Windows 7 PVM image.

    All apps are behaving as normal with the exception of Google Chrome:

    - Performance is extremely sluggish overall
    - The "browsing area" of the Chrome broswer flickers and some times turns completely black
    - Scrolling laggs and reading long threads, posts or long sites is very tiresome.

    Performance in Firefox and Explorer is perfect. Chrome is updated and at its latest version.

    Any ideas on how to fix the issue (i have reinnstalled chrome etc..)?

    Thanks
     
  2. RobN2037

    RobN2037

    Messages:
    3
    Still an issue after re-install

    I am having the same problem.

    I tried Parallels support and I have just re-installed but with no joy

    Anything on this would be helpful
     
  3. RobN2037

    RobN2037

    Messages:
    3
    Looks like a return to Parallel 7 is the official answer

    Shiraj on the Parallels chat support now suggests that downgrading to Parallels 7 is the solution.

    Perhaps the best answer might be to never upgrade or use an alternative VM implementation.

    I'm very disappointed by this outcome
     
  4. alexg

    alexg Parallels Developers

    Messages:
    536
    Hi,

    I'm sorry for giving you troubles. The problem was found and fixed. Please wait for the update. Thank you for your patience.

    Alex
     
  5. RobN2037

    RobN2037

    Messages:
    3
    Great news!

    Alex

    That is really good news. I find Parallels 8 to be great, with only the Chrome browser issue as a problem.

    It's just a particular problem in that I use certain Chrome browser apps extensively at work

    Rob
     
  6. Leif ArneB

    Leif ArneB

    Messages:
    5
    Thanks

    Alex,

    Thanks for your swift resolution of the issue! looking forward to a fix in a future update :)
     
  7. bcrespino

    bcrespino

    Messages:
    4
    Same issue. Subscribing to hear the resolution.
     
  8. serv

    serv Parallels Developers

    Messages:
    809
    Parallels Desktop 8 update that addresses Chrome issue has been released. Check for updates via Parallels Desktop menu.
     
    Last edited: Sep 6, 2012
  9. Leif ArneB

    Leif ArneB

    Messages:
    5
    Confirmation that newest version fixes the issue

    I can confirm that the new release fixes the issue. Had to reinnstall Parallels fully with a new download of the trial version. No update out yet.
     
  10. Parallels User AGR

    Parallels User AGR

    Messages:
    1
    Any news on this?

    This issue is preventing me from continuing some 2d canvas / HTML5 work in Chrome using Parallels 8 - debating on going back to PD7. Check for updates right now and still no update. My current PD8 version is Build 8.0.18101
    (Revision 797180; September 5, 2012)

    Thanks!
     
  11. JoelRubio

    JoelRubio Bit Poster

    Messages:
    53
    This issue just appeared on me in the last 2 weeks

    Running P8 (8.0.18354), MacBook Pro 13", late 2011, 8GB RAM, latest as latest as Chrome can be. Some tabs withing Chrome just goes black. Only way to recover is close that tab, re-open the URL again. Firefox and IE are all fine.

    Chrome or P8 issue?
     
  12. bcrespino

    bcrespino

    Messages:
    4
    I have the same issue. I just popped in the last couple of weeks. I assume it was a Chrome update that changed something because I didn't have the issue for months prior.
     
  13. benben

    benben

    Messages:
    4
    Serious Chrome Issues For Latest Version

    I currently have the most updated versions of Parallels 8 and Google Chrome and am having the issues described by others, using a Windows 7 VM.

    Sometimes tabs go black and I can't get it back. Sometimes I navigate to another page and what I see doesn't change. Sometimes it goes all white. Have to keep opening new tabs and copy/paste the URL. Sometimes I have to do that a few times before it works.
     
  14. MarkusGoebel

    MarkusGoebel

    Messages:
    1
    Chrome performance on MacBook with Retina

    Having the same issue on my MacBook Pro with Retina display and Windows 7 with Chrome running from Windows. Very frustrating!
     
  15. Eiffel

    Eiffel

    Messages:
    1
    Same issue. W7 on MBP.
     
  16. ValeryD

    ValeryD

    Messages:
    1
    Macbook Pro Retina / Windows 8 : Chrome - Same issue.
     
  17. danieltharris

    danieltharris

    Messages:
    87
    May as well add here that i've seen the black browser area bug too. Just have to close down Chrome, it's useless otherwise.

    I'm on a MBPr, but running at Scaled resolution, as otherwise external displays appear fuzzy and exhibit some odd behaviour (Understandably considering what Parallels had to do to accomodate Windows inability to set different DPI per display...that too is understandable it would be no easy feat lol)
     
  18. Paul Batum

    Paul Batum

    Messages:
    6
    Macbook Pro Retina / Windows 8 : Chrome - same problem. Bad performance, black windows, etc.
     
  19. hyunjo

    hyunjo

    Messages:
    1
    MBPr, Parallels Desktop build 8.0.18354, Windows 8, Chrome 24.0.1312.57.

    often times, when i switch away from parallels, and then back, the chrome window turns all black. It is very annoying.
     
  20. UldisK

    UldisK

    Messages:
    1
    Parallels 7 also has this problem. My system config: MBP late 2011, OS 10.8; Parallels Build 7.0.15107; Chrome 24.0.1312.57.
     

Share This Page