Missing : Tilde key

Discussion in 'General Questions' started by DankerO, Nov 6, 2017.

  1. DankerO

    DankerO Bit Poster

    Messages:
    14
    I have had some issues with parallels and that is that it won't allow me to type the tilde key. If any of you know what the problem is help is greatly appreciated.
     
  2. Meenakshi@Parallels

    Meenakshi@Parallels Kilo Poster

    Messages:
    450
    Hello DankerO, please press ctrl+alt and check if that works. Thanks!
     
  3. DankerO

    DankerO Bit Poster

    Messages:
    14
    That's the key to "tab" out of the VM for me.
     
  4. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,129
    So pressing Shift key and the key with the Tilde sign in Windows doesn't help? Please clarify.
     
    DankerO likes this.
  5. DankerO

    DankerO Bit Poster

    Messages:
    14
    Okay, so far now I have tried to install another VM with another windows OS (windows 8) and it didn't work there either (so im starting to believe its an issue within paralles itself). So when I am in the desktop in windows it works fine, but as soon as I launch a program it stops working completely. I cannot figure out whether it is actually the shift key that is broken or the tilde key. Both work in the actual desktop.
     
  6. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,129
    Does this mean that you can input Tilde on the Windows desktop? As in, where on the desktop are you able to type in this symbol?
     
    DankerO likes this.
  7. DankerO

    DankerO Bit Poster

    Messages:
    14
    I can press the windows key and type it in the search bar, I can go to an application like word and it'll let me type it, however the problem arises when I launch any type of game. I have tried many games and the problem still persists. It may be something that impedes this within the VM, I believe it to be something that Parallels installs into the VM so that it works, but I am not sure.
     
  8. DankerO

    DankerO Bit Poster

    Messages:
    14
    Yeah something to do with parallels, cannot figure out what. If you could help me now i require to use it more than ever to fix a program in the VM as it requires a command for it to work...
     
  9. DankerO

    DankerO Bit Poster

    Messages:
    14
    Yeah, so my tilde key isn't working for programs such as... well games. Whenever I am in windows desktop it works fine as in I can input it into the search bar. However when I launch a game it just won't allow me to type it. I have googled for answers and came up empty, I have started threads in other forums and came up empty. If any of you have played any of the fallout games and tilde works on windows 10... tell me. I want to know if the issue is on my end or if it is general. Anywho, thanks. Bye.
     
  10. DankerO

    DankerO Bit Poster

    Messages:
    14
    I have tried many ways of trouble shooting, I have tried installing other games, EVEN valve games (they make it simpler to use developer console) and no luck... I am prepared to just quit and find some way to bootcamp windows in an external hard drive. I've tried for months but no luck. BTW I am using Parallels 12.
     
  11. DankerO

    DankerO Bit Poster

    Messages:
    14
    I've tried both Windows and Mac solutions : no result. I have tried to undergo simple solutions mentioned online : no result. It is strange, as if there is something that restricts the tilde key from being inputted, however it does not seems to be part of windows, however it seems to be part of something that parallels installs. It may be that I am using a hard drive to house the actual VM's, I am going to attempt to move the VM to my actual desktop and will update with results. And I have given up hope of someone knowing what to do, so I am taking it upon myself to log my attempts to solve this issue. My god...

    Edit: its 48.6GB... not enough space.
    Edit: regedit doesn't do anything if you have already have set your VM to "for games"
     
    Last edited: Nov 28, 2017
  12. DankerO

    DankerO Bit Poster

    Messages:
    14
    As of now death seems like a preferrable alternative than finding a solution. But in all seriousness, I am still convinced it is something that it is something that parallels installs into the VM that appears in device manager, however I cannot confirm this.
     
  13. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,129
    Please specify the names of at least a couple of games with which you're experiencing this issue. Also, explain in which part/section of those games you need the Tilde input.
     
  14. DankerO

    DankerO Bit Poster

    Messages:
    14
    Right. So I was playing the original Tom Clancy's Ghost Recon and the tilde key is required to change weapons (this has a simple fix just bind to another key. However, I started playing Fallout 3 and Fallout New Vegas, the games are not perfect so for Fallout New Vegas I require to input a set of commands in order to make a quest in the game work. For Fallout 3 I require it to make it work. I cannot bind the key to another as the developers binded the key to tilde permanately.
     
  15. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,129
    Ok, please do this: Shut down Windows (as opposed to simply suspending it; see for details), open the virtual machine configuration window, navigate to Hardware -> Mouse & Keyboard, select 'Auto-detect for games' for 'Keyboard', close the window, start up Windows, switch Windows to Full Screen view and, while in Full Screen view, check for the issue again.
     
  16. DankerO

    DankerO Bit Poster

    Messages:
    14
    The "Auto detect for games" only appears for the mouse, not for the keyboard. It only shows "optimize" or "don't optimize" for games. As of now I have it set for optimize for games, the keyboard that is.
     
    Last edited: Dec 1, 2017
  17. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,129
    With this option selected, did you check for the issue in Windows Full Screen view? Please confirm.
     
  18. DankerO

    DankerO Bit Poster

    Messages:
    14
    The issue persists. I've also tried to switch the keyboard layout of my mac from ABC to US directly. It didn't work. I've checked the keyboard language of the keyboard, it was US. I've also went to all of the trouble shooting that the game communities offer... no success.
     
    Last edited: Dec 2, 2017
  19. DankerO

    DankerO Bit Poster

    Messages:
    14
    Well... I got it working. I just had to switch the keyboard layout from United States... to US.
     
  20. Shathish@Parallels

    Shathish@Parallels Kilo Poster

    Messages:
    344
    Hello @DankerO Great! We are glad that you have resolved the issue.
     

Share This Page