Problem when (re)installing parallels tools

Discussion in 'macOS Virtual Machine' started by PedroC16, Dec 29, 2023.

  1. PedroC16

    PedroC16 Bit poster

    Messages:
    2
    Hello,
    I have Parallels Desktop 19 installed on an Apple Silicon Mac, and I use several Mac VMs inside. When I firstly created the VMs, I installed parallels tools inside them and it went smoothly. However, after some upgrade (I'm not sure if it was the Mac OS upgrade of the VM or if it was Parallels Desktop upgrade), parallels tools stopped working.
    Then I tried to reinstall it. I noticed that there were no "reinstall parallels tools" option available, because Parallels didn't recognize the existing installation, but rather there was just the "install parallels tools" option. Then I went for it and proceeded with parallels tools installation, and normally rebooted the VM after the installation. The problem is that after rebooting the VM, it is still the same thing, without parallels tools working. Parallels still doesn't recognize the installation. I've tried to repeat the installation procedure several times and always got same result.
    The same behavior is happening among all my Mac vms.
    Detail:
    Host: Mac OS 14.2.1
    Parallels 19.2.1
    VMs: Mac OS 14.2.1
    Architecture: Apple Silicon
     
    ErgunC likes this.
  2. Trishna Oobeyram

    Trishna Oobeyram Staff Member

    Messages:
    261
    Hello,
    To let us better understand the situation, please perform the following steps:
    1. Reproduce the issue.
    2. Collect a technical report (click Parallels icon || > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID.
    We will be waiting for your reply.
     
  3. PedroC16

    PedroC16 Bit poster

    Messages:
    2
    I generated report # 446675380 .
    I tried to install parallels tools, then I pressed reboot button when asked, and then the system started with parallels tools installer screen again.
     
  4. AlexanderG17

    AlexanderG17 Bit poster

    Messages:
    5
    I'm seeing the same problem.
    Host: MacOS 14.4.1
    Parallels: 19.3.1
    MacOS VM: MacOS 14.4.1
    Apple Silicon M2 Max

    Report ID: 458552298
     

Share This Page