Windows 10 Default Browser

Discussion in 'Windows Guest OS Discussion' started by LaurenceH, Jul 18, 2016.

  1. LaurenceH

    LaurenceH Bit Poster

    Messages:
    7
    When I originally installed Windows 10 I thought I had set the default browser to Firefox in OS X but now the default is Edge. When I try to change it all I can see are Windows apps, not Mac apps. Is it possible to specify Mac apps as defaults or must I install FF again under Windows?

    Thanks!
     
  2. Guna@Parallels

    Guna@Parallels Parallels Support

    Messages:
    433
    Hi @LaurenceH
    If would like to open a web address (link/URL) from Windows side on the Mac FireFox , try the below steps
    1. Open virtual machine's configuration window -> Options tab -> Web & Email
    2. Web Pages > Open in Mac.
    3. Click on the Apple logo> System Preferences > General > Default web browser > Choose FireFox
    Refer to this blog for more information.
     
  3. LaurenceH

    LaurenceH Bit Poster

    Messages:
    7
    Thanks! That worked perfectly.
     
  4. Guna@Parallels

    Guna@Parallels Parallels Support

    Messages:
    433
    Awesome! Feel free to reach us for further assistance
     
  5. Chicagot

    Chicagot Bit Poster

    Messages:
    13
    I'm having a similar issue - the default browser on the Mac is Safari, Parallels is configured to open web pages on the Mac, but Windows 10 (anniversary edition) keeps reseting the default browser back to Edge every time I fire up the Parallels instance. The Parallels config still shows open on the Mac. I can change the default browser in Windows 10 to the Mac, but it doesn't stick.
     
    Martin9 likes this.
  6. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi, please check out this article to reset the browser defaults and then configure Parallels Desktop to open web pages on the Mac again and let us know how it works.
     
  7. Martin9

    Martin9 Bit Poster

    Messages:
    23
    same issue like @Chicagot here. So, sorry to tell you @PaulC that your reply is not of big help unfortunately. The problem it is not about HOW to change the default browser or file settings. The question is how to avoid that Edge is automatically set as default browser in Windows after every new start. This problem only occurs after installation of the W10 anniversary update.
     
  8. SteveR3

    SteveR3 Bit Poster

    Messages:
    3
    Same problem on three Macs here: Ever since Windows 10 anniversary launched a few weeks ago, the default browser keeps resetting from Chrome to Edge every time I restart Windows. This only happens on my Macs running Parallels and Windows 10. My single Asus computer running Windows 10 doesn't revert to Edge.
     
    Martin9 likes this.
  9. Martin9

    Martin9 Bit Poster

    Messages:
    23
    good to know @SteveR3. So this really seems to be a Parallels issue! I first made a posting in Microsoft's W10 forum but they immediately asked me to post it here...
     
  10. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Try hitting the command button (start menu) with windows open and type default programs. Click on the icon that appears, when the window comes up scroll down to browser defaults and select open in mac. Double check your parallels desktop settings. Options < Web And Email < WebPages < Open in Mac. These are the setting i have set now and the issue is not present. Please get back to me if this does not resolve your problem and i will work on it more. Thanks
     
  11. Martin9

    Martin9 Bit Poster

    Messages:
    23
    thanks @dustinh1 but this is what I do every morning when I start my machine. As mentioned, after a new start of Windows, Edge is again set for default browser. Settings in PD as recommended by you are set correct and don't change.
     
  12. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    hmmm? ok try this please and let me know the results. Its basically just editing the registry setting in windows 10 to change the defaults and block edge from launching automatically for anything.
    LINK: http://www.sordum.org/downloads/?st-edge-block Just run the .exe and click block.
    If you ever want to unblock just run again and click unblock. Of course run this in windows 10.
     
  13. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    if you do not want to block edge like this i can help you with the registry settings that need to be changed to stop it from hijacking file associations and resetting defaults. This is actually a windows 10 issue and not parallels just to be clear. It is caused by the hash algorithm that windows 10 now uses when file associations and defaults are changed.
     
  14. Martin9

    Martin9 Bit Poster

    Messages:
    23
    thanks @dustinh1 but this website is not trustworthy enough for me to run an .exe file from that source. There is not even an imprint shown. Anyway, it would be great to know which settings need to be changed in the registry to reach same result as such recommended file. I was already intensively checking on Google for corresponding proposals and tutorials but couldn't find one that was of use for me.
     
  15. Martin9

    Martin9 Bit Poster

    Messages:
    23
    ok, that sounds great. Can you give the reg keys that need to be modified please? Well, you state that this is a W10 issue but as you can see in the posting of @SteveR3 he faces the problem only with his Parallels installations while a real W10 installation does not have that problem. So I am not sure this is a W10 issue and I would not be surprised if even modifications in the registry will be reset by this problem....
     
  16. SteveR3

    SteveR3 Bit Poster

    Messages:
    3
    It could very well be a Windows 10 issue, but all three of my virtual machines have the same problem and my single Windows computer does not.
    One thing that might be making a difference: Chrome for Windows is installed on that computer and has remained the default browers. I use Chrome for Mac on my three Apple computers and that option does not appear in the virtual machine, just "Open in Mac."
     
  17. Martin9

    Martin9 Bit Poster

    Messages:
    23
    I also have Firefox and Chrome installed on my Mac but they don't appear in the virtual machine...wonder if we'll ever find out what's the problem...if I would know the registry keys I could at least make a work around by using a batch file in autostart....
     
  18. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    There are a lot of Windows users that are having the same issue on native Windows of installs. I have ran the exe file myself then rescanned my system to be sure there is no malware present. There is a good tutorial on this also I found on Google. I'm on my iPhone right now but as soon as I can get to my Mac I'll post the link for the registry edits if you still don't feel comfrey lie with the executable
     
  19. Martin9

    Martin9 Bit Poster

    Messages:
    23
    great, thanks for your efforts. Did the exe-file solve the issue constantly?
     
  20. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Yes but it does block edge from running at all. Which I don't mind I always use opera on Mac for any internet links and Adobe for pdf files. I have restarted the vm several times and the entire system also and the defaults are staying as open in Mac.
     
    Last edited: Aug 25, 2016
    Martin9 likes this.

Share This Page