Windows 10 for ARM

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by DonaldB4, Dec 17, 2020.

  1. DonaldB4

    DonaldB4 Bit Poster

    Messages:
    3
    Running Windows 10 on the MacBook M1.
     
  2. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    186
    Best Answer
  3. KevinP13

    KevinP13 Bit Poster

    Messages:
    3
    Which Windows version are you running? I have been successful to install and boot up Windows ARM64 Insider preview but the mouse input will not work in Windows.
     
  4. PejmanK

    PejmanK Bit Poster

    Messages:
    3
    I installed and and everything was responsive, then I did a windows update and it rebooted the vm. after reboot now it's unresponsive or to say it better, if I run an app, the app opens but nothing shows on the screen.
    for example I clicked on the search area on the taskbar and typed cmd (you can't see anything is typing), then I pressed enter and the cmd opens because I see it on the Mac dock. I can even start typing commands in that invisible cmd.
     
    JosephS8 likes this.
  5. ShaunG1

    ShaunG1 Bit Poster

    Messages:
    1
    Installed the Windows 10 ARM version last night and it is amazingly quick! Everything running perfectly so far, have installed all office apps including Visio (which is the only reason I need to use Windows). Visio opens in about 2 seconds. Fantastic job parallels!!
     
    SimonZ2 likes this.
  6. DarrenP4

    DarrenP4 Bit Poster

    Messages:
    2
    I tried to install build 20231. My first time Windows blue screened a lot and was very unresponsive (Stuck on the setting up windows screen for example). Never got a desktop. Finally just deleted the VM. The second time things were better and I got a desktop, but now the display doesn't refresh. So I click the Start Button for example, nothing seems to happen, but if I resize the window, when it refreshes the resolution then the start menu suddenly appears. Click off of it, same thing, have to resize my window for the display to refresh for the menu to go away.

    I haven't customized any of the VM settings, so its all default.

    Ubuntu Server ARM appears to work great. Although the ISO wasn't recognized as a ARM image, so had to manually setup a VM without install media, and then attach the ISO later.
     
  7. JosephS8

    JosephS8 Bit Poster

    Messages:
    1
    Having the same issue here. The display doesn't respond, and when I resize the VM window I can see the app has launched. I have reinstalled parallel tools in the VM and that app window responds, but after reboot it returns to not updating display when clicking on apps or typing.
     
  8. davidm18

    davidm18 Bit Poster

    Messages:
    1
    just here to confirm the same behavior from the last two posts. My build 20231 behaves the same way. I submitted feedback to Parallels as well.
     
  9. LiamB1

    LiamB1 Bit Poster

    Messages:
    1
    Yep. Same here. Tried 3 different VMs all with the same issue. Must be a conflict with the latest version of Windows 10 ARM. I'm gonna hunt down an earlier version and will report back.
     
  10. PaulB24

    PaulB24 Bit Poster

    Messages:
    2
    I am also experiencing this identical behavior. I've reinstalled several times. The VM works well until I reboot or restart it for the first time. Unresponsive UI from that point forward.
     
  11. DiegoH2

    DiegoH2 Bit Poster

    Messages:
    4
    Same behavior....if you reinstall the Parallels Tools again without restarting...just pospone...it works again. I think is a bug...so every time is necessary to reinstall parallels tools....kind of annoying...anyway.
     
  12. PaulB24

    PaulB24 Bit Poster

    Messages:
    2
    There was a suggestion in another thread to disable time sync (VM Configuration / Options / More Options). Set 'Time' dropdown to 'Do not sync'. After I changed this, my VM began working properly this morning.
     
  13. JasonR17

    JasonR17 Bit Poster

    Messages:
    1
    Same issue with me. Windows will boot, but you can't type or click on anything.
     
  14. DiegoH2

    DiegoH2 Bit Poster

    Messages:
    4
    Go go configs and options...disable date sync
     
  15. Jonas8

    Jonas8 Bit Poster

    Messages:
    5
    Hi all,
    I need help, I am trying to use my Edimax Wifi N150 adapter or any other USB wireless adapter in order to make My windows 10 Pro insider Preview to connect to my real wireless network. unfortunately, they are all giving driver issues and not working.

    Any ideas?
     
  16. KevinC18

    KevinC18 Bit Poster

    Messages:
    9
    hi

    how do i select an operating system for windows 10 on new mac 1 laptop please
     
  17. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    186
    Best Answer
  18. KevinC18

    KevinC18 Bit Poster

    Messages:
    9
  19. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    186
    VM = virtual machine = your Win 10 running on the Mac
    The installation image is the Windows file you downloaded. If I remember correctly it is a .vhdx file, but.iso also works.
     
  20. KevinC18

    KevinC18 Bit Poster

    Messages:
    9
    i am still having no luck and parallels support of no assistance.

    im getting the installation images message and despite downloading the windiows ard vhdx doesnt seem to fix it
     
  21. KevinC18

    KevinC18 Bit Poster

    Messages:
    9
    this is the message i am getting

    "the specified image cannot be used because your Mac is equipped with the Apple M1 chip that doesn't support Intel-based operating systems"
     

Share This Page