Windows 10, no sound, no Parallels Virtual Audio Adapter Visible

Discussion in 'Windows Guest OS Discussion' started by Suhat, Jan 6, 2021.

  1. Suhat

    Suhat Bit Poster

    Messages:
    1
    Hi,
    I have Parallels for M1 chipsets. VM is working just fine but I have no sound on VM. I have tried reinstalling Parallels Tools but did not workout. I searched the forum and I suppose I should be seeing Parallels Virtual Audio Adapter under Settings>Sound>Input and Output tabs. However I only have Macbook Pro Speakers and Microphone under those. Also, when I open device manager and check Sound,Video and Game Controllers Tab I see High Definition Audio Device instead of parallels audio controller. Any ideas? Thanks!
     
  2. AndyD7

    AndyD7 Bit Poster

    Messages:
    6
    I see 'High Definition Audio Device' instead of 'Parallels Audio Controller' too, and I'm experiencing disruptive crackling when playing audio. I found this thread https://forum.parallels.com/threads/crackling-sounds.341232/ which explains how to update the driver to the Parallels Audio Controller, but the advice from Shathish@Parallels didn't work for me. There was no Parallels Audio Controller in the list, only the High Definition Audio driver. Also the entries, 'UpperFilters' and 'KS' in the Registry Editor were not there either.

    I followed the advice from the mentioned blog post http://glimpseoftheobvious.blogspot.com/2014/02/how-to-fix-annoying-popping-audio-with.html but this didn't fix the audio crackling issue. Does anyone know how we can install the Parallels Audio Controller?
     
  3. MeaghanH

    MeaghanH

    Messages:
    2
    I had the same issue- I had accidentally hit "deny" when asked to allow Parallels to have access to accessibility during the installation update. My fix was to go on Mac to System Preferences>Security&Privacy>Full Disc Access> "+" and search for the parallels desktop app.
    Once that permission is locked, I reopened Parallels, reinstalled Parallels Tools (Actions>Reinstall Parallels Tools) and then restarted the virtual machine. After that, sound fixed!
     
  4. JoshuaL9

    JoshuaL9

    Messages:
    1
    Meaghan H! You are a life saver! I did exactly what you wrote step by step and Brava! Sound! Thank you thank you thank you!
     
  5. FinlayW

    FinlayW Bit Poster

    Messages:
    4
    I have the same problem. My Parallels has full disk access, however I still need to reinstall Tools every time I open Windows.
     
  6. ChrisR20

    ChrisR20

    Messages:
    2
    Hi, I found a fix for my setup (macOS 10.15.7, Parallels Desktop 16.5.0 for Mac, VM: Win10, 20H2, 19042.928):
    • giving the Parallels desktop App full disk access under macOS security settings (not sure if that is really needed, anyhow THANKS to Meaghan! :D )
    • in the advanced Sound & Camera settings of the VM I chose "AC'97" and then the "Parallels Audio Controller" did show up under the windows devices
    Hope this is useful for you -- oh and I use a thunderbolt 3 hardware audio device with the VM.
    .C
     
  7. FinlayW

    FinlayW Bit Poster

    Messages:
    4
     
  8. FinlayW

    FinlayW Bit Poster

    Messages:
    4
    .
    Thank you for this . I did as you suggested and got Parallels Audio Controller showing up. However it only works if I troubleshoot and windows offers to reinstall the driver. Then it only works for that a session. Each session I have to go through the sam troubleshoot//reinstall palaver. only using speakers or headphones connected to audio port on iMac.
     

Share This Page