Windows ARM64 - seems to boot up

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by DanO3, Dec 17, 2020.

  1. DanO3

    DanO3 Bit Poster

    Messages:
    6
    KevinH31 and KaanF like this.
  2. MarkByrn

    MarkByrn Bit Poster

    Messages:
    20
    It booted up just once and couldn't run any app other than Office and Edge; other apps like the Microsoft Store just crashed on the splash screen. After doing a restart, nothing worked; just hung. Removed the VM, installed again, and same issue.
     
  3. DanO3

    DanO3 Bit Poster

    Messages:
    6
    I didn't have that experience at all. I did have an Edge fail though. Had to use Internet Explorer to install Chrome. Just asked Windows update to install the Dev build so I can try to install Intel64 binaries. Fingers crossed...
     
  4. ShaunC5

    ShaunC5 Bit Poster

    Messages:
    5
    Same here; the installation was seamless and fast, and whilst the menus are snappy nothing else seems to want to open; not even a simple photo!
     
  5. Ricoculous

    Ricoculous Bit Poster

    Messages:
    16
    Mine crashes and boots to setup repair
     
  6. KaanF

    KaanF Bit Poster

    Messages:
    3
    thank you im downloading :)
     
  7. PeterS68

    PeterS68 Bit Poster

    Messages:
    13
  8. KevinP13

    KevinP13 Bit Poster

    Messages:
    3
    I have it Windows 10 ARM64 booted up but MB Air M1 mouse input does not work.
     
    JackLin56 and applefanboy27 like this.
  9. Ricoculous

    Ricoculous Bit Poster

    Messages:
    16
    Finally got it running, rebooted, and now I have the same issue. It's loading like it should work, but nothing responds.
     
  10. Ricoculous

    Ricoculous Bit Poster

    Messages:
    16
    Okay, after further troubleshooting, if you click on something and then do the "Ctrl Alt Delete" keyboard command and hit esc on the keyboard, it pulls up. So it seems to be working but not updating on the screen...
     
  11. MDN255

    MDN255 Bit Poster

    Messages:
    4
    Hi, I got excited when Parallels released it for Apple Silicon. I got Windows 10 ARM running on my MacBook Pro 13 M1. It seems graphics is not working? When I got into Windows, I attempt to click "MS Edge" and it didn't show up but the icon show up on Mac's Dock. When I move around and it froze in Windows 10. Do anyone have similar issue? Or know any workaround solution, yet? I am still playing to see if I can find workaround temporary.
     
  12. JohnD45

    JohnD45 Bit Poster

    Messages:
    1
    I installed it just fine and was able to surf the web vi MS Edge. I then installed Windows update and everything is frozen. I removed the VM and installed it again. Same issue. It boots up, but everything is frozen and I cannot do anything.
     
  13. ManuelL8

    ManuelL8 Bit Poster

    Messages:
    3
    I downloaded the ARM file from the link above and so far, so good. Before you can actually download the file, you need to register to Windows Insider program. There are no real requirements. I entered my Microsoft account information and was able to download the Windows 10 ARM image file. After the long download, 8.17 gb, I resumed the Parallels installation and it found the VHDX file in my MacBook Air's download folder and installed Windows. Once done, it stated that there were issues and needed to restart. It was OK after that. I was able to log into my MS account and get to the Office subscriptions and those are installing too. I have the M1 Air, 8gb ram, 512 gb drive.
     
  14. ParallelsU233

    ParallelsU233 Bit Poster

    Messages:
    3
    OK. I downloaded the Windows 10 ARM and it installed, booted up and did a system up date. Then it becomes unresponsive. After several restarts same thing. Unresponsive.
    I deleted Windows and reinstalled it. Same thing.
     

    Attached Files:

  15. DanO3

    DanO3 Bit Poster

    Messages:
    6
    Update - I've upgraded to build 21277 and am currently installing Oracle Database 11 XE. First click on the setup.exe fails. Second worked. I guess Windows did something to let the Intel code run.

    I'm still not observing the Windows failing to work behaviour other people are reporting here.
     
  16. Ricoculous

    Ricoculous Bit Poster

    Messages:
    16
    Have you rebooted since you setup? Mine ran fine until the reboot. And it still is responsive, it just isn't displaying the changes. So if I open file explorer, and then use the Devices - Keyboard - Ctrl, Alt, Delete - option, and then hit escape, I can see file explorer.
     
    ManuelL8 likes this.
  17. DanO3

    DanO3 Bit Poster

    Messages:
    6
    Intel builds of Notepad++ and 7zip working fine on Windows 21277.
     
  18. RobN5

    RobN5 Bit Poster

    Messages:
    1
    I had no issues in installing from the Windows 10 ARM64 preview site and running on an Air M1 16GB. Edge needed an update but installed without and issue. Chrome 32 bit also installed without a problem
     
  19. MDN255

    MDN255 Bit Poster

    Messages:
    4
    I finally found a workaround solution. By click Action | Reinstall Parallel Tools. Then just let it run until it pops up and immediately click "Postpone" to restart. Then finally everything is working correct. DO NOT RESTART or SHUTDOWN. If you do, then it will stop working. You will need to reinstall Parallels Tools and "Postpone" to restart again if you decide to reboot or shutdown.
     
    ManuelL8, PejmanK and AndrewS41 like this.
  20. Ricoculous

    Ricoculous Bit Poster

    Messages:
    16
    Can confirm this worked. You're a legend! Been trying to find a work around for a few hours now. This is way more reasonable then what I came up with.
     

Share This Page