Windows ARM64 - seems to boot up

Discussion in 'Parallels Desktop 16 for M1 Mac Technical Preview' started by DanO3, Dec 17, 2020.

  1. KevinB21

    KevinB21 Bit Poster

    Messages:
    6
    I should've checked the forums before deleting my Windows VM. I had the same experience but thought it was because I had installed Windows updates. The issue is definitely just that it isn't updating the display. If you launched something but don't see it on screen, you can resize the screen a bit and it will refresh and show your app. I found the "reinstall parallels tools trick" too but the fact that it fails after reboot didn't seem super helpful, but I guess it's fine to experiment with for now.
     
  2. DanO3

    DanO3 Bit Poster

    Messages:
    6
    Rebooted because of the Windows updates so yes some rebooting may do some magic.
     
  3. DanO3

    DanO3 Bit Poster

    Messages:
    6
    Yes but I just joined today. Just a form to complete.
     
  4. JPhi

    JPhi Bit Poster

    Messages:
    7
    If you resize the window (just a millimetre is enough), it forces a screen refresh. At least you see what happened if you were in the middle of upgrades you want to complete before you turn the VM off.
     
  5. Ricoculous

    Ricoculous Bit Poster

    Messages:
    15
    Is your Microsoft Store working? Mine crashes.
     
  6. JPhi

    JPhi Bit Poster

    Messages:
    7
    Crash on start. Interesting, as I did remember seeing it work on QEMU.
     
  7. ShaunC5

    ShaunC5 Bit Poster

    Messages:
    5
    For me QEMU was very functional but obviously the resolution was very poor, however now this is good resolution and doesn't crash (for me) but not many things work.
     
  8. david1610

    david1610 Bit Poster

    Messages:
    11
    I have also got it to work by updating to Dev build 21277 . This version allows for x64 emulation. I was able to download and run the Windows software I use for translation (memoQ Translator Pro) which seems to work OK. Will test more. I also used that Advanced Feature "Ignore error messages and carry on" ;)
     
  9. applefanboy27

    applefanboy27 Bit Poster

    Messages:
    5
    So I have downloaded the Windows 10 ARM .VHDX file from the Windows Insider link and when I try and install it I am getting "Failed to convert the virtual machine." error. Anyone know how to fix this?
     
  10. PeterS68

    PeterS68 Bit Poster

    Messages:
    13
    The reinstall parallels tools thing works great, things seem back to running again.
     
  11. PeterS68

    PeterS68 Bit Poster

    Messages:
    13
    Check that actually, no MS apps seem to work at all, everything just bails after loading. Oh well, Ubuntu is working
     
  12. RonaldM7

    RonaldM7 Bit Poster

    Messages:
    7
    Same here, the first time it opened Edge, but then it crashed, restarted, nothing worked. I didn't try to reinstall.
     
  13. PeterS68

    PeterS68 Bit Poster

    Messages:
    13
    Ya ok I did the same
     
  14. ShaunC5

    ShaunC5 Bit Poster

    Messages:
    5
    Does anyone have a functional apps like microsoft store?
     
  15. applefanboy27

    applefanboy27 Bit Poster

    Messages:
    5
    managed to install it now after reinstalling Parallels, now the mouse and keyboard doesn't work when running the windows vm
     
  16. Ricoculous

    Ricoculous Bit Poster

    Messages:
    15
    How did you do that?
     
  17. Ricoculous

    Ricoculous Bit Poster

    Messages:
    15
    Never mind, was able to get it working.
     
  18. AndreH8

    AndreH8 Bit Poster

    Messages:
    2
    Hello,
    You can just disable the "parallels tools service" in windows services, that'll stop certain things from working (auto resize resolution on window size change, etc...) but it stops you from having to run parallels tools each time you reboot.
     
  19. ZoeQ

    ZoeQ Bit Poster

    Messages:
    2
    I finally got Trados running as well!!
     
  20. ZoeQ

    ZoeQ Bit Poster

    Messages:
    2
    But it has stopped working for me after shutting windows down and then trying to re-start it. It's simply not responsive and re-installing parallels tools (and postponing it) doesn't help at all. Also impossible to shut it down and close it. Had to force quit parallels.
     

Share This Page