Scrolling sucks in macOS 10.12 Guest...

Discussion in 'Mac OS X Guest OS Discussion' started by viola, Jul 29, 2017.

  1. viola

    viola Kilo Poster

    Messages:
    139
    When I scroll in macOS 10.12.6 GUEST on a 10.12.6 host, the scrolling happens WAY too fast on an Apple Magic Trackpad 2. Right now when I scroll in Safari, for example, on the guest machine, just a slight movement of my two fingers makes the page JUMP way too far. I have to rock the tips of my two fingers just to scroll a little instead of having it jump nearly to the top and bottom of a webpage that is several pages in length.

    Is there some way to get smooth scrolling in a one-to-one ratio with my macOS HOST system on the GUEST?
     
  2. Shathish@Parallels

    Shathish@Parallels Kilo Poster

    Messages:
    344
    Hello ylon, please open the virtual machine configuration http://kb.parallels.com/117287 and go to Hardware > Boot Order > paste in Boot Flags box "
    devices.usb.mouse=0" and check it helps. Thanks, Shathish
     
    JuanM11 likes this.
  3. viola

    viola Kilo Poster

    Messages:
    139
    @Shathish@Parallels does the argument need to be encapsulated with quote marks within the Boot flags box or without quotes?

    When I placed this argument (without quotes) within the box, I now have NO cursor within the virtual machine. I cannot click on or navigate in any way shape or form.

    [​IMG]
     
  4. bloque13

    bloque13 Bit Poster

    Messages:
    3
    host & guest os macos 10.12.6
    parallels 13.0.1
    Same issue, the mouse works for a short while then the mouse icon disappears and cannot click anywhere.
    Navigating with the keyboard is the only option.
    Restart the VM sometimes solves the issue.
    Tried the boot flags, makes no difference.
    Tried the auto detect / optimise / don't optimise hardware settings, makes no difference.
    How can I update the VM settings so the mouse works correctly?
     
    Last edited: Sep 13, 2017
  5. Vidar

    Vidar Bit Poster

    Messages:
    1
    What is happening with this problem I have exactly the same problem, also putting in the boot flag, removed the mouse totaly.
     
    viola likes this.
  6. Flynn

    Flynn Bit Poster

    Messages:
    1
    Any news about this? Scrolling still sucks within a macOS 10.13.5 guest on Parallels Desktop 13.3.1. Why is a Magic Trackpad supported as a Trackpad including gestures within a Windows guest and within a macOS guest it's treated as a mouse? Parallels Desktop seems to be mainly optimized for virtualizing Windows.
     
  7. JohnA7

    JohnA7 Bit Poster

    Messages:
    2
    Just bumping this to say that Trackpad scrolling is still way too fast when using 10.14 (beta) on Parallels. 13.3.2. I have two trackpads (built in to 2016 MacBook Pro and external Magic Trackpad 2) and it's fine in Windows guest OS, but is recognized as a regular mouse in macOS and even turning the scroll speed setting for the mouse down all the way it is still too fast; it makes it difficult to use the guest OS.

    Thanks!
     
  8. Paya

    Paya Bit Poster

    Messages:
    5
    This still happens in macOS 10.14.1 guest and Parallels 14.0.1 (45154). Scrolling on my macbook touchpad is unusable. Same goes for magic mouse.

    In Windows 10 guest, everything works well.
     
  9. SeanM11

    SeanM11 Bit Poster

    Messages:
    6
    I have the same issue. Thinking of trying a Magic Mouse just to see if it becomes usable.
     
  10. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    2,036
    Have you installed Parallels Tools in guest macOS X?
     
  11. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    2,036
    What is the version of macOS X, Parallels Desktop and the macOS X guest you have?
     
  12. Paya

    Paya Bit Poster

    Messages:
    5
    Yes I have. I have tried magic mouse also, it has the same problem
     
  13. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @Paya, on the Mac it is:
    System Preferences>Accessability>Mouse and Trackpad>Mouse Options:
    Set Scroll Speed to Minimum and Remove the Inertia Settings for Scrolling.
    Also change the settings for the Mouse itself:
    * System Preferences>Mouse:
    * Set Tracking Speed to Slow
    Parallels Desktohavelso has two-step settings. It creates a Virtual Machine on the Mac Drive. In this case for Windows 10, Use the Virtual Machine Settings>Hardware>Mouse & Keyboard: Set Mouse to Auto-Detect for Games, Check to Enable Smooth Scrolling, after that start the virtual machine to check if that works!
     
  14. Paya

    Paya Bit Poster

    Messages:
    5
    I followed your advice to modify the guest macOS. I did:
    • Set scroll speed to minimum in SysPref -> Accessibility -> Mouse and trackpad -> Mouse options
    • Did not remove inertia, since that option is not available. Guest macOS does not seem to have 'trackpad' options in that settings dialog that my host macOS has. There is no inertia option in "Mouse Options..."
    • Set tracking speed to slow in SysPref->Mouse. Scrolling speed is the lowest in that dialog also.
    • In VM settings, hardware, mouse&keyboard, I set mouse to auto-detect for games. There is no option to "enable smooth scrolling"
     
  15. SeanM11

    SeanM11 Bit Poster

    Messages:
    6
    I have Mojave 10.14 for host and guest VM. Parallels 14.0.1.

    I have been really disappointed with Parallels so far.
    1. I can't run docker for Mac in the Mac VM because you can't have a nested hypervisor.
    2. The VM pauses all the time if I do something in an app on the host, and it will not resume.
    3. The scrolling using the Magic Trackpad is insane.
     
  16. SeanM11

    SeanM11 Bit Poster

    Messages:
    6
    I had already tried all of this. Except for the "Remove Inertia"... that setting does not exist. Scrolling is still unusable.
     
  17. SeanM11

    SeanM11 Bit Poster

    Messages:
    6
    Scrolling using the keyboard arrow keys is the only thing that lets me continue to use the VM... until I switch away to the host machine to read an email and come back to find the VM paused... and won't resume. *sigh*
     
  18. Paya

    Paya Bit Poster

    Messages:
    5
    I have the same issue with "won't resume". It turns out if you go to your VM apple menu, system preferences, energy saver and make sure the VM never goes to sleep on battery/power adapter, it won't do that anymore. Apparently Parallels does not seem to support waking up the VM when it goes to sleep. So don't ever press apple menu>Sleep otherwise it won't resume anymore either.
     
  19. SeanM11

    SeanM11 Bit Poster

    Messages:
    6
    Thanks Paya, that definitely works around the can't resume problem. Now if Parallels can solve the scrolling issue... :-/
     
  20. JuanM11

    JuanM11 Bit Poster

    Messages:
    1
    My scrolling in Windows 10 using the trackpad was unusable and unstable, and this fix solved my issue! Thank you!
     

Share This Page