Trackpad scrolling is too fast and frequently uncontrollable...

Discussion in 'Windows Guest OS Discussion' started by viola, Jan 11, 2019.

  1. viola

    viola Kilo Poster

    Messages:
    119
    I use a Magic Trackpad 2 with Parallels and frequently find apps, especially idle games like Star Trek Timelines and such scrolling too fast. Turning OFF "Smooth scrolling" in the "Mouse & Keyboard" options under the VM settings helps it a little to make it more clunky, but it's not enough.

    How can I make scrolling be more natural and like macOS scrolling in Windows 10 guests under Parallels 14?
     
  2. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Hello viola, Kindly start the virtual machine and go to the top menu bar and click on Actions--> Configure--> Hardware--> Mouse & Keyboard and change the mouse to ' Do not optimize for games '. Let us ensure that Parallels Tools are properly installed. Please follow https://bit.ly/2N1mrkW to install Parallels Tools. If you see reinstall or update Parallels Tools then kindly reinstall it.
     
  3. viola

    viola Kilo Poster

    Messages:
    119
    That does seem to scroll vertically better. Not perfect, but it seems to be more controllable. Unfortunately now it seems that HORIZONTAL scrolling is a bit weird. Sometimes it's way too fast and then when the application or game has been running for an extended period of time it slows down to a few pixels per scroll and is infuriating. I have now found too that the mouse is not being recognized in the correct location sometimes - I have to adjust for the location by clicking under things so that I always find that clicking buttons and other elements are shifted up like 10-20 pixels it feels like....

    A good test for this so you can see is in a Steam game called Star Trek Timelines. I think you should have development take a look to see some of these peculiarities.
     
  4. viola

    viola Kilo Poster

    Messages:
    119
    Notice how the cursour dysfunction manifests itself:
    [​IMG]
     
  5. viola

    viola Kilo Poster

    Messages:
    119
    Let me further demonstrate the horizontal scroll with a Trackpad problem with the following screencast. Notice how it inches along again (it starts spontaneously without seemingly any reason) and it will move more rapidly only when I grab the itsy bitsy nearly unclickable horizontal scrollbar:
    [​IMG]
     
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,211
    Hi @viola, could you please provide us with the problem report also? Check this article for more info about report and reply us with the report number. Thanks in advance
     
  7. HermannR2

    HermannR2 Bit Poster

    Messages:
    2
    wann bekommt Parallels endlich die Apple Magic Mouse unter Windows in den Griff?
    Das Arbeiten unter Windows ist eine einzige Katastrophe damit.
    Ich arbeite mit Embarcadero Studio 10.2 - ewig scrollt der Text unkontrolliert hoch oder runter . . . .
     
  8. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,211
    Are you using the latest version of Parallels Desktop? Could you please provide us with more detailed step-by step instruction, and then we will be able to reproduce this issue on our side.
     
  9. UlrichH4

    UlrichH4 Bit Poster

    Messages:
    1
    The same thing I have, also.
    1) Have a Magic Mouse connected to your iMac (or other Macs, also ?)
    2) Start Parallels Win7 or Win10 - both shows that problem very well.
    3) Use any application/program that uses the scroll-feature - here, use a single finger on top of your Magic Mouse and move it up or down on the surface of that mouse.
    4) The ticks per length number is much to high - no smooth moving is possible. Instead the scrolling is by factor 16 or so to high.
    That makes scrolling with the Magic Mouse not useable.
    Often by accident the finger moves a little on the mouse what results to that unexpected behaviour.
    Take SOLID WORKS or Google-Maps or any Browser will behave the same.

    There is no adjustment feature for the "ticks per length" number in Paralles. The Magic Mouse does emit very high tick rates instead of a wheel mouse.

    Does this explanation gives a more clear picture on this problem? Would be nice to use my Magic Mouse on the Paralles hosted environments, also.

    Thanks a lot.
    Uli
     
  10. HermannR2

    HermannR2 Bit Poster

    Messages:
    2
    I use the last version from Parallels.....
    I'm desperately using a separate mouse when I'm working with Windows.
    For me incomprehensible, why not get the most used mouse in an Apple at Parallels under control.
     
  11. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,211
    @HermannR2 @UlrichH4 did you try to change settings in vm configuration: for optimize for games/ don't optimize for games.
    Does it change something?
     
  12. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,211
    We've received your reply:
    no impact...
     
  13. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,211

Share This Page