Windows File Associations Not Working

Discussion in 'Windows Guest OS Discussion' started by joco, Jul 10, 2007.

  1. macguy

    macguy Bit Poster

    Messages:
    51
    I have very little experience with RegEdit. Do I run Regedit or Regedit32 or what? How do I back up the Registry before I do this in case I end up trashing the Registry?
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,440
    Windows 2000 regedit32
    Windows XP and higher regedit
     
  3. macguy

    macguy Bit Poster

    Messages:
    51
    Well, thanks, but with little experience in running regedit, I have no idea how to make these kind of changes, and there is too much chance of really messing up the registry.

    I and the rest of the Parallels community need a better fix than this.
     
  4. Low_Jack

    Low_Jack

    Messages:
    3
    Is there any solution?

    I been reading all post but i think that there is still no solution for this problem?
    Im running Parallels 3 build 5608 and Office 2007 and I can't find a solution.
    What I really want is that at least have my windows working fine without parallels installed. Cause I tried removing parallels and windows still works bad! Please anyone can help me with the auto_files ?!?
    Thanks
     
  5. geeves

    geeves

    Messages:
    3
    pdf_auto_file confirmed as problem

    I to was pleased to find this thread. This is indeed unique to parallels initial account.

    On making a new user account the content-type association problem became resolved.

    I can now deliver to IE or firefox pdf files which then get opened immediately in acrobat reader 8.1

    Cheers
     
  6. John@Parallels

    John@Parallels

    Messages:
    6,440
    with PDF
    open regedit go to HKCR\ and delete .pdf hive.
    Then right click on pdf and select open with, select Adobe acrobat, this will create new .pdf hive
    Or delete .pdf hive and resinstall Adobe reader
     
  7. Low_Jack

    Low_Jack

    Messages:
    3
    And what about microsoft office associations?

    I see that the pdf association problem y solved. But I need help on solving the problem with microsoft office associations. Is there any solution to solve de auto_file problem?
    Thank you very much
     
  8. John@Parallels

    John@Parallels

    Messages:
    6,440
    Basically you can perform the same steps with docx,doc, ppt,pptx,exl, exlx
     
  9. Low_Jack

    Low_Jack

    Messages:
    3
    Thanks!

    I have already solved my problem! Thank u very much for your help!
     
  10. BeaverGeek

    BeaverGeek

    Messages:
    5
    John,

    Will your instructions work for PDfM 4.0? I'm having this same problem as of today. I have updated to 4.0.3540 as of today; fresh install of Windows XP SP3 (not an upgrade). I have just installed the latest Adobe Acrobat 9.0 and Microsoft Word 2007. File assocations for .docx and .pdf are not working: for their respective file types shown in Windows Explorer there is no icon and the file says "docx_auto_file" or "pdf_auto_file".

    Thanks...
     
  11. BeaverGeek

    BeaverGeek

    Messages:
    5
    It appears that only programs that have a conflict between Mac and Windows are having problems with file assocations. For example, OneNote 2007 icons are properly displayed on all of my OneNote files in Windows. There is no Mac-equivalent to OneNote so there is no conflict. For my PDF and DOCX files however, both of these files could be opened in Mac OR Windows XP Pro SP3: the .DOCX file with Office 2008 for Mac OR Microsoft Office 2007 (WINXP). Likewise the PDF file could be opened in Mac OS X via Preview, or in Windows via Adobe Reader 9. So there is definitely something buggy going on with the SmartSelect option. I'm going to disable SmartSelect and try and reinstall Adobe Reader to see if that has any affect.
     
  12. gpercy

    gpercy

    Messages:
    2
    I am having a similar problem with 4.0.3540. While trying to open files from within Windows XP, file associations for .xlsx and .pdf are not working, both have a generic icon with "xlsx_auto_file" or "pdf_auto_file". After getting the error message "Windows can not open this file", I choose "Select the program from a list", but Microsoft Office Excel 2007 is not in the list to choose from. Instead, Excel from Microsoft Office 2008 (Mac) is the only Excel available, even though I have Shared Applications turned off.

    My configuration settings for the virtual machine are:

    Shared Folders/Share Mac OS X folders... OFF
    Shared Folders/User-defined Mac OS X folder (one folder defined)

    Shared Profile/Shared Profile... OFF

    Shared Applications/Windows applications/Share Windows applications... OFF
    Shared Applications/Mac OS X applications/Share Mac OS X applications... OFF

    I never experienced this problem with PDFM 3.x, even though I was using the same configuration and applications within Windows XP.

    Will this problem be fixed in a future update?

    Thanks,
    Gerry
     
    Last edited: Dec 22, 2008
  13. John@Parallels

    John@Parallels

    Messages:
    6,440
    Please open it once from within Windows and associate with Excel 2007, the same for pdf - Adobe or other software you want to use
     
  14. Juan

    Juan

    Messages:
    2
    Major Problem

    I don't know what has been posted for Parallels 4.0 but I have the same issue.

    I installed Windows Server 2008
    I have Parallel 4.0 (build 4.0.3810)
    I have the same file association issues with Office 2007 enterprise.

    This was not an issue until I upgraded to 4.0 this was a parallel that I upgraded from 3.0 to 4.0. I initially crated it in 3.0. Once I upgraded I installed office 2007 and all my file associations don't work.

    this is no minor issue that can be fixed with right clicking and opening with 'always' with office word or excel. It really appears as if Office is not installed.

    Let me put it this way, I love Mac and I am a Microsoft SharePoint consultant. SharePoint needs office and requires for it to be installed so that applications open properly and integrate properly. I cannot use this Parallel until this is fixed, i cannot do work, I cannot do demos, NOTHING until this is fixed, So when I go to demonstration I will fire up bootcamp and work under the same conditions with Win2008 and office and SharePoint and do away with Parallels.

    This bug has made Parallels completely useless for me. I have installed and uninstalled, and repaired office 2007 and no luck, Creating a new Parallel from the ground up, is not practical here, I have install not just the OS and Office but all my development tools , this will take a week to do and this is time I can be using to prepare presentations and do my work,
    Thanks a lot Parallel's!!!

    Juan
     
  15. John@Parallels

    John@Parallels

    Messages:
    6,440
    Could you please uninstall Parallels Tools and perform Office repair,?
    and reinstall Tools again?
     
  16. kevinherring

    kevinherring

    Messages:
    12
    John,
    Although you have been very helpful with this problem, Parallels STILL haven't come up with a real solution to this, which amazes me! The solutions you have come up with are merely work-arounds. And it still happens in version 4 as well!

    I have just been bitten by this bug again as I had to reinstall my Bootcamp partition. When I loaded it up in Parallels, I forgot to turn off application sharing and all my file associations were changed. Instead of wasting time on registry changes etc, the only way to PROPERLY fix it suggested so far is:
    1. Turn off application sharing in Parallels.
    2. Create a new user account in your Windows VM.
    3. Delete the old user account.

    Fortunately it is a fresh install, so I don't have much in the way of user settings. If I did, this would be a pain in the ass.

    Please please please come up with a SOLUTION to this problem!
    Kevin

    p.s. I always forget that I can't post replies using Opera. There is no Submit button! Also very annoying.
     
  17. >>> Message has been deleted by the user <<<
     
  18. Michael Kono

    Michael Kono

    Messages:
    2
    I have just downloaded trial of Parallels for Mac 4.0 and have been going nuts over fact that I can't get Windows XP Java Web Launcher to install in guest XP to launch .jnlp files. Parallels insists on overriding with Mac Java Web launcher. Looks like the bug that got reported wrt file association for applications in April 2006 is still there in v4.0 in April 2009!
     
  19. >>> Message has been deleted by the user <<<
     
  20. Ryan Marsh

    Ryan Marsh

    Messages:
    5
    Thanks guys

    Just switched back to Parallels after a year of using VMWare Fusion and I got hit with this bug right out the gates. Awesome guys. Thanks. Its been over a year and this still isn't fixed?

    Host: Mac OSX 10.5.6
    Guest: Windows XP SP3 (Fresh install)
    Guest Apps: Office 2007, SQL Server 2005 tools, Notepad++
    Parallels 4.0.3810
     

Share This Page