Windows ARM64 - seems to boot up

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by DanO3, Dec 17, 2020.

  1. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    Hello,

    I am using Parallels 17 with Windows 11 Dev on Apple M1.

    Here are a couple of questions I was wondering about, in case anybody wants to comment, greatly appreciated.

    1. In official parallels documents, it is mentioned that it is not recommended to move/clone a VM that uses vTPM. Why? Simply because it requires additional steps to handle, or is there another reason?
    2. I often backup a full vTPM-VM file to an external harddrive. Let's assume my Mac SSD crashes and I want to use the copied VM from the external drive on a new MacBook. Is it correct that by following the steps described under https://kb.parallels.com/en/122702 , I will have all the means to be able to run the vTPM on the New Mac (assuming it's the same type of MacBook)?
    3. I am currently on Dev Channel. At the moment, Dev and Beta Channel are identical builds and it is possible to move to Beta. However, Beta has additional requirements: https://blogs.windows.com/windows-i...ing-for-insider-preview-builds-of-windows-11/ (I recommend you read the table!! ) Has anybody switched to Beta Channel, and did it work? What about CPU type requirements for Beta? Is it correct that one can always switch back to Dev channel from the Beta channel?
    4. Currently I am having issues (in WIndows full screen, game mode) switching to windows because I simply see the background of the sign in screen with no possibility to interact, I have to go to Parallels menu and to press ctrl alt del to get into windows.
     
  2. Rick056

    Rick056 Junior Member

    Messages:
    17
    Does anyone know what happened or where I can download (legit links) Windows 10 ARM? All the links referenced only go to Windows 11 ARM now with no reference to Windows 10 ARM on the page. I am and have been Insider previously so it's got nothing to do with not having access. I was able to download Windows 11 ARM but I want Windows 10. Help appreciated. Just checking our Parallels 17 for specific reason to run Windows TEN on my M1. Thanks.
     
  3. ChristopherY1

    ChristopherY1 Bit poster

    Messages:
    1
    So do you need to buy a license to use the ARM Version of Windows? Also if I try to down load a game the Microsoft store it seems to just freeze and not allow the download. if this because the license isnt recognized?
     
  4. RalphB6

    RalphB6 Bit poster

    Messages:
    3
    So far so good. On a M1 MacBook Pro running Parallels 17 with Windows Insider program and Windows 10 build that just migrated to Windows 11 ARM via the Beta Channel. I was on the Dev Channel but did not see any updates. Once I switched to Beta I started seeing updates. Runs smooth for web browsing, YouTube, and MS Office products.
    Device name MACBOOKPROM1
    Processor Apple Silicon 3.20 GHz (4 processors)
    Installed RAM 6.00 GB
    Device ID DF8E5EB9-CF5A-xxxx-xxxx-33D0458C1087
    Product ID 00330-80000-00000-AA274
    System type 64-bit operating system, ARM-based processor
    Pen and touch Pen support
    ----
    Edition Windows 11 Pro
    Version 21H2
    Installed on ‎9/‎14/‎2021
    OS build 22000.184
    Experience Windows Feature Experience Pack 1000.22000.184.0
     

    Attached Files:

  5. RonM9

    RonM9 Bit poster

    Messages:
    7
    Is anyone else having serious problems with this? Whenever I start using Windows 11 for a few minutes, then no buttons will work, and content is not appearing in Edge. Something is seriously wrong, and I have reinstalled Windows 11 twice now.
     
    LeventY1, Lucas Farina and JimmyZ1 like this.
  6. JimmyZ1

    JimmyZ1 Bit poster

    Messages:
    4
    I had this issue. This happens after you install the update. If you install the clean windows, and do not allow it to update, everything is fine. Hoping for a solution soon.
     
    LeventY1 likes this.
  7. RonM9

    RonM9 Bit poster

    Messages:
    7
    Thanks! I'm glad it's not just me. I thought I was going crazy.

    Apparently, we need to get out of the Dev channel and move to the Beta channel, but they seems impossible.
     
  8. Lucas Farina

    Lucas Farina Bit poster

    Messages:
    2
    I'm too, very sad =/
     
  9. SWANDY

    SWANDY Pro

    Messages:
    315
    I have had a similar issue where buttons (like the ones to power off in settings) don't respond as quickly as I would expect. Have had it for a while - nothing in my case related to Windows updates, which I was getting from the Insider Program and since quiting the insider program and finally getting around to activating my Windows 11 PRO ARM installation. Only issue with Edge is that it occasionally seems slower than I remember running Windows 10 under Bootcamp, but that is expected running Windows under Bootcamp vs Parallels in my experience.
     
  10. JimmyZ1

    JimmyZ1 Bit poster

    Messages:
    4
    How were you able to quit the insider program and get into the release branch of the windows 11 ARM from the dev branch (which is what the insider program gives you)?
     
  11. JimmyZ1

    JimmyZ1 Bit poster

    Messages:
    4
    I tried to create an ISO from the uupdump.net sources, but got an error. Any help?
     

    Attached Files:

  12. Lucas Farina

    Lucas Farina Bit poster

    Messages:
    2
    The build 22483 released on 20 October seems to have solved the problem
     
  13. KevinW27

    KevinW27 Bit poster

    Messages:
    3
    With the 22483 build I can't use the start menu or the settings app in the windows 11 arm vm. I feel so dumb. I was installing Parallels and the Windows Insider exactly as intended but the settings does not open, the Windows start menu does not open and I can't search anything. What the hell am I doing wrong? Can someone explain what settings I have to change.
     
  14. KevinW27

    KevinW27 Bit poster

    Messages:
    3
    Thanks. I used an uupdump. Now everything works. :)
     
    MikeS39 likes this.
  15. DebasmitaM

    DebasmitaM Forum Maven

    Messages:
    1,142
    Hello, thank you for sharing the knowledge. Parallels Team.
     
  16. DebasmitaM

    DebasmitaM Forum Maven

    Messages:
    1,142
    Hello, we are happy to hear that your issue has been resolved. Please reach us back fir any further queries. Thanks, Parallels Team.
     
  17. RobB11

    RobB11 Bit poster

    Messages:
    4
    I'm having the same issue where many of the buttons don't work, and I am unable to click on settings. Does anyone have a tutorial on how to build an iso on uupdump? Does the iso have to be built on a PC and then brought over to the Mac?
     
  18. pp_4

    pp_4 Bit poster

    Messages:
    3
    Ok I had the same problem as you. Here is how I solved it:

    Disable searchindexer.exe from the services tab. Watch everything start working like magic!!!
     
  19. peyrolles

    peyrolles Bit poster

    Messages:
    5
    How do you disable searchindexer.exe?
     
  20. pp_4

    pp_4 Bit poster

    Messages:
    3
    upload_2021-10-29_11-7-3.png

    This is from Windows 10 that does not have searchIndexer but it will be something like this. Just disable it and you should be fine after.
     

Share This Page